Alt + F7 shortcut does not work on Lubuntu

Bug #1313352 reported by André Campos Rodovalho
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Bad configuration on ~/.config/openbox/lubuntu-rc.xml file is causing the shortcut not to work. The entire original entry is:

    <keybind key="C-F7">
      <action name="Execute">
        <command>sleep 2;xset dpms force off</command>
      </action>
    </keybind>

Removing "sleep 2;" part of the command tag makes the shortcut to work property.
I tested this on different machines, restarting openbox, I tested on different installations, both fresh install...

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: openbox 3.5.2-6
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: LXDE
Date: Sun Apr 27 10:39:24 2014
InstallationDate: Installed on 2014-04-27 (0 days ago)
InstallationMedia: Lubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
SourcePackage: openbox
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
André Campos Rodovalho (andre-rodovalho) wrote :
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openbox (Ubuntu):
status: New → Confirmed
Revision history for this message
Lyn Perrine (walterorlin) wrote :

This bug also affects me on an upgrade from 13.10.

affects: openbox (Ubuntu) → lubuntu-default-settings (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.40

---------------
lubuntu-default-settings (0.40) utopic; urgency=medium

  [ Julien Lavergne ]
  * usr/share/xsessions/QLubuntu.desktop
   - Use LXQt as environment for the Qt session.
  * debian/control:
   - Depends on xbacklight to make some shortcuts workings (LP: #1313358)
  * usr/share/lubuntu/openbox/*rc.xml
   - Fix C-F7 shortcut (LP: #1313352)
   - Fix launcher shortcuts (LP: #1313355)
  * etc/xdg/lxsession/*/desktop.conf
   - Use Lubuntu of the icons theme.

  [ Unit 193 ]
  * Move etc/ and usr/ under src/
  * Update debhelper compat to level 9.
  * Update standards-version to 3.9.5.
  * qlubuntu-default-session: Alternatively depend on lxqt-lightdm-greeter.
  * d/copyright: Update to copyright format 1.0, update copyright years.
  * d/copyright: Set Julien Lavergne as Upstream-Contact.
  * d/maintscript: Move lightdm config to usr/share, this follows standard
    lightdm config such that the file is removed when the package is.
  * Move d/20-*.conf to src/usr/share/lightdm/lightdm.conf.d/
  * d/rules: Call dh_install with --fail-missing.
  * 20-qlubuntu.conf: The session name is QLubuntu, not qlubuntu.
 -- Julien Lavergne <email address hidden> Wed, 20 Aug 2014 21:49:00 +0200

Changed in lubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers