xfce4-power-manager is not running by default with Lubuntu 13.10

Bug #1242452 reported by amjjawad  on 2013-10-20
154
This bug affects 31 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Medium
Unassigned

Bug Description

This is very basic and simple, yet very important feature that should be loaded by default. Until a week or so before the final release of Saucy, everything was fine but then, suddenly, I noticed the Power Manager is not running when I start my machine and login to Lubuntu and it seems this is a last minute change.

If I go to Menu > Preferences > Power Manager, I get this message:

"Xfce4 Power Manager is not running, do you want to launch it now?"

Please note that I am not converting people in Real Life to Linux. People who have been using Windows XP for their entire life. If this bug will remain for a long time, I will have hard time and that will never make them happy which means I have to find another alternative for Lubuntu.

This is on both i386 and amd64 - Lubuntu 13.10

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xfce4-power-manager 1.2.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic i686
ApportVersion: 2.12.5-0ubuntu2
Architecture: i386
Date: Mon Oct 21 01:53:31 2013
InstallationDate: Installed on 2013-10-17 (3 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
MarkForUpload: True
SourcePackage: xfce4-power-manager
UpgradeStatus: No upgrade log present (probably fresh install)

amjjawad  (amjjawad) wrote :
amjjawad  (amjjawad) wrote :

On Facebook Group, this workaround has been posted:

Menu > Preferences > default application for LXsession > Power Manager > Other > xfce4-power-manager > Apply > Reboot.

HOWEVER, please note that this is not enough and this feature should be loaded by default, just like it used to be.

I can't ask Windows Users who just started to use Linux (Lubuntu) to do that :)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-power-manager (Ubuntu):
status: New → Confirmed
affects: xfce4-power-manager (Ubuntu) → lubuntu-default-settings (Ubuntu)
Changed in lubuntu-default-settings (Ubuntu):
status: Confirmed → New
Changed in lubuntu-default-settings (Ubuntu):
status: New → Confirmed
emptythevoid (emptythevoid) wrote :

I also experienced this problem on upgrade from 13.04 to 13.10, and the above work-around fixed it. I also had a problem where xscreensaver wasn't working either (wouldn't ask for a password after waking from suspend), and I had to set xscreensaver as the default screensaver, too.

amjjawad  (amjjawad) wrote :

@emptythevoid

Lubuntu 13.10 has no xscreensaver by default, unless you have installed it? that is different story :)

Federico Leoni (effelle-gmail) wrote :

Another solution is to open Preferences --> Default applications for LXSession, then go to the autostart tab and here change the option "Disable autostarted applications" from the default "config-only" to "no". You may need to change the settings for laptop-mode from "no"to "yes". (settings tab).

Note that you need to disable "network" from Prefereces-->Desktop Session Settings or you will have two nm-applet running at the same 1time.

I think the new default application manager introduced on 13.10 is a bit confusing but if it is the new way of configuring session isn't
better to trow out the "classic" Desktop session Settings entry on menu?

John Hupp (john.hupp) wrote :

I was troubleshooting another Autostart problem (with SpiderOak online backup) and was looking for Preferences-->Desktop Session Settings, but find that it is not present.

My current assumption is that Preferences-->Default Applications for LXSession somehow incorporates and replaces Desktop Session Settings, but I have not figured out how to use it for that purpose yet.

Or its absence is also a bug.

This machine has a fresh full install of Saucy. Federico, did you *upgrade* to Saucy and perhaps thereby preserve Desktop Session Settings?

N1ck 7h0m4d4k15 (nicktux) wrote :

This is something that Lubuntu devs should check about.

By default xfce4-power-manager has a .desktop startup file inside /etc/xdg/autostart .

Lubuntu 13.10 and newer versions are not reading this folder for autostart applications, so a user should add the xcfe4-power-manager command in .config/lxsession/Lubuntu/autostart file if he/she wants the power-manager to start properly.

I think that Lubntu devs should think about and create this file and add it to .config/lxsession/Lubuntu/autostart by default.

Regards
 NikTh

amjjawad  (amjjawad) wrote :

32 days now or so and there is no real action on this bug but I guess sooner or later, the Developers will pay attention to this one because, IMHO, this one is important and shouldn't be ignored or treated as Low Priority but that is just my opinion and after all, I am not a Dev :)

TArpi (teksearpi) wrote :

Folks!

Nowadays, I think laptops, and notebooks are the hw's on which Lubuntu is installed, at least my case is that. :).
So I think this is a bug and should treated with high priority.

Thanks!
TArpi

Daniel Kessel (dkessel) wrote :

I totally to agree with amjjawad and TArpi. This should be a high priority bug, especially for the LTS release.

Laptop users cannot see their battery state without this, I believe.

Changed in lubuntu-default-settings (Ubuntu):
importance: Undecided → Medium
amjjawad  (amjjawad) on 2014-03-01
tags: added: trusty
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1242452

tags: added: iso-testing

bug applies to lubuntu 14.04 too.

still alive at today's image. see ubuntu-bug report attached, please.

ubuntu-bug report

Julien Lavergne (gilir) wrote :

Could you install laptop-detect package, logout, login and see if it's working ? (be sure to have power manager in lxsession-default-apps set to auto).

Pjotr12345 (computertip) wrote :

No success.... I installed laptop-detect, logged out and in again, but no change. Then I did a full reboot, again with no success.

amjjawad  (amjjawad) wrote :

Lubuntu 14.04 LTS i386 Fresh New Installation and I confirm that 'xfce4-power-manager' is running by default now.

Thank you!

It appears that the bug report (Bug #1326045I just filed for Lubuntu 14.04 LTS Desktop AMD64 has the same issue.
The matter has not really been resolved, and Lubuntu 14.04 LTS has it.

Kevin Brace

Sorry for the typo on Comment #20.
It appears that the bug report (Bug #1326045) I just filed for Lubuntu 14.04 LTS Desktop AMD64 has the same issue.
The matter has not really been resolved, and Lubuntu 14.04 LTS still has the issue.

Kevin Brace

Cedric M (cedric780) wrote :

I have a similar problem on Ubunto 14.04 LTS where I installed XFCE :
Launching the Power manager does nothing then after a few seconds a dialog display:

"Unable to get configuration information from xfce power manager: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

Launching "xfce4-power-manager-settings" has the same result.
Launching "sudo xfce4-power-manager-settings" asks me "Xfce4 Power Manager is not running, do you want to launch it now?"

Özgür (ozgurkinaci) wrote :

Hi,

I have found this
http://askubuntu.com/questions/129671/how-can-i-workaround-the-xfce4-power-manager-being-broken

It does not solve the main problem, but it looks like a workaround.

Özgür

John Hupp (john.hupp) wrote :

In Lubuntu 13.10 the primary cause for this not running was an lxsession bug (https://bugs.launchpad.net/ubuntu/+source/lxsession/+bug/1309698) that preventing anything from auto-starting from /etc/xdg/autostart (where Power Manager is set to launch from).

That bug was fixed in Lubuntu 14.04.1, so the other shortcuts began functioning once again (things like the Network Manager applet, nm-applet).

But xfce4-power-manager continued to fail, and this is because of a line in the shortcut:
OnlyShowIn=XFCE;

Comment out that line and the shortcut will work!

John Hupp (john.hupp) wrote :

Following up on my own comment, I do note that on a laptop I just checked (also running Lubuntu 14.04.1), 'OnlyShowIn=XFCE' is present but power manager starts anyway.

The only speculation I have about why power manager works on the laptop and not on the desktop is that somewhere (in the lxsession settings perhaps) there is a profile setting for desktop vs laptop, which may influence the outcome here.

ofb (cottlestonpie) wrote :

14.04.03 LTS still has this bug: xfce power manager is not running by default.

I used the second workaround here
http://ubuntuforums.org/showthread.php?t=1392692&p=8753382#post8753382

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers