Keybind to lock screen still using removed xscreensaver-command

Bug #1204052 reported by Jonas Zoner on 2013-07-23
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
lubuntu-default-settings (Ubuntu)
Undecided
Julien Lavergne

Bug Description

The keybind to lock the screen (crtl+alt+l) in the openbox default configuration file is still using the obsolete (and removed) xscreensaver-command.

File:
/usr/share/lubuntu/openbox/rc.xml

Relevant part:
<keybind key="C-A-l">
      <action name="Execute">
        <command>xscreensaver-command -lock</command>
      </action>

Expected behavior:
using lightdm to lock the screen.

Occuring behaviour:
Error message (No such file or directory) since xscreensaver is not included anymore.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: lubuntu-default-settings 0.32
ProcVersionSignature: Ubuntu 3.10.0-4.13-generic 3.10.1
Uname: Linux 3.10.0-4-generic i686
ApportVersion: 2.11-0ubuntu1
Architecture: i386
Date: Tue Jul 23 12:10:47 2013
InstallationDate: Installed on 2013-07-22 (0 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130721)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: lubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.xdg.lubuntu.lxdm.lxdm.conf: [modified]
mtime.conffile..etc.xdg.lubuntu.lxdm.lxdm.conf: 2013-07-22T22:04:54.575891

Jonas Zoner (jonaszoner) wrote :
Jonas Zoner (jonaszoner) wrote :

After a little research I was able to fix this myself:
<!-- Lock the screen on Ctrl + Alt + l-->
    <keybind key="C-A-l">
      <action name="Execute">
        <command>lxlock</command>
      </action>
    </keybind>

The attachment "patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Jonas Zoner (jonaszoner) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-default-settings (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1204052

tags: added: iso-testing
Julien Lavergne (gilir) on 2013-07-25
Changed in lubuntu-default-settings (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.33

---------------
lubuntu-default-settings (0.33) saucy; urgency=low

  * usr/share/lxpanel/Lubuntu
   - Enable xkb plugin by default for switching keyboard layout.
  * usr/share/lubuntu/openbox
   - Fix transmission menu item (LP: #1193055)
  * etc/xdg/lxsession/QLubuntu/desktop.conf
   - Fix launch of razor-panel
  * etc/xdg/lubuntu/lightdm/lightdm-gtk-greeter.conf
   - Update with new upstream version.
  * /usr/share/lubuntu/openbox/*rc.xml
   - lxsession-default lock instead of xscreensaver (LP: #1204052)
  * etc/xdg/lxsession/*/conffiles.conf
   - Fix terminal conffiles.
 -- Julien Lavergne <email address hidden> Thu, 29 Aug 2013 00:20:19 +0200

Changed in lubuntu-default-settings (Ubuntu):
status: In Progress → Fix Released

thix bux not fixed .
file not changed.
please re-patch it .

# version
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Saucy Salamander (development branch)
Release: 13.10
Codename: saucy

# Desktop Session
$ echo $DESKTOP_SESSION
Lubuntu

# version of package
$ aptitude versions lubuntu-default-settings
Package lubuntu-default-settings:
i 0.34 saucy 500

# source file
$ sed -n 420,425p usr/share/lubuntu/openbox/rc.xml
    <!-- Lock the screen on Ctrl + Alt + l-->
    <keybind key="C-A-l">
      <action name="Execute">
        <command>xscreensaver-command -lock</command>
      </action>
    </keybind>

Thank You

gilir,

sorry but this bug is still alive.

once i cannot reopen this bug, i opened another at Bug #1241901

best regards,
ibere

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers