Default theme "Lubuntu-default" is too much CPU intensive

Bug #878958 reported by Gionatan Danti on 2011-10-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
Medium
Julien Lavergne
Oneiric
Undecided
Unassigned
Precise
Medium
Julien Lavergne

Bug Description

SRU explanation:
[Impact]: This bug impact performance on default installaion of Lubuntu, on some configurations
[Development Fix]: This bug was fixed in 0.19 version of lubuntu-artwork, by disabling inset on theme configuration
[Stable Fix]: Same fix than the development fix can by apply (see http://launchpadlibrarian.net/83896618/lubuntu-artwork_0.18_0.19.diff.gz)
[Test Case] From the original report :
a) open a window with some text (eg: obconf -> appearance)
b) open a terminal window and run top
c) open another window and keep moving it over the previous one
d) read, from top, the cpu usage: it will at be near 100% for one core
[Regression Potential] : Minimal, eventually some graphical difference in some cases, but the tests doesn't show any visual differences

Original report :
This (very nice!) default theme use, for many widgets, the "inset" text rendering mode from murrina engine. While beautiful, this "engraved" text rendering effect cause a very high CPU load when a moving window overlaps another one, static window. This results in the overlapped window issuing many expose events that can not be served in time, so a grey trail is visible behind the moving window.

Steps to reproduce this:
a) open a window with some text (eg: obconf -> appearance)
b) open a terminal window and run top
c) open another window and keep moving it over the previous one
d) read, from top, the cpu usage: it will at be near 100% for one core (my machine has an i5-520 CPU @ 2.4 GHz)

Possibile solutions:
a) enable X-based when-mapped backing store
b) use compiz (or other gl-based wm) as window manager
c) simply disable "inset" text rendering or change default theme

Solutions a) and b) have their problems and controindications (especially for a resource-contrained distribution as Lubuntu).
Solution c) is the most obvious: simply disable inset text rendering and CPU usage decrease significantly.

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lubuntu-artwork 0.18
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Thu Oct 20 18:31:43 2011
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: lubuntu-artwork
UpgradeStatus: No upgrade log present (probably fresh install)

Gionatan Danti (shodanshok) wrote :
Julien Lavergne (gilir) wrote :

Thanks for your bug report. I tried on my system, but i didn't see any difference with or without this modification. I'll publish a package so people can also test if it's improving the performances.

Changed in lubuntu-artwork (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Julien Lavergne (gilir)
Gionatan Danti (shodanshok) wrote :

Hi, thank you for your support.

I tried on a older PC also (P4-based Celeron 2.0 GHz + integrated i845 graphics) and the problem is much more pronounced: moving a window over another one cause the bottom window to be almost fully greyed. Removing the "inset" text-rendering propriety significantly reduce the problem, and using a simpler theme (eg: Clearlooks, Mist, etc.) result in a even less pronounced gray trail (and lower CPU usage).

Thanks.

Julien Lavergne (gilir) wrote :

I uploaded a modified version of the theme in this PPA : https://launchpad.net/~lubuntu-dev/+archive/staging . It should be available soon.
Let me know if you see any improvements with it.

Gionatan Danti (shodanshok) wrote :

Hi, I can confirm that with your package the high CPU load and the associated gray trail have gone. Now the theme looks only a little heavier then a "normal" murrina-based one.

Another, minor problem is the fact that murrina is quite challenging per-se, as other themes (eg: Clearlooks, Mist, etc.) are significantly less CPU-intensive ones; however, murrina looks great...

Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.19

---------------
lubuntu-artwork (0.19) precise; urgency=low

  * usr/share/themes/Lubuntu-default/
   - Disable inset text style, to reduce CPU usage (LP: #878958)
 -- Julien Lavergne <email address hidden> Fri, 28 Oct 2011 13:39:35 +0200

Changed in lubuntu-artwork (Ubuntu Precise):
status: In Progress → Fix Released
Julien Lavergne (gilir) on 2011-10-28
description: updated

Hello Gionatan, or anyone else affected,

Accepted lubuntu-artwork into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in lubuntu-artwork (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
frenchy82 (cartes) wrote :

Hi,

I've tried it on my old laptop in oneiric 386, and the result is very better with this package

All the system seems to be most reactive f(in my opinion)

Martin Pitt (pitti) on 2011-12-17
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.18.1

---------------
lubuntu-artwork (0.18.1) oneiric-proposed; urgency=low

  * usr/share/themes/Lubuntu-default/
   - Disable inset text style, to reduce CPU usage (LP: #878958)
 -- Julien Lavergne <email address hidden> Fri, 28 Oct 2011 13:47:08 +0200

Changed in lubuntu-artwork (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers