Dropbox applet icon is too small

Bug #878121 reported by Alexander Andjelkovic on 2011-10-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Lubuntu Artwork
Fix Released
Undecided
Alexander Andjelkovic
lubuntu-artwork (Ubuntu)
Undecided
Julien Lavergne
lxpanel (Ubuntu)
Undecided
Unassigned

Bug Description

The icon used for the Dropbox applet is too small.

Julien Lavergne (gilir) wrote :

Thanks for your bug report. Could you provide a screenshot of this ? Is it reproductible with another icons theme ?

affects: lxpanel (Ubuntu) → ubuntu
affects: ubuntu → lxpanel (Ubuntu)
Changed in lxpanel (Ubuntu):
status: New → Invalid

It seems to be icon theme related, since it seems to apply to Transmission as well.
I have not tried another icon theme, but I have included a screenshot.
The problem is purely cosmetic.

Redwolf (viking.redwolf) wrote :

I'm not sure, but I think that's the original Dropbox from inside the DEB. It was adapted for Unity and Ambiance / Radiance themes, so it may be a "bug" for Dropbox itslef.

And just one note, cosmethic bugs are BUGS. I know, I'm graphic, but they are all important. Usability is in danger when look'n'feel is bad. So, well done, Alex, for noticing this bug.

This has to do with LXpanel, it does not handle svg-files correctly.
22x22 svg-icons get scaled down, probably to 16x16.
Please try replacing a 22x22 svg-icon with a 22x22 png-icon and you will see the difference.

Please note:

I could not reproduce my work-around by placing png-icons inside /usr/share/icons/elementary-mono-dark/*.

However... Placing svg-icons inside /usr/share/icons/lubuntu/* , DOES NOT solve the issue, they have to be png for it to work.

Changed in lubuntu-artwork (Ubuntu):
assignee: nobody → Alexander Andjelkovic (frankbooth)
Changed in lubuntu-artwork (Ubuntu):
status: New → Invalid
Changed in lubuntu-artwork (Ubuntu):
status: Invalid → In Progress

Bug is Dropbox related, but has a workaround...

For some reason Dropbox is force using 16px panel icons. By placing .png's with desired size in your icon themes .../panel/16/.

Please note that .svg icons won't give you the desired result.

Changed in lubuntu-artwork (Ubuntu):
status: In Progress → Fix Committed
Julien Lavergne (gilir) on 2012-10-10
Changed in lubuntu-artwork:
status: New → Fix Committed
assignee: nobody → Alexander Andjelkovic (frankbooth)
Changed in lubuntu-artwork (Ubuntu):
status: Fix Committed → Confirmed
assignee: Alexander Andjelkovic (frankbooth) → nobody
Julien Lavergne (gilir) on 2012-11-23
Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.35

---------------
lubuntu-artwork (0.35) raring; urgency=low

  * Backup current artwork items to 1210 items, and prepare 1304.
  * Update icon theme:
   - Fix dropbox icon (LP: #878121).
  * Update gtk3 theme:
   - Fix black tooltips (LP: #1065941).
  * debian/control:
   - Depends also on gtk2-engines-pixbuf along with gtk2-engines.
 -- Julien Lavergne <email address hidden> Fri, 23 Nov 2012 18:47:42 +0100

Changed in lubuntu-artwork (Ubuntu):
status: In Progress → Fix Released
Changed in lubuntu-artwork:
status: Fix Committed → Fix Released
James0r (james-auble2) wrote :

Issue affects me. Using Linux Mint 17 Xfce. The workaround in post #6 fixed the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers