CPU increase when using lxtask + 11.04 gtk theme

Bug #776776 reported by Julien Lavergne on 2011-05-03
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
High
Julien Lavergne
Natty
Undecided
Unassigned

Bug Description

Binary package hint: lubuntu-artwork

SRU :
1. This bug impact all Lubuntu users using the theme by default, increasing the CPU usage for all applications. It's more visible on limited hardware, which is the target of Lubuntu.
2. This bug was fixed on 0.15 version of lubuntu-artwork. The animation setting was turn off (it's also the case for Ubuntu theme).
3. The patch is available on bzr branch of lubuntu-artwork for Natty (http://bazaar.launchpad.net/~lubuntu-desktop/+junk/lubuntu-artwork-natty/revision/92)
4. You can reproduce the bug by launching lxtask. You should have an increase of the CPU usage on Xorg and on lxtask itself.
5. The only regression I'm aware is the removal of animation of the progress bar. But as Ubuntu don't use this type of settings, I think it's quite safe to turning it off. I also used it during a week, without any problems.

I noticed an increase of the CPU usage when using lxtask, and the new gtk theme is Lubuntu 11.04. There is ~ + 20 % of CPU usage between the old gtk theme and the new one, using a 1 Ghz CPU. I still don't know if it's the theme itself, or the use of murrine + cairo on my machine which is problematic.

Using a eeePC 701, Intel driver.

Redwolf (viking.redwolf) wrote :

I don't really know (for now). But using a task / process manager increases the CPU usage a lot, because of the continuous scanning of threads in RAM. Try gnome-system-monitor and you'll see your CPU usage increasing up to 100%. If problem persists without using monitors the it's another problem. The theme was tested (a lot) for checking its resources hungry and it must be as fast as any other Cairo based theme (like Elementary or Deepin).

Anyway I'll keep it an eye.

Julien Lavergne (gilir) wrote :

It's not a problem of using a taskmanager, because I used it in both tests :

With lxdesign + taskmanager running : 60 % CPU usage
With ozone + taskmanager running : 80 ~ 90 % CPU usage

You can try by running lxtask, and switching the gtk theme from one to the other. You will see the change in CPU usage.

Redwolf (viking.redwolf) wrote :

I don't really how to measure this. But I've tested (with two terminals) that my system uses near 2% CPU when iddle, and lxtask adds up to 8% more. But I think it's normal. I can't reproduce your settings.

Redwolf (viking.redwolf) wrote :
Julien Lavergne (gilir) wrote :

No, the problem is not with lxtask. Try to switch to LxDesign theme and watch your CPU usage.

Anyway, I think I found the problem. If I remove line 131 :
animation = TRUE

my CPU usage is back to normal, like the previous gtk theme. Except the animation on the progress bar, I don't know what animations are removed by this. Do you know the consequence of this removal ?

Redwolf (viking.redwolf) wrote :

I think this only affect progress bars. But I've noticed Fedora 15 and 16 have a problem with this. Murrine is being compiled bad with this option (maybe a bug in Murrine). We need to test it with other Murrine themes, like Elementary. If problem persist we'll have to take the decision about remove animations of dialogs (it's ok for me, we don't really need that flashing, fancy but unuseful effect).

Julien Lavergne (gilir) wrote :

Thanks for the reply.
In the short term, I'll disable the animation for Natty and Oneiric. We will re-evaluate this later in Oneiric cycle. Also, with the switch to GTK3, maybe progress will be made about this issue.

Changed in lubuntu-artwork (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.15

---------------
lubuntu-artwork (0.15) oneiric; urgency=low

  * usr/share/themes/Lubuntu-default/gtk-2.0/gtkrc:
   - Remove animation due to CPU usage (LP: #776776)
 -- Julien Lavergne <email address hidden> Mon, 16 May 2011 12:43:45 +0200

Changed in lubuntu-artwork (Ubuntu):
status: In Progress → Fix Released
Julien Lavergne (gilir) on 2011-05-16
description: updated

Accepted lubuntu-artwork into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in lubuntu-artwork (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Filip Dominec (fdominec) wrote :

I am using Lubuntu Oneiric alpha 1 and the problem of 100% CPU usage persists.

After boot, in the process list of the htop command, there is no process consuming more than 3 %. However, the total usage reaches 100 %. Please tell me what should I try next.

Julien Lavergne (gilir) wrote :

This is not the same bug. On Oneiric, lxtask display 100 % of CPU usage all the time, even if there is no activity.

Redwolf (viking.redwolf) wrote :

So the theme doesn't need to be changed again. Are you using GTK2 or GTK3 applications when this happens? Anyway, this was solved and so thread marked as that.

SteVe Cook (yorvyk) wrote :

I've created a new bug #796843 for this, as it's a different problem.

papukaija (papukaija) wrote :

I have installed the package from -proposed and can confirm that it fixes the bug. However, on my system the LxDesign theme (which was mentioned in comment 5 to test for) didn't have an animated progress bar in the stable version, so I used Lubuntu-default theme for the test:

The Lubuntu-default showed a CPU usage of up to 20% for lxapnel/Xorg and it with the proposed package it fell down to 1-5% while the Simple-Green showed up to 5% of CPU for both the stable and proposed version.

Martin Pitt (pitti) on 2011-06-24
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.14.1

---------------
lubuntu-artwork (0.14.1) natty-proposed; urgency=low

  * usr/share/themes/Lubuntu-default/gtk-2.0/gtkrc:
   - Remove animation due to CPU usage (LP: #776776)
 -- Julien Lavergne <email address hidden> Mon, 16 May 2011 15:51:41 +0200

Changed in lubuntu-artwork (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers