Missing Lubuntu Plymouth logo

Bug #1582046 reported by Benoît Thébaudeau on 2016-05-16
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Lubuntu Artwork
Undecided
Unassigned
lubuntu-artwork (Ubuntu)
High
Julien Lavergne
Xenial
High
Unassigned

Bug Description

[Impact]
During the merge of an upload of lubuntu-artwork back to the bzr branch, some files was forgotten in the process (images files). The consequence was that the plymouth theme was broken, unable to displays the images which was part of the theme. It also breaks unlocking encrypted home directory process, since plymouth can't display the prompt.

The upload just move the images files to the correct location.

[Test Case]
Boot a Lubuntu system which is enable to display graphical theme for plymouth.
Without the fix, you should see a black screen. With it, you should see the Lubuntu logo during the boot process.

[Regression Potential]
I can't see any potential regression, since it's currently completely broken.

[Original report]
Source package: lubuntu-artwork 0.61
Binary package: plymouth-theme-lubuntu-logo 0.61
Description: Ubuntu 16.04 LTS
Release: 16.04

There is an empty screen during boot instead of the Lubuntu logo. The cause of this issue is that the following files are not installed:
/usr/share/plymouth/themes/lubuntu-logo/lubuntu_logo.png
/usr/share/plymouth/themes/lubuntu-logo/password_field.png
/usr/share/plymouth/themes/lubuntu-logo/progress_dot_off.png
/usr/share/plymouth/themes/lubuntu-logo/progress_dot_on.png

In order to fix this issue, in the source package, the files src/lib/plymouth/themes/lubuntu-logo/* should be moved to src/usr/share/plymouth/themes/lubuntu-logo/ .

Julien Lavergne (gilir) on 2016-05-16
Changed in lubuntu-artwork:
status: New → Fix Committed
Changed in lubuntu-artwork (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-artwork (Ubuntu Xenial):
status: New → Confirmed
Julien Lavergne (gilir) wrote :

This also make the prompt to decrypt LVM device hidden behind (blank) splash screen (see duplicate 1574317)

Adolfo Jayme (fitojb) on 2016-06-03
Changed in lubuntu-artwork (Ubuntu Xenial):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.62

---------------
lubuntu-artwork (0.62) yakkety; urgency=medium

  * Move remaining files from src/lib/plymouth/ to src/usr/share/plymouth/
    (LP: #1582046). Thanks Benoît Thébaudeau for the patch.
  * Backup current artwork items to 1604 items, and prepare 1610 ones.
  * Stop copying LXDM theme, since it didn't change since ages.
  * src/usr/share/plymouth/themes/lubuntu-text
   - Update to 16.10
  * src/usr/share/icons:
   - Add symlinks to provide more icons from other icon themes.
   - Add missings icons from other themes.
   - Update icons.
  * debian/copyright:
   - Adjust copyright with icon adding from others themes.
  * debian/control:
   - Provide adwaita-icon-theme, adwaita-icon-theme-full, gnome-icon-theme,
     gnome-icon-theme-symbolic,hicolor-icon-theme, humanity-icon-theme.
     lubuntu-icon-theme provide the same set of icons.

 -- Julien Lavergne <email address hidden> Thu, 02 Jun 2016 23:01:13 +0200

Changed in lubuntu-artwork (Ubuntu):
status: Triaged → Fix Released
Julien Lavergne (gilir) on 2016-06-26
description: updated
Changed in lubuntu-artwork:
status: Fix Committed → Fix Released
Changed in lubuntu-artwork (Ubuntu Xenial):
status: Confirmed → In Progress

Hello Benoît, or anyone else affected,

Accepted lubuntu-artwork into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lubuntu-artwork/0.61.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lubuntu-artwork (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Ethan Blanton (eblanton) wrote :

Updating this package did not fix my problem (described in duplicate bug #1574317), but updating the (related?) plymouth-theme-lubuntu-logo to 0.61.1 did.

Julien Lavergne (gilir) wrote :

Thanks Ethan for the test. It's the expected behavior, the fix is about the plymouth theme, which is in the binary plymouth-theme-lubuntu-logo (part of the lubuntu-artwork source package).

Benoît Thébaudeau (btheb) wrote :

I confirm that plymouth-theme-lubuntu-logo 0.61.1 from xenial-proposed fixes this bug for me.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.61.1

---------------
lubuntu-artwork (0.61.1) xenial-proposed; urgency=medium

  * Move remaining files from src/lib/plymouth/ to src/usr/share/plymouth/
    (LP: #1582046). Thanks Benoît Thébaudeau for the patch.

 -- Julien Lavergne <email address hidden> Sun, 26 Jun 2016 14:27:20 +0200

Changed in lubuntu-artwork (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lubuntu-artwork has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers