xenial boots to black wallpaper.

Bug #1551446 reported by Brendan Perrine on 2016-02-29
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
High
Unassigned
lubuntu-default-settings (Ubuntu)
High
Julien Lavergne

Bug Description

to reproduce boot the dialy iso of lubuntu xenial from Feburary 28th or later and boot into a live session or a new install. Note dist upgrading on a previous install will not work as config files in your home folder for an already existing user will use that wallpaper as that is intended behavior but that is not what is broken. These images have

lubuntu-artwork:
  Installed: 0.60
  Candidate: 0.60
  Version table:
 *** 0.60 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

on these iso and boots to a black backgruodn when on fresh install or a new install.

I expected the last stable release wallpaper to appear at least until the wallpaepr for 16;04 was ready and put in the correct way to start in live session as I like the team work but don't want to miss them by default. Instead I got a black wallpaper instead when I booted the live session. pcmanfm is loading the desktop backgroudn with the lubuntu desktop so it is not pcmanfm part but rather maybe the file it is poining to.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: lubuntu-artwork 0.60
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CasperVersion: 1.367
CurrentDesktop: LXDE
Date: Mon Feb 29 21:49:59 2016
LiveMediaBuild: Lubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160228)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lubuntu-artwork
UpgradeStatus: No upgrade log present (probably fresh install)

Brendan Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1551446

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-artwork (Ubuntu):
status: New → Confirmed
sudodus (nio-wiklund) wrote :

This affects lubuntu desktop i386 too.

The files are there in /usr/share/lubuntu/wallpapers, and can be selected. After that the wallpaper is shown. Apparently they are not selected now (this bug appeared recently).

sudodus (nio-wiklund) wrote :

The installed system's login screen has the wallpaper, but the logged in desktop is black.

Changed in lubuntu-artwork (Ubuntu):
importance: Undecided → High
Brendan Perrine (walterorlin) wrote :

Reading the changlog of lubuntu default settings suggests that it might be this package as that loads the pcmanfm desktop for that.

lubuntu-default-settings (0.45) xenial; urgency=medium

  * src/etc/xdg/lubuntu/libfm/libfm.conf
  * src/usr/share/lxpanel/profile/Lubuntu-Nexus7/config
  * src/usr/share/lxpanel/profile/Lubuntu/config
   - Set lxterminal as the terminal by default, until
     lxsession-default-terminal is fixed (LP: #1434774).
  * src/etc/xdg/lubuntu/menus/lxqt-applications.menu
   - Exclude synaptic-kde.desktop in LXQt menu, until OnlyShowIn is fixed in LXQt
     (see bug #582). Thanks Ariszlo for the patch.
  * src/etc/xdg/pcmanfm/lubuntu/desktop-items-0.conf
  * src/etc/xdg/pcmanfm/lubuntu/pcmanfm.conf
   - Update some pcmanfm default settings and activate mounted devices on the
     desktop by default.
  * debian/control:
   - Provides lxqt-common to be able to install lxqt-session
     (lubuntu-default-settings also should provides all functionnalities of
     lxqt-common).
  * src/etc/xdg/lxqt/panel.conf
   - Remove lxqt-panel.conf until xdg dirs are correctly used.
  * Translations update.

 -- Julien Lavergne <email address hidden> Sat, 27 Feb 2016 16:13:04 +0100

Also affects installs.

summary: - xenial amd64 dialy boots to black wallpaper in live session.
+ xenial amd64 dialy boots to black wallpaper.
Phill Whiteside (phillw) wrote :

and 1386

summary: - xenial amd64 dialy boots to black wallpaper.
+ xenial boots to black wallpaper.
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-default-settings (Ubuntu):
status: New → Confirmed
Changed in lubuntu-default-settings (Ubuntu):
importance: Undecided → High
Julien Lavergne (gilir) on 2016-04-10
Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → Invalid
Changed in lubuntu-default-settings (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-default-settings - 0.46

---------------
lubuntu-default-settings (0.46) xenial; urgency=medium

  * src/etc/xdg/lubuntu/menus/lxqt-applications.menu:
   - Add some comments to the structure.
   - Exclude Evince from Office menu, it's already in Graphics.
   - Exclude Pcmanfm from System menu, already in Utility.
  * src/etc/xdg/pcmanfm/lubuntu/pcmanfm.conf:
   - Re-add [desktop] item in pcmanfm.conf, to correctly load settings on first
     start (LP: #1551446).

 -- Julien Lavergne <email address hidden> Sun, 10 Apr 2016 12:09:00 +0200

Changed in lubuntu-default-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers