new themes in lxappareance does not apply until after login and logout.

Bug #1460192 reported by Lyn Perrine
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
Fix Released
Medium
Unassigned
lxappearance (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

To reproduce boot the live session of zsync http://cdimage.ubuntu.com/cdimagae/lubuntu/dialy-live/20150529/wilydesktop-amd64.iso. Or an installed version of Lubuntu 15.10 Open lxappearnce or customize look and feel and try setting the theme to lubuntu-dark panel. Nothing changes and it still looks like the lubuntu-default them not the dark panel one. Lxappearnce appears to change the panel but nothing changes.

lubuntu-artwork:
  Installed: 0.54
  Candidate: 0.54
  Version table:
 *** 0.54 0
        500 http://archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu Wily Werewolf (development branch)
Release: 15.10
lxappearance:
  Installed: 0.6.1-1
  Candidate: 0.6.1-1
  Version table:
 *** 0.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages
        100 /var/lib/dpkg/status
 I expected the dark panel to paint the panel dark in the bottom like it did in utopic and vivid. Instead it stays light even when changing it. However in an installed session logging out and logging back in again shows the correct image for the panel but not during the same session for both the lubuntu and lubuntu netbook session selected in lightdm.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: lubuntu-artwork 0.54
ProcVersionSignature: Ubuntu 3.19.0-18.18-generic 3.19.6
Uname: Linux 3.19.0-18-generic x86_64
ApportVersion: 2.17.3-0ubuntu3
Architecture: amd64
CasperVersion: 1.360
CurrentDesktop: LXDE
Date: Fri May 29 19:46:25 2015
LiveMediaBuild: Lubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150529)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lubuntu-artwork
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Lyn Perrine (walterorlin) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1460192

tags: added: iso-testing
Revision history for this message
Lyn Perrine (walterorlin) wrote : Re: lubuntu dark panel does not apply a dark panel

I also get no dark panel on the bottom in an installed kvm vm as if it is not painting the dark panel anymore.

summary: - lubuntu dark panel does not apply in live session
+ lubuntu dark panel does not apply a dark panel
Revision history for this message
Lyn Perrine (walterorlin) wrote :

Actually one more thing to add logging out of the session on the installed session and logging back in again does apply the dark panel. This makes me think the bug might be in lxappearnce in applying the theme to a running session.

description: updated
summary: - lubuntu dark panel does not apply a dark panel
+ lubuntu dark panel does not apply a dark panel without logout
Revision history for this message
A. Eibach (andi3) wrote : Re: lubuntu dark panel does not apply a dark panel without logout

Does not only happen with "dark panels".

Darklooks *IS* my default, and just to see some action I changed it in some ugly one, e. g. HighContrast.
No effect.
But wait...after logout and logging back in, theme showed up as expected.

summary: - lubuntu dark panel does not apply a dark panel without logout
+ new themes in lxappareance does not apply until after login and logout.
Revision history for this message
sudodus (nio-wiklund) wrote :

Trying to run 'customize look and feel' in today's live session of Lubuntu i386 causes a crash that prompts me to send a bug report. 'Nothing else' happens.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-artwork (Ubuntu):
status: New → Confirmed
Changed in lxappearance (Ubuntu):
status: New → Confirmed
Changed in lxappearance (Ubuntu):
importance: Undecided → Medium
Changed in lubuntu-artwork (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Lyn Perrine (walterorlin) wrote :

I cannot reproduce this bug in openbox or i3 as standalone window managers And only in lxde.

Revision history for this message
Lyn Perrine (walterorlin) wrote :

After a few more lubuntu updates and lxappearnce is now applying new themes properly so if no one else is affected mark this as fix released?

Revision history for this message
Walter Lapchynski (wxl) wrote : Re: [Bug 1460192] Re: new themes in lxappareance does not apply until after login and logout.

i think if someone else can confirm that the bug cannot be reproduced, we
call it fix released. let me know if you need me to change the status.

Revision history for this message
A. Eibach (andi3) wrote :

FIXED! Definitely. Thanks to the dev team.

(using wily FINAL, no beta crud)

Changed in lxappearance (Ubuntu):
status: Confirmed → Fix Released
Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
A. Eibach (andi3) wrote :

Wasn't aware that I have the permission to do that, but it worked :P

Revision history for this message
A. Eibach (andi3) wrote :

Fix now available in Wily FINAL version (out on Oct 22, 2015)

Revision history for this message
A. Eibach (andi3) wrote :

^^ I wrote this above in "Comment on this change" but it appeared here. Tough luck.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers