Menus are almost unreadable, with deceptive highlighting

Bug #1256560 reported by Scott Cowles Jacobs on 2013-11-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
Undecided
Redwolf

Bug Description

I am using Lubuntu 13.10, but for various reasons use several different Gnome apps, including Nautilus and Evince. This bug is for both of the above, and probably for any Gnome app that has menus displayed with a button on the right of the control area (whatever the area is that is just under the window titlebar).

The menus that pop up when one of the menu buttons is pressed (View Options and Location Options for Nautilus; I don't know what the two menus are called for Evince, as they seem not to have tooltips)
are dark grey/light grey(or possibly white) on a black background, and thus very difficult to read.

In fact, unless I increase my monitor's brightness to close to 100%, I cannot tell that the dark grey menu items are there at all.

Also, the options that are selectable are the ones in dark grey. The options that are not selectable are in light grey or white.
Thus, the only options that you can select, are those that you cannot see...

I had two ideas on this:

1) Perhaps somehow Gnome apps are depending on something that is normally there for a full gnome desktop, that is not there if one is just installing certain apps in isolation.
This... something... is where Gnome decides on what colors to use in displaying the menus.
Without this, some default colors are used that don't work very well.

2) My Lubuntu setup uses the window Theme Bear2 (standard, included with Lubuntu, not downloaded).
Perhaps there is some interaction with the particular Theme used...
No. I just tried several different themes, and the menus all came up exactly the same.

Unless everybody's menus are this way, I am going to assume that 1) is probably closer to being the cause.

Remember, this applies to Evince as well (and perhaps many other Gnome apps.)
If there is some way to report a bug for "Gnome in general" and not for a particular Gnome app.
either move this bug there, or let me know where to do it, and I will.

I will attach screenshots showing the problem for each of the two menus for Gnome and also for Evince's two menus.

---------------------------------------------
scott@scott-ASUS-M2N68-AM-PLUS:~$ uname -a
Linux scott-ASUS-M2N68-AM-PLUS 3.11.0-13-generic-tuxonice #20~ppa1-Ubuntu SMP Fri Nov 8 11:40:45 UTC 2013 i686 athlon i686 GNU/Linux

scott@scott-ASUS-M2N68-AM-PLUS:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10 (actually Lubuntu)
Release: 13.10
Codename: saucy

scott@scott-ASUS-M2N68-AM-PLUS:~$ nautilus --version
GNOME nautilus 3.8.2

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that seems like an issue in the lubuntu GTK theme

affects: nautilus (Ubuntu) → lubuntu-artwork (Ubuntu)
Redwolf (viking.redwolf) wrote :

I confirm this bug. I already fixed GTK2 and GTK3 menus (gtkcombobox controls) and get it back to white (like first Box style, this property is back now). But Evince uses different controls to draw menuses. I'm on it.

Changed in lubuntu-artwork (Ubuntu):
assignee: nobody → Rafael Laguna (rafaellaguna)
assignee: Rafael Laguna (rafaellaguna) → nobody
status: New → In Progress
assignee: nobody → Rafael Laguna (rafaellaguna)
Redwolf (viking.redwolf) wrote :

Pseudo-fix (temporary): http://i.imgur.com/rW0vOtJ.png

Redwolf (viking.redwolf) wrote :

While it isn't fixed yet, revision 380 ensures to whiten menuses and corrects a few problems. Anyway, still working on this "button-menuses" control.

http://bazaar.launchpad.net/~lubuntu-art/lubuntu-artwork/quantal/revision/380

Redwolf (viking.redwolf) wrote :

For your info. I fixed the Evince (button menus) problem, but ruined another thing (gtkcombos are related to this menus, I need to balance them). Also, this was because of changes (again!) on the Unico engine settings. Let me work a few days on this.

Redwolf (viking.redwolf) wrote :

Fix done on revision 381:
http://bazaar.launchpad.net/~lubuntu-art/lubuntu-artwork/quantal/revision/381

Side effects detected. an annoying horizontal line now appears under the menu (or up the toolbars). I'll fix it.

Changed in lubuntu-artwork (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.43

---------------
lubuntu-artwork (0.43) trusty; urgency=low

  * Update icon theme.
  * Remove elementaryLubuntu icon set.
  * Fix menu background (LP: #1256560).
  * Add Unity and Xfce support.
 -- Julien Lavergne <email address hidden> Sun, 09 Feb 2014 20:53:19 +0100

Changed in lubuntu-artwork (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers