System Profiler and Benchmark 2 blank gui boxes closing the small one results in the system info to be displayed.

Bug #1029212 reported by warren on 2012-07-26
146
This bug affects 27 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
lubuntu-artwork (Ubuntu)
Undecided
Unassigned
Nominated for Raring by Adolfo Jayme

Bug Description

1) Lubuntu 12.10 Alpha3 i386 (Live USB stick)
2) Hard Info 0.5.1 (System Profiler and Benchmark)
3) I expected System Profiler and Benchmark when opened to display the Computer, Devices, Network, and Benchmarks category list and their respective subtopics which are to display their info.
4) I have attached 3 images to this bug report the first shows what happens when the hardinfo app is first opened two empty gui boxes one small and one large. The second shows one small empty box with hardinfo app appearing after the small box close button was clicked. The last image shows what happens when the small box close button has been clicked again.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: hardinfo 0.5.1-1.1ubuntu5
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic i686
ApportVersion: 2.4-0ubuntu5
Architecture: i386
CasperVersion: 1.320
Date: Thu Jul 26 01:07:35 2012
LiveMediaBuild: Lubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: hardinfo
UpgradeStatus: No upgrade log present (probably fresh install)

warren (wkclemmons) wrote :
warren (wkclemmons) wrote :

It seems to take three clicks of the close button on the smaller box to get the System Profiler and Benchmark to display normally.

Ron Mitchell (rm2892) wrote :

Similar problem here with System Profiler and Benchmark. Running an eMAC PPC G4 with 1 Gig of RAM.

Getting 4 blank gui-boxes opening. Have to close each one of them out for the program to properly open.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hardinfo (Ubuntu):
status: New → Confirmed
Greg Faith (gregfaith) wrote :

Also affects Lubuntu desktop amd64 current daily build 20120728. Will report on qa-tracker, tag iso-testing and notify Lubuntu-qa .

tags: added: iso-testing
Julien Lavergne (gilir) wrote :

Confirmed it's artwork related, if I switch to another widget theme, it's working as usual. I still don't know why thoses white windows appears on this artwork.

Redwolf (viking.redwolf) wrote :

It's a very very weird behaviour. Can we identify what controls is using that small window?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-artwork (Ubuntu):
status: New → Confirmed
amjjawad  (amjjawad) wrote :

Well, the problem still exist on Lubuntu 12.10 both i686 and amd64 and YES, this is the final release that I'm talking about. There are many blank boxes at the beginning and I need to keep closing them until I get something useful on the screen and sometimes, when I change the category, I get the same blank weird boxes.

And Julien is right, when I change the widget, it works normally. Weird.

@Rafael, hope you will figure it out soon, my friend :)

Yes, it's on my to-do list :)

--
紳癒礁湖 (Rafael Laguna)
Lubuntu Artwork Team

2012/10/22 amjjawad <email address hidden>

> Well, the problem still exist on Lubuntu 12.10 both i686 and amd64 and
> YES, this is the final release that I'm talking about. There are many
> blank boxes at the beginning and I need to keep closing them until I get
> something useful on the screen and sometimes, when I change the
> category, I get the same blank weird boxes.
>
> And Julien is right, when I change the widget, it works normally. Weird.
>
> @Rafael, hope you will figure it out soon, my friend :)
>
> --
> You received this bug notification because you are subscribed to
> lubuntu-artwork in Ubuntu.
> https://bugs.launchpad.net/bugs/1029212
>
> Title:
> System Profiler and Benchmark 2 blank gui boxes closing the small one
> results in the system info to be displayed.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/hardinfo/+bug/1029212/+subscriptions
>

kalehrl (kalehrl) wrote :

I've got the same problem on my 12.04 after installing lubuntu-art ppa.
I read on the mailing list that the bug was fixed in 12.10 but it still persist in 12.04.
Any indication about when it will be fixed?
Thank you.

kalehrl (kalehrl) wrote :

I solved the problem by uninstalling hardinfo :D

ATIpro (somebody2112) wrote :

There are some problems with new artwork. Many lines like these can be found in ~/.cache/lxsession/Lubuntu/run.log:

** (deadbeef:1784): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Lubuntu-default/gtk-2.0/images/null.png,
borders don't fit within the image

** (deadbeef:1784): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Lubuntu-default/gtk-2.0/images/scrollbar_horizontal.png,
borders don't fit within the image

** (deadbeef:1784): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Lubuntu-default/gtk-2.0/images/scrollbar_vertical.png,
borders don't fit within the image

** (firefox:1686): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Lubuntu-default/gtk-2.0/images/scrollbar_vertical-sel.png,
borders don't fit within the image

Redwolf (viking.redwolf) wrote :

ATIpro, it's not a bug, just a workaround to make scrollbars work. I already explained this in other bug (don't remember which one) that this doesn't affect any app. Also the rendering of the theme is not affected. But you see weird messages when launching from a Terminal, that's all. Anyway, I'll fix this. But it doesn't have relation at all with the System Profiler bug.

David Conner (dlbike76) wrote :

The problem is still present in raring as of raring daily image 20121130. The problem does not occur if you switch to another widget theme.

tags: added: raring
C de-Avillez (hggdh2) wrote :

setting importance on this task to low, given that changing themes work; I am also not sure this is a problem *in* hardinfo.

Changed in hardinfo (Ubuntu):
importance: Undecided → Low
David Conner (dlbike76) wrote :

I did a backtrace in GDB, and have attached it. If I'm reading the backtrace correctly, then the blank window is a dialog that is being created within log_handler(). I'm not sure why there is no text in the dialog though.

Thanks,

David

Jackson Doak (noskcaj) wrote :

marked as hundredpapercuts. due to being a minor issue that will possibly go unfixed

Changed in hardinfo (Ubuntu):
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
tags: added: amd64
Chris Wilson (notgary) wrote :

Thanks for reporting this to the paper cuts project. The correct way to do this sin't to assign the team, but to add a paper cut task to the report, which I've done. For information on how to report a paper cut, see this http://askubuntu.com/questions/231178/how-do-i-report-a-paper-cut

Changed in hardinfo (Ubuntu):
assignee: Paper Cuts Ninja (papercuts-ninja) → nobody
tags: added: bitesize

this bug is alive on Lubuntu 12.10 and 13.04, 32 bits, both fresh install.

workaround from comment #6 works, but it may look strange for new users/new comers see that some applications "do not work" out of the box as expected.

i believe it takes a while for new users to find on release notes the fix/workaround:
https://wiki.ubuntu.com/RaringRingtail/ReleaseNotes/Lubuntu

shouldn't we provide an "it just works" experience on new hardware as said at the 12.10, the version where the bug started?
https://wiki.ubuntu.com/QuantalQuetzal/ReleaseNotes/Lubuntu

or by "it just works" mean the OS works, but some applications we provide by default do not?

pls, don't take my comment to the wrong side. :-)

I just want to be sure what's the experience we intend do provide to new Lubuntu users.

cheers,
Iberê

Redwolf (viking.redwolf) wrote :

Solved with revision #330

Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → Fix Committed
Changed in hundredpapercuts:
status: New → Fix Committed
Changed in hardinfo (Ubuntu):
status: Confirmed → Fix Committed
amjjawad  (amjjawad) wrote :

Thanks Rafael, this is a great news :)

May I know please that fix will be included in what release(s)? and when?

Thank you :D

Redwolf (viking.redwolf) wrote :

Immediatly for Saucy. Then Julien will port the solution onto Raring and
below (a few days, I think).

--
紳癒礁湖 (Rafael Laguna)
Lubuntu Artwork Team

2013/6/18 amjjawad <email address hidden>

> Thanks Rafael, this is a great news :)
>
> May I know please that fix will be included in what release(s)? and
> when?
>
> Thank you :D
>
> --
> You received this bug notification because you are subscribed to
> lubuntu-artwork in Ubuntu.
> https://bugs.launchpad.net/bugs/1029212
>
> Title:
> System Profiler and Benchmark 2 blank gui boxes closing the small one
> results in the system info to be displayed.
>
> Status in One Hundred Paper Cuts:
> Fix Committed
> Status in “hardinfo” package in Ubuntu:
> Fix Committed
> Status in “lubuntu-artwork” package in Ubuntu:
> Fix Committed
>
> Bug description:
> 1) Lubuntu 12.10 Alpha3 i386 (Live USB stick)
> 2) Hard Info 0.5.1 (System Profiler and Benchmark)
> 3) I expected System Profiler and Benchmark when opened to display the
> Computer, Devices, Network, and Benchmarks category list and their
> respective subtopics which are to display their info.
> 4) I have attached 3 images to this bug report the first shows what
> happens when the hardinfo app is first opened two empty gui boxes one small
> and one large. The second shows one small empty box with hardinfo app
> appearing after the small box close button was clicked. The last image
> shows what happens when the small box close button has been clicked again.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: hardinfo 0.5.1-1.1ubuntu5
> ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
> Uname: Linux 3.5.0-6-generic i686
> ApportVersion: 2.4-0ubuntu5
> Architecture: i386
> CasperVersion: 1.320
> Date: Thu Jul 26 01:07:35 2012
> LiveMediaBuild: Lubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.1)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: hardinfo
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/1029212/+subscriptions
>

amjjawad  (amjjawad) wrote :

Gracias amigo :D
Thank you so much, my friend :D

 Just checked Saucy, still nothing yet. But I can wait, no problem :D

John Hupp (john.hupp) wrote :

Thanks for getting this done!

Julien Lavergne (gilir) on 2013-06-18
Changed in lubuntu-artwork (Ubuntu):
status: Fix Committed → In Progress
Changed in hardinfo (Ubuntu):
status: Fix Committed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.39

---------------
lubuntu-artwork (0.39) saucy; urgency=low

  * Backup current artwork items to 1304 items, and prepare 1310 ones.
  * lib/plymouth/themes/lubuntu-text:
   - Update to 13.10.
  * Update gtk2 theme:
   - Fix blank windows on hardinfo and errors on terminal (LP: #1029212).
   - Improve overall control bitmaps
  * Update gtk3 theme :
   - Fix black border (LP: #1186631)
   - Improve overall control bitmaps
  * Update icon theme.
   - Fix glyphs gradients
   - Add more apps and devices
 -- Julien Lavergne <email address hidden> Thu, 27 Jun 2013 23:34:59 +0200

Changed in lubuntu-artwork (Ubuntu):
status: In Progress → Fix Released
Adolfo Jayme (fitojb) on 2013-06-28
no longer affects: hardinfo (Ubuntu)
Chris Wilson (notgary) on 2013-06-28
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
amjjawad  (amjjawad) wrote :

With Saucy Alpha 1, after system update (sudo apt-get upgrade && sudo apt-get dist-upgrade), I confirm the issue has been fixed.

However, I have no idea what about other releases? 13.04? 12.10? 12.04? I need to check. Hope someone else can confirm about the previous releases :)

Thank you so much for fixing this.

Jonathan Marsden (jmarsden) wrote :

On Fri, Jun 28, 2013, at 03:38 PM, amjjawad wrote:

> However, I have no idea what about other releases? 13.04? 12.10?
> 12.04? I need to check. Hope someone else can confirm about the
> previous releases :)

Bug fixes are made to the current development release first, then, if
possible and appropriate, and if someone has the time to do it, they can
then be backported to earlier releases.

You should not expect that a new fix immediately appears in earlier
releases. That is the way Ubuntu development works. See

  https://help.ubuntu.com/community/UbuntuBackports

and

  https://wiki.ubuntu.com/UbuntuBackports

Jonathan
--
  Jonathan Marsden
  <email address hidden>

amjjawad  (amjjawad) wrote :

Thank you, Jonathan :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers