package liblua5.1-rex-pcre0 (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/lua/5.1/rex_pcre.so', which is also in package lrexlib1 0:2.4.0-1~ppa15

Bug #608681 reported by Dave Fields on 2010-07-22
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
lua-rexlib (Ubuntu)
Low
Unassigned

Bug Description

During regular prompted update

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: liblua5.1-rex-pcre0 (not installed)
ProcVersionSignature: Ubuntu 2.6.32-24.38-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
Architecture: amd64
Date: Thu Jul 22 07:11:58 2010
ErrorMessage: trying to overwrite '/usr/lib/lua/5.1/rex_pcre.so', which is also in package lrexlib1 0:2.4.0-1~ppa15
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: lua-rexlib
Title: package liblua5.1-rex-pcre0 (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/lua/5.1/rex_pcre.so', which is also in package lrexlib1 0:2.4.0-1~ppa15

Dave Fields (dfields) wrote :
dasy2k1 (dasy2k1) wrote :

affects i386 too not just AMD64

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

You have installed the same package using a PPA that you added. An easy workaround for this would be to remove the PPA from your sources.

Thanks for taking the time to make Ubuntu better!

Changed in lua-rexlib (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
dasy2k1 (dasy2k1) wrote :

found workaround,

it was mudlet that had the dependancy on lrexlib1 0:2.4.0-1~ppa15

and the new version of mudlet that needed liblua5.1-rex-pcre0

if you uninstall mudlet and lrexlib1 0:2.4.0-1~ppa15

then install liblua5.1-rex-pcre0 and the new mudlet everything works fine

it was just a 4 way cross dependancy that was breaking the auto pakage updater

A depends on B
Anew depends on C

Anew confilcts with B
A conflicts with C
B and C conflict with each other

tags: added: package-conflict
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers