lttng-modules-dkms fails to build on updated kernel

Bug #1396758 reported by Michael Jeanson on 2014-11-26
192
This bug affects 37 people
Affects Status Importance Assigned to Milestone
lttng-modules (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
Utopic
High
Unassigned
Vivid
High
Unassigned

Bug Description

Rationale:

lttng-modules-dkms won't build on updated trusty kernels since tracepoints where backported from the stable tree but the kernel version was not incremented.

Testcase:

Install lttng-modules-dkms, it now builds successfully

Regression potential:

Can't be worse, current package won't build modules and generate error reports on each kernel update.

Changed in lttng-modules (Ubuntu):
status: New → Invalid
Changed in lttng-modules (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High

Hello Michael, or anyone else affected,

Accepted lttng-modules into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/lttng-modules/2.4.0-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lttng-modules (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Jonah Graham (v-ubuntuone-v) wrote :

After having the same error described with the previous version, I successfully installed lttng-modules-dkms:all 2.4.0-1ubuntu1.1 and was able to run some kernel tracing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lttng-modules - 2.4.0-1ubuntu1.1

---------------
lttng-modules (2.4.0-1ubuntu1.1) trusty; urgency=medium

  * Fix dkms build failure with updated kernels (LP: #1396758)
 -- Michael Jeanson <email address hidden> Wed, 26 Nov 2014 21:08:51 +0100

Changed in lttng-modules (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lttng-modules has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in lttng-modules (Ubuntu Utopic):
status: New → Confirmed
importance: Undecided → High
Changed in lttng-modules (Ubuntu Vivid):
importance: Undecided → High

lttng-modules fails to install on Utopic. It installs fine on Vivid with the 3.16 kernel, but it fails with the 3.18 kernel, which is what Vivid will use soon.

I added bug tasks for Utopic and Vivid, but maybe new bugs for them would be better?

Changed in lttng-modules (Ubuntu Vivid):
status: Invalid → Confirmed
tags: added: kernel-da-key

The attachment "lttng-modules-sru.diff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
summary: - lttng-modules-dkms fails to build on updated trusty kernels
+ lttng-modules-dkms fails to build on updated Trusty, Utopic and Vivid
+ kernels
summary: - lttng-modules-dkms fails to build on updated Trusty, Utopic and Vivid
- kernels
+ lttng-modules-dkms fails to build on updated Trusty kernel
Joseph Salisbury (jsalisbury) wrote :

I created new bugs for Utopic and Vivid:

Utopic: bug 1402062
Vivid: bug 1402064

no longer affects: lttng-modules (Ubuntu Utopic)
no longer affects: lttng-modules (Ubuntu Vivid)
Daniel van Vugt (vanvugt) wrote :

It's easier to manage all three distros in a single bug, and that's what LP is designed for. So I've nominated vivid and utopic to have tasks added, if you look up the top ^^^

summary: - lttng-modules-dkms fails to build on updated Trusty kernel
+ lttng-modules-dkms fails to build on updated kernel
Changed in lttng-modules (Ubuntu Utopic):
status: New → Confirmed
importance: Undecided → High
Joseph Salisbury (jsalisbury) wrote :

To expand on comment #8, the lttng-modules package will install on Vivid with the 3.16 kernel. However, kernel 3.18, we will need LTTng 2.6-rc. Upstream is very near completion of the RC cycle (close to final).

Hello Michael, or anyone else affected,

Accepted lttng-modules into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lttng-modules/2.5.0-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lttng-modules (Ubuntu Utopic):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed

The fix for this bug has been awaiting testing feedback in the -proposed repository for utopic for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate

Tested the proposed package on Utopic, It installs, all dkms modules are correctly built and kernel tracing is working.

It is still failing on Vivid though, LTTng 2.6 works, I'm looking at which patches need to be backported to 2.5.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lttng-modules - 2.5.0-1ubuntu1

---------------
lttng-modules (2.5.0-1ubuntu1) utopic; urgency=medium

  * Fix dkms build failure for Utopic kernels (LP: #1396758)
 -- Joseph Salisbury <email address hidden> Wed, 17 Dec 2014 15:44:50 -0600

Changed in lttng-modules (Ubuntu Utopic):
status: Fix Committed → Fix Released

the kernel patch included in todays [15april2015] update package appears to repeat the problem with lttng-modules, or maybe catalyse the repeat of the problem. on first restart after installing the updates, a 'sytem program problem' was reported on the desktop 4 times before the desktop finished loading; the same as before the previous problem with lttng-modules was fixed.

the kernel patch included in todays [15april2015] update package appears to repeat the problem with lttng-modules, or maybe catalyse the repeat of the problem. on first restart after installing the updates, a 'sytem program problem' was reported on the desktop 4 times before the desktop finished loading; the same as before the previous problem with lttng-modules was fixed.?field.comment=the kernel patch included in todays [15april2015] update package appears to repeat the problem with lttng-modules, or maybe catalyse the repeat of the problem. on first restart after installing the updates, a 'sytem program problem' was reported on the desktop 4 times before the desktop finished loading; the same as before the previous problem with lttng-modules was fixed.

tags: removed: removal-candidate

I can confirm that this bug seems to have re-emerged. On a fully updated system:

mlcurry@ubuntu:~/tmp$ sudo apt-get -qq update
mlcurry@ubuntu:~/tmp$ sudo apt-get -qq dist-upgrade
mlcurry@ubuntu:~/tmp$ apt-get -qq source lttng-modules
gpgv: Signature made Wed 26 Nov 2014 01:19:42 PM MST using RSA key ID 64792D67
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./lttng-modules_2.4.0-1ubuntu1.1.dsc
dpkg-source: info: extracting lttng-modules in lttng-modules-2.4.0
dpkg-source: info: unpacking lttng-modules_2.4.0.orig.tar.gz
dpkg-source: info: unpacking lttng-modules_2.4.0-1ubuntu1.1.debian.tar.gz
dpkg-source: info: applying fix-build-on-ubuntu-kernels.patch
mlcurry@ubuntu:~/tmp$ cd lttng-modules-2.4.0/
mlcurry@ubuntu:~/tmp/lttng-modules-2.4.0$ make
make -C /lib/modules/3.16.0-46-generic/build M=/home/mlcurry/tmp/lttng-modules-2.4.0 modules
make[1]: Entering directory `/usr/src/linux-headers-3.16.0-46-generic'
  CC [M] /home/mlcurry/tmp/lttng-modules-2.4.0/lttng-ring-buffer-client-discard.o
  CC [M] /home/mlcurry/tmp/lttng-modules-2.4.0/lttng-ring-buffer-client-overwrite.o
  CC [M] /home/mlcurry/tmp/lttng-modules-2.4.0/lttng-ring-buffer-metadata-client.o
  CC [M] /home/mlcurry/tmp/lttng-modules-2.4.0/lttng-ring-buffer-client-mmap-discard.o
  CC [M] /home/mlcurry/tmp/lttng-modules-2.4.0/lttng-ring-buffer-client-mmap-overwrite.o
  CC [M] /home/mlcurry/tmp/lttng-modules-2.4.0/lttng-ring-buffer-metadata-mmap-client.o
  CC [M] /home/mlcurry/tmp/lttng-modules-2.4.0/lttng-statedump-impl.o
/home/mlcurry/tmp/lttng-modules-2.4.0/lttng-statedump-impl.c: In function ‘lttng_statedump_process_ns’:
/home/mlcurry/tmp/lttng-modules-2.4.0/lttng-statedump-impl.c:310:2: error: implicit declaration of function ‘task_nsproxy’ [-Werror=implicit-function-declaration]
  proxy = task_nsproxy(p);
  ^
/home/mlcurry/tmp/lttng-modules-2.4.0/lttng-statedump-impl.c:310:8: warning: assignment makes pointer from integer without a cast [enabled by default]
  proxy = task_nsproxy(p);
        ^
cc1: some warnings being treated as errors
make[2]: *** [/home/mlcurry/tmp/lttng-modules-2.4.0/lttng-statedump-impl.o] Error 1
make[1]: *** [_module_/home/mlcurry/tmp/lttng-modules-2.4.0] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.16.0-46-generic'
make: *** [default] Error 2

The "task_nsproxy" error corresponds to upstream bug https://bugs.lttng.org/issues/838 , which was fixed upstream in 2.5+ only. The commits linked on that bug would have to be backported to the 2.4 package.

i just did a kernel upgrade in vivid and still get the lttng-modules 2.5.1 system program error

      From: Alex Mont <email address hidden>
 To: <email address hidden>
 Sent: Wednesday, 19 August 2015, 5:47
 Subject: [Bug 1396758] Re: lttng-modules-dkms fails to build on updated kernel

The "task_nsproxy" error corresponds to upstream bug
https://bugs.lttng.org/issues/838 , which was fixed upstream in 2.5+
only. The commits linked on that bug would have to be backported to the
2.4 package.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1396758

Title:
  lttng-modules-dkms fails to build on updated kernel

Status in lttng-modules package in Ubuntu:
  Confirmed
Status in lttng-modules source package in Trusty:
  Fix Released
Status in lttng-modules source package in Utopic:
  Fix Released
Status in lttng-modules source package in Vivid:
  Confirmed

Bug description:
  Rationale:

  lttng-modules-dkms won't build on updated trusty kernels since
  tracepoints where backported from the stable tree but the kernel
  version was not incremented.

  Testcase:

  Install lttng-modules-dkms, it now builds successfully

  Regression potential:

  Can't be worse, current package won't build modules and generate error
  reports on each kernel update.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lttng-modules/+bug/1396758/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers