Ubuntu

Unity doesn't start at all on a 3D capable machine instead of falling back to unity-2d as it should (because of lack of 16bit support in compiz).

Reported by Stéphane Graber on 2012-04-24
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
High
Stéphane Graber
Precise
High
Stéphane Graber

Bug Description

[rationale]
DESKTOP_SESSION isn't properly set when using the "default" session (no parameter passed to Xsession), this leads to gconf not loading the custom unity settings, resulting in just nautilus being running.

The fix adds an Xsession.d script to both ltsp-client-core and ltsp-server, this script parses the parameter of Xsession and sets DESKTOP_SESSION to the expected value, similar to what lightdm does on a regular desktop.

[test case]
1) Build a fat client chroot on a working LTSP system (ltsp-build-client --fat-client)
2) Boot a 3D capable thin client
3) Login using the default session

3) in the past would lead to a blank screen, with the fix, you get unity-3d.

[regression potential]
As far as I can tell, DESKTOP_SESSION is only used by gconf at the moment, so if the code fails, all we should get is more gconf weirdness, though I can hardly see how it could get any worse than not getting a desktop session.

Related branches

Changed in ldm (Ubuntu):
status: New → In Progress
assignee: nobody → Stéphane Graber (stgraber)
status: In Progress → Fix Committed
status: Fix Committed → Confirmed
importance: Undecided → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/987726

tags: added: iso-testing
eric (obrowny06) wrote :

I can confirm that ubuntu 3D is not working with ltsp and that there is no fallback. Ubuntu-2D is working well and gnome fallback is working too.

Stéphane Graber (stgraber) wrote :

Well, to be accurate, the fallback actually happens but it seems dependent on the hardware and not always happening.
My test hardware for non-3D stuff is a kvm virtual machine using the cirrus virtual graphic card and at least for this one, if I select Ubuntu I get redirected to an Ubuntu 2D session just fine. That's mostly why I didn't catch this earlier.

My guess is that something in nux's graphic capability check is failing causing some hardware (if not most) to be considered as ok for Ubuntu when it's really not (if only because compiz fails in 16bit mode). I'm hoping to get a fix in nux instead of LTSP as people tend to update their application server a lot more than they do their chroot.

Christopher (soft-kristal) wrote :

I can't run 3d at all, and my dash panel icons won't reset to 32 instead of 48, which I guess is part of the problem.

I updated 11.10 to 12.04 overnight. I test alphas on another partition and the 64 bit version of 12.04 is working normally.

Stéphane Graber (stgraber) wrote :

Hmm, actually these are for a similar problem with fat clients, it shouldn't be the 16bit issue there as fat clients aren't supposed to start in 16bit mode.

Franck Goirand (fgoirand-5) wrote :

Hello

Actually i have a similar problem with a fat clients on a 3D capable machine (intel i915 and nvdia).
After user login, i see empty screen without anything and default wallpaper. The right click is activate, and i can change default wallpaper or launch nautilus.

Manually selecting unity-2d works around the issue, i have full desktop with unity-2d.

Possible by-pass by add the next line in LTS.CONF
LDM_SESSION="gnome-session --session=ubuntu-2d"

Stéphane Graber (stgraber) wrote :

Anyone affected by this bug, can you please attach your $HOME/.xsession_errors as well as the output of "xrandr" and "/usr/lib/nux/unity_support_test -p"?

Stéphane Graber (stgraber) wrote :

oh, and also a "ps faux" output of a broken session would be useful

Franck Goirand (fgoirand-5) wrote :

YES, of course

unity_support_test
http://pastebin.com/zXbzWxv9

.xsession-errors
http://pastebin.com/6e4ZnRve

ps -faux
http://pastebin.com/VJNgXJmp

xrandr
http://pastebin.com/sEvuZabv

If you need again don't hesitate to ask me

Franck Goirand (fgoirand-5) wrote :

some news on fixing this bug ?

onanisland (jmuir84) wrote :

I am also experiencing issues when I went from 11.10 to 12.04 LTS. We currently use fat-clients and I am getting just a wallpaper on new accounts, the previous 11.10 accounts login just fine. I'm hoping this will be fixed soon as this is a pretty big issue for me not being able to add new user accounts at the moment.

affects: ldm (Ubuntu) → ltsp (Ubuntu)
Changed in ltsp (Ubuntu):
status: Confirmed → Fix Released
Changed in ltsp (Ubuntu Precise):
assignee: nobody → Stéphane Graber (stgraber)
importance: Undecided → High
status: New → Triaged
description: updated
Changed in ltsp (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Changed in ltsp (Ubuntu Precise):
status: Triaged → In Progress

Hello Stéphane, or anyone else affected,

Accepted ltsp into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ltsp/5.3.7-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ltsp (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

Tested on a fat client, confirmed that prior to the update I'd just get an empty desktop without unity, post-upgade unity 3d starts as expected.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ltsp - 5.3.7-0ubuntu2.2

---------------
ltsp (5.3.7-0ubuntu2.2) precise-proposed; urgency=low

  * Add Xsession.d script in both ltsp-client-core and ltsp-server to
    properly set DESKTOP_SESSION when using the default session.
    (LP: #987726)
 -- Stephane Graber <email address hidden> Thu, 02 Aug 2012 12:10:06 -0400

Changed in ltsp (Ubuntu Precise):
status: Fix Committed → Fix Released
Franck Goirand (fgoirand-5) wrote :

Hello
Solution tested my workstations with which I had the problem.
Problem solved.
thank you

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions