ltsp-live fails to configure internal NIC

Bug #856460 reported by Jean-Baptiste Lallement on 2011-09-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
High
Stéphane Graber

Bug Description

Edubuntu 20110922

Testing Environment:
Virtual Box - 1GB Memory allocated
NIC 1: e1000
NIC 2: PCnet Fast III (internal network)

TEST CASE:
1. Boot Edubuntu LiveCD
2. Click on the "Start LTSP Live" icon on the launcher
3. On the 'LTSP-Live configuration" dialog select the internal NIC and press OK

Result:
The UI is disabled for a few seconds then back to normal
The following message is displayed on the terminal:
===
Creating new configuration file
Failed to enable LTSP: nmcli con up id LTSP iface eth1

Error: Unknown connection: LTSP.
===

LTSP is not displayed in the list of known connections from n-m
If 'Connect Automatically' is unchecked in the properties of the connection, the the interface comes up correctly.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ltsp-livecd 5.2.16-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CasperVersion: 1.284
Date: Thu Sep 22 14:20:22 2011
LiveMediaBuild: Edubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110922)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ltsp
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
description: updated
description: updated
tags: added: iso-testing
Changed in ltsp (Ubuntu):
assignee: nobody → Stéphane Graber (stgraber)
Changed in ltsp (Ubuntu):
importance: Undecided → High
Stéphane Graber (stgraber) wrote :

I'm starting to run out of ideas, I tried 5 different VM configurations and 2 physical systems and couldn't reproduce what you're seeing...

Can you also attach a "lspci -nnn" and if your system is a libvirt VM, the output of "dumpxml <vmname>" from virsh?

Changed in ltsp (Ubuntu):
status: New → Incomplete
Jonathan Carter (jonathan) wrote :

I had the same problem with Virtualbox with 2x virtual Intel e1000 on Edubuntu 12.04 alpha 2

To fix it, you have to go to your guest's network settings and under Promiscuous Mode, you have to choose "Allow All".

I'm marking this bug as invalid since it's not technically an ltsp-live problem.

Changed in ltsp (Ubuntu):
status: Incomplete → Invalid
Jonathan Carter (jonathan) wrote :

Reverting to incomplete, after discussing it with stgraber, he informed me that JBL also had this problem on KVM.

Changed in ltsp (Ubuntu):
status: Invalid → Incomplete
Jonathan Carter (jonathan) wrote :

Interesting, enabling promiscuous mode on i386 fixed it for me under VirtualBox. On amd64 I still get the problem mentioned above.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/856460

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ltsp - 5.2.16-0ubuntu14

---------------
ltsp (5.2.16-0ubuntu14) precise; urgency=low

  * ltsp-live: inotify is broken on overlayfs so upstart and NM don't
    detect configuration changes. Add some ugly workaround to force
    upstart to detect the new job (reload-configuration) and manually
    start it. For Network Manager, restart network-manager just after
    adding the new config. (LP: #856460)
  * Cherry pick another upstream fix to deal with install media
    without the non-PAE kernel. Actually run the check in the target
    rather than the host (which may have different APT sources).
 -- Stephane Graber <email address hidden> Wed, 01 Feb 2012 14:09:32 -0500

Changed in ltsp (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers