Ltsp node fails to gain authorisation

Bug #439611 reported by Dave Morley on 2009-09-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
High
Unassigned
Nominated for Lucid by Martin-Éric Racine

Bug Description

On 20090929.2 of ubuntu 64bit alternate.

Ltsp starts but you can not login under the only user on the system.
Login screens says Verifying password. Please wait.

Then it cycles back to the a-c-f1 messages and back to the login prompt.

p.s. had to redirect the i386 to amd64 in /etc/ltsp/dhcp.conf first

Related branches

Dave Morley (davmor2) wrote :

Additional info:

Text below login changes from Verifying password. Please wait to No response from server restarting

Alkis Georgopoulos (alkisg) wrote :

As a first step, could you try to run the following on the server?
  sudo ltsp-update-sshkeys
  sudo ltsp-update-image
and then restart the client?

Ara Pulido (ara) on 2009-10-02
Changed in ltsp (Ubuntu):
status: New → Incomplete
Daniel Milde (daniel-milde) wrote :

Same for me.

There were some messages about corruption in squashfs:

failed to read block 0xb951c75

Ltsp-update-sshkeys and ltsp-update-image didn't help. The image seems to be broken.

Daniel Milde (daniel-milde) wrote :

I tried another client and now i/o errors don't appear even on the first device. Login works properly (for second unprivileged user as well).

But there is another huge bug - the X server mirrors the screen, so it's unreadable. Tried on Asus EEE PC 1000H and Lenovo 3000 N200.

Daniel Milde (daniel-milde) wrote :

Update:

Works for me. Do you have properly set network? With static IP address for server?

The bug with unreadable screen on client is caused by Nvidia drivers on server.

Changed in ltsp (Ubuntu):
status: Incomplete → Fix Committed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ltsp - 5.1.90-0ubuntu2

---------------
ltsp (5.1.90-0ubuntu2) karmic; urgency=low

  * Fix login not working after installation (LP: #439611)

 -- Stephane Graber <email address hidden> Mon, 05 Oct 2009 00:08:08 -0400

Changed in ltsp (Ubuntu):
status: Fix Committed → Fix Released
tags: added: iso-testing
Martin-Éric Racine (q-funk) wrote :

This affects Lucid as well. Login repeatedly fails as above. Updating the keys and the images did not help.

Sameer Verma (sverma-sfsu) wrote :

Confirmed on Lucid. I have ltsp-server 5.2.1-0ubuntu9 with 33 workstations working with an external DHCP service. We use dnsmasq (backported from Maverick because of the udhcpc bug). Two to three accounts end up not being able ot log in every time the lab is full.

Updating the keys did not help. Where should I look?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers