ltsp-client chroot is missing the python-serial package

Bug #368079 reported by joe_d on 2009-04-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
Undecided
Unassigned

Bug Description

This occurs in 64-bit Ubuntu 9.04

From the chroot, a 'ps aux | grep jetpipe' shows that Jetpipe is not running.

In 8.04, the /opt/ltsp/i386/etc/rcS.d/S32ltsp-client-setup file contained '/usr/sbin/jetpipe ${DEVICE} ${PORT}' on line 130, but this no longer seems to be the case on 9.04.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I don't really know how jetpipe is supposed to work but maybe it'll only
start when the matching lts.conf parameters are set.

Stéphane
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkn16hsACgkQjxyfqkjBhuxrsgCeNBvRQqgWLctbriF1IQwdjUXg
0IMAnjpBWd2Zn/GUCvLZbgKdP6UYGxG9
=aJ5v
-----END PGP SIGNATURE-----

It probably is only supposed to start when the appropriate parameters are set in lts.conf, but even with all of the instructions at http://www.ltsp.org/twiki/bin/view/Ltsp/Printers followed, it is still not running in the chroot after a successful boot.

I suppose it's possible that it is being executed from somewhere other than S32ltsp-client-setup now, but execution is failing.

The reason I say this is because if I manually run `/usr/sbin/jetpipe /dev/usb/lp0 9100' from the chroot, it fails with an error relating to the line `import serial'. If that line is commented out, jetpipe runs and works exactly as it's supposed to, allowing access to the /dev/usb/lp0 device via a connection to port 9100.

Oliver Grawert (ogra) wrote :

the following workaround should fix the issue:

sudo chroot /opt/ltsp/i386 apt-get install python-serial
sudo ltsp-update-image

apparently there was no dependency added to the ltsp-client package when jetpipe grew serial support.

summary: - ltsp not launching jetpipe on startup
+ ltsp-client chroot is missing the python-serial package
joe_d (joseph-d) wrote :

I can confirm that the above-mentioned workaround solves the problem. Thank you!

Adilson Oliveira (agoliveira) wrote :

I found the exact same problem yesterday and can confirm the bug. I think this is a high importance bug as printers that were working no longer work and it's a case for a SRU.

Changed in ltsp (Ubuntu):
status: New → Confirmed
Stéphane Graber (stgraber) wrote :

Dependency has been fixed in Karmic.

Changed in ltsp (Ubuntu):
status: Confirmed → Fix Released
Roland Giesler (lifeboy) wrote :

It seems that it doens't work in Maverick anymore. The behaviour that was described 9.04 is also found in 10.10.

Python serial is installed, yet jetpipe is not triggered when a USB printer is plugged into a thin client machine.

Roland Giesler (lifeboy) wrote :

However, in Maverick the /opt/ltsp/i386/etc/rcS.d/S32ltsp-client-setup file is substantially smaller and not reference is made to jetpipe at all. udev is refered to, but there are no udev script to run in the event that a device is connected.

Does anyone know how this works and what is wrong?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers