Ubuntu

time zone not correct on client

Reported by laga on 2008-03-02
2
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I've found that the time zone is not set correctly on the client. The 035-copy-timezone plugin works and /etc/timezone inside the server has the correct timezone, but it looks like /etc/localtime is not updated properly:

user@box ~> cat /opt/ltsp/i386/etc/localtime
TZif2UTCTZif2UTC
UTC0

I'd expect to see GMT+1 (or whatever is appropriate for Europe/Berlin) in there.

Running dpkg-reconfigure tzdata inside the chroot followed by ltsp-update-image fixes this for me. It's 100% reproducible. I'm using the LTSP packages from Hardy on Gutsy and my chroot is Hardy.

Related branches

Oliver Grawert (ogra) wrote :

seems we should add that command to the plugin then :)

laga (laga) wrote :

Yup. I've finally had time to test it.
I'm not sure if --priority=critical is needed because the debconf frontend is set to noninteractive already.

--- 035-copy-timezone.orig 2008-03-04 15:10:50.432578357 +0100
+++ 035-copy-timezone 2008-03-03 19:44:25.460383649 +0100
@@ -3,6 +3,8 @@
         # Set default timezone to that of server Bug #126443
         if [ -f /etc/timezone ]; then
             cp /etc/timezone $ROOT/etc/timezone
+ # fix https://bugs.launchpad.net/ubuntu/+source/ltsp/+bug/197723
+ chroot $ROOT dpkg-reconfigure --priority=critical tzdata
         fi
         ;;
 esac

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ltsp - 5.0.40~bzr20080212-0ubuntu3

---------------
ltsp (5.0.40~bzr20080212-0ubuntu3) hardy; urgency=low

  * add CONFIGURE_FSTAB lts.conf option to override fstab
    creation on client (LP: #198114)
  * use servers timezone during chroot creation (LP: #197723)
  * added note to lts-parameters.txt taht teh values apply to
    lts.conf only (LP: #197744)
  * merge mythbuntu plugin changes (LP: #195943)

 -- Oliver Grawert <email address hidden> Fri, 14 Mar 2008 01:05:21 +0100

Changed in ltsp:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers