ltsp_config hanging in NFS_root environment

Bug #156229 reported by Ondar on 2007-10-23
4
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
Undecided
Scott Balneaves

Bug Description

Binary package hint: ltsp-client

Startup procedure never returns the ltsp_config script when booting from NFS method is used.
Further investigation shows, that the problem is in this line:
nbd_pid=$(pgrep -f $(cat /proc/mounts|grep /rofs|grep nbd|cut -d" " -f1) 2>/dev/null)
when I comment this line out, the initialization procedure finishes correctly.

Note: when I run this script manually from within a shell, it returns fine even with the line above enabled.
It only affects Gutsy.

Ondrej

Oliver Grawert (ogra) wrote :

can you attach your /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default file please ?

Oliver Grawert wrote:
> can you attach your /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default
> file please ?
>
>
Hi Oliver,
Well, I boot from RHEL so my pxelinux config file is stored on a
different location. Anyway - here is it:
prompt 0
label linux
  kernel ltsp-gutsy/vmlinuz
  append rw initrd=ltsp-gutsy/initrd.img
nfsroot=192.168.60.17:/pxeboot/ltsp-gutsy

Regards,
Ondrej

The information contained in this e-mail and in any attachments is confidential and is designated solely for the attention of the intended recipient(s). If you are not an intended recipient, you must not use, disclose, copy, distribute or retain this e-mail or any part thereof. If you have received this e-mail in error, please notify the sender by return e-mail and delete all copies of this e-mail from your computer system(s).
Please direct any additional queries to: <email address hidden>.
Thank You.
Silicon and Software Systems Limited. Registered in Ireland no. 378073.
Registered Office: Whelan House, South County Business Park, Leopardstown, Dublin 18

I can confirm this bug. When not using nbd, the ltsp_script makes the screen script to exit. Because a variable is empty, pgrep -f faile. Attached, there is a patch to correct this. This patch have been tested on nbd setup, and nfs setup.

Scott Balneaves (sbalneav) wrote :

Sounds good, we'll get this in for Hardy. Not sure on the process for/if we can patch it for Gutsy

Scott

Changed in ltsp:
assignee: nobody → sbalneav
status: New → Confirmed
Changed in ltsp (Ubuntu):
status: Confirmed → Fix Committed
Alkis Georgopoulos (alkisg) wrote :
Changed in ltsp (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers