[Gutsy] LTSP chroot building progressbar in d-i hangs

Bug #121547 reported by Stéphane Graber on 2007-06-21
2
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
Low
Oliver Grawert

Bug Description

Installing the Edubuntu Server Tribe-1, the install hangs while "Building LTSP chroot" (50%).

Looking at the console it's : "Updating /var/lib/tftpboot directories for chroot: /opt/ltsp/i386"
I waited for 30minutes without having it to move to the next step.

Attached are the syslog and the "ps aux".

Stéphane Graber (stgraber) wrote :
Stéphane Graber (stgraber) wrote :

this is a result of the new squashfs image builder we use now, since tribe 2 it shouldnt take more than 10-15 min but there is no feedback yet to the first consle where the user sits, if you switch with alt-f4 to the fourth console you should see the process going forward.

Changed in ltsp:
assignee: nobody → ogra
status: New → Confirmed
Martin Pitt (pitti) wrote :

This is mainly a cosmetical problem, so moving to tribe-4. Not worth delaying the T3 release for this.

Martin Pitt (pitti) wrote :

Not a showstopper, thus moving again, but it should be fixed soon.

Oliver Grawert (ogra) wrote :

first half is solved, i got a working prototype that needs to get waved into teh udeb now

Changed in ltsp:
status: Confirmed → In Progress
Changed in ltsp:
importance: Undecided → Low
Oliver Grawert (ogra) wrote :

ltsp (5.0.26) gutsy; urgency=low

  [Oliver Grawert <email address hidden>]
  * new udeb postinst (and new template) added, fixes (LP: #121547)
    we have full progress reporting in teh installer now :)
  * added option --skipimage to ltsp-build-client to supress ltsp-update-image
    execution in d-i (we run it separately in the udeb)
  * its not an error if the port is set in inetd.conf.

  [Scott Balneaves <email address hidden>]
  * Close LP: #137461
  * added missing manpages for ltsp-update-image, and nbdrootd
  * Fix a couple of debian control issues
  * Fix bug with localdev: encrypt tunnel for X forwarding for all things.
    LDM_DIRECTX will override X, but all other communication should be
    encrypted
  * since we're zeroing /etc/hostname in the plugin, don't need to do it in
    the initramfs, add plugin to Ubuntu
  * fixing problem with hostnames not being set in the client, even if
    they're specified in dhcpd
  * Added ram limiting from old 4.2, fixed typo

  [Vagrant Cascadian <email address hidden>]
  * merged patch to set hostname from the initramfs
  * merge with scotts-gutsy, *except* keep debian logo.

 -- Oliver Grawert <email address hidden> Thu, 06 Sep 2007 13:24:27 +0200

Changed in ltsp:
status: In Progress → Fix Released
Oliver Grawert (ogra) wrote :

shows up in a different way now, but still not solved it seems :(

Changed in ltsp:
status: Fix Released → In Progress
Oliver Grawert (ogra) wrote :

ltsp (5.0.37) gutsy; urgency=low

  * revert the ltsp-build-client behavior of the d-i progress bar to teh
    feisty behavior, together with the new compress progressbar that should
    suffice to fix LP: #121547

  * ignore getltscfg if it fails during boot, so we dont need dummy entries
    in "comment only" lts.conf files in the future

 -- Oliver Grawert <email address hidden> Fri, 05 Oct 2007 18:03:54 +0200

Changed in ltsp:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers