'ltsp-client-builder' failed with error code 1 during LTSP server installation with 20120213.1 alternate images

Bug #1124029 reported by Para Siva on 2013-02-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
High
Unassigned
Precise
High
Stéphane Graber

Bug Description

== Rationale ==
For some reason /run/resolvconf sometimes (race condition) doesn't exist at the time we try to setup LTSP. This is a bug in its own but is then making a touch /etc/resolv.conf fail in ltsp-client-builder.

The workaround for now is to call mkdir -p /run/resolvconf through in-target, thereby ensuring /run/resolvconf always exists, which should make the touch succeed.

== Test case ==
It's unfortunately a race condition, so short of trying a few installs and considering it fixed, there's no trivial way of confirming this.
One could try to remove /run/resolvconf on purpose just before ltsp-client-builder is called and see what happens, but that'd require some pretty careful timing.

== Regression potential ==
This is a mkdir -p of a directory under /run, so it really shouldn't ever fail.
However the fix is just working around a bigger problem and if anything inside the target tries to resolve a hostname, this will still fail as we won't have any DNS servers configured.

--- original report ---

The following error occurs during LTSP server installation on hardware with Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64+mac (20130213.1).

Feb 13 11:40:02 main-menu[409]: (process:21643): mount: mounting proc on /target/proc failed: Device or resource busy
Feb 13 11:40:02 main-menu[409]: WARNING **: Configuring 'ltsp-client-builder' failed with error code 1
Feb 13 11:40:02 main-menu[409]: WARNING **: Menu item 'ltsp-client-builder' failed.

**This is with amd64+mac and will report the outcome of i386 and amd64 installations shortly.

== Test case ==
1) Press F4
2) Choose LTSP
3) Install
(This is a side-by-side installation along with another precise alternate one. Not sure if that's any reason for this)

Para Siva (psivaa) wrote :
Para Siva (psivaa) wrote :
Para Siva (psivaa) wrote :
Para Siva (psivaa) wrote :
Colin Watson (cjwatson) wrote :

The description shows the log from the second attempt. The first attempt says:

Feb 13 11:38:30 in-target: W: Duplicate sources.list entry cdrom://Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64+mac (20130213.1)/ precise/main i386 Packages (/var/lib/apt/lists/Ubuntu%2012.04.2%20LTS%20%5fPrecise%20Pangolin%5f%20-%20Release%20amd64+mac%20(20130213.1)_dists_precise_main_binary-i386_Packages)
Feb 13 11:38:30 in-target: W: Duplicate sources.list entry cdrom://Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64+mac (20130213.1)/ precise/restricted i386 Packages (/var/lib/apt/lists/Ubuntu%2012.04.2%20LTS%20%5fPrecise%20Pangolin%5f%20-%20Release%20amd64+mac%20(20130213.1)_dists_precise_restricted_binary-i386_Packages)
Feb 13 11:38:30 in-target: W: You may want to run apt-get update to correct these problems
Feb 13 11:38:30 in-target: /bin/touch: cannot touch `/etc/resolv.conf'
Feb 13 11:38:30 in-target: : No such file or directory
Feb 13 11:38:30 main-menu[409]: WARNING **: Configuring 'ltsp-client-builder' failed with error code 1

Para Siva (psivaa) on 2013-02-13
description: updated
Colin Watson (cjwatson) wrote :

This worked for me with amd64. (Installing on a blank disk, but I don't think side-by-side makes any difference here.)

Para Siva (psivaa) wrote :

Tried twice afterwords on amd64+mac image

First attempt: Entire disk with network connected ---> The installation succeeded

Second attempt: Side-by-side with no network connected ---> The installation failed. ( the installation fails even after connecting the network afterwards)

description: updated

Hello Parameswaran, or anyone else affected,

Accepted ltsp into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ltsp/5.3.7-0ubuntu2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ltsp (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Stéphane Graber (stgraber)
milestone: none → ubuntu-12.04.2
Changed in ltsp (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in ltsp (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

Regression tested in a VM, looks good.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ltsp - 5.3.7-0ubuntu2.5

---------------
ltsp (5.3.7-0ubuntu2.5) precise-proposed; urgency=low

  * Add an hack to ltsp-client-builder to ensure /run/resolvconf exists in
    the target. This is an hack because /run/resolvconf should always exist
    in there but for some reason, doesn't in some weird corner case.
    This hack avoids some installation failing when trying to touch
    /etc/resolv.conf (LP: #1124029)
 -- Stephane Graber <email address hidden> Wed, 13 Feb 2013 13:08:57 -0500

Changed in ltsp (Ubuntu Precise):
status: Fix Committed → Fix Released
Alkis Georgopoulos (alkisg) wrote :

Since 14.04 there are no alternate CD images, so I'm marking the ltsp (Ubuntu) part of this bug report as Invalid.

Changed in ltsp (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers