[Feisty] LTSP: libGL error: open DRM failed

Bug #110009 reported by Georg Graf on 2007-04-25
8
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
Wishlist
Oliver Grawert

Bug Description

brand-new Feisty Installation, "out of the Box" with only LTSP added

LTSP Client with i815 chipset, xorg for i810 is proper configured (16Bit Color, 42MB memory..)
Xorg.6.log on LTSP-Client reports "direct rendering enabled"

but glxinfo reports "libGL error: open DRM failed (Operation not permitted)"
so, a view lines later there is: "direct rendering: No" - see attachment with complete glxinfo below
running glxinfo in LTSP-Client with sudo reports the same.

I tried also a seperate xorg.conf for this client with
Section "DRI"
 Mode 0666
EndSection

but nothing changed

(Remark: I had some problems more to get LTSP running under Feisty: dhcpd doesn's start and logon is only possible with the statement
SCREEN_02 = startx in lts.conf - no logon with ldm possible - i report this in another bug - this is only for the DRM -Problem)

Georg Graf (georg-graf) wrote :
Matt (matt-openforeveryone) wrote :

I am also having a similar problem when connecting to an Ubuntu 7.10 box from another using ssh -X.
GLX apps work on the client but when running a glx app from the ssh server I get the following errors:
libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering

The is no problem when doing the same using an old SuSE server and the same client.

Output from glxinfo running on the Ubuntu server is attached.

Changed in xorg:
status: Unconfirmed → Confirmed
Changed in xorg:
status: Confirmed → Unconfirmed
Matthew Bowman (matthew-bowman) wrote :

I am having exactly the same issue. I need to run OpenGL apps from the server on the thin clients.

Matthew Bowman (matthew-bowman) wrote :
Timo Aaltonen (tjaalton) wrote :

To me it seems to be an issue with LTSP setup. Check 7.10 or Hardy alpha3.

Changed in xorg:
status: New → Incomplete
Oliver Grawert (ogra) wrote :

feisty had no GL support at all on the feature list, we deliberately didnt install libgl1-mesa-dri...
in gutsy this package was added and should make basic GL and composite possible with some manual configuration work.

Changed in ltsp:
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Robert Pickle (rpickle) wrote :

I'm getting the same errors in Hardy alpha 3 (up to date as of 2/13/2008) with libgl1-mesa-dri installed. What other "manual configuration work" is required? I added the whole "Section DRI.." thing to my xorg.conf to no avail. I don't have any LTSP packages installed.

Oliver Grawert (ogra) wrote :

did you use the proper runes to recreate the image and anything ?
if you are testing hardy you should make sure the ltsp-server package is up to date and wipe and rebild the chroot and image for every new version to get a clean setup ... libgl1-mesa-dri was added to the default install with the 5.0.40 package

Oliver Grawert (ogra) wrote :

also note that nobodys works on XDMCP integration in ltsp since we dont support it (beyond basic functionallity). if you say you use SCREEN_07=startx that forces the insecure XDMCP connection. can you confirm that you see the issue without forcing away the ltsp disply manager ?

Robert Pickle (rpickle) wrote :

Hi Oliver,

I've rebuild and installed fresh from daily ISOs to no avail. However I'm a little confused as to your 2nd post- I do have the libxdmcp6 and dev packages installed, but am not sure how I am forcing an xdmcp connection or how to even check. I'm just trying to "ssh -X" into a cluster.

Robert Pickle (rpickle) wrote :

well, this seems to have fixed itself now.

Oliver Grawert (ogra) wrote :

wonderful, closing then, feel free to reopen if you see it again.

Changed in ltsp:
assignee: nobody → ogra
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers