sound config not reset after thin client usage

Bug #105709 reported by Oliver Grawert on 2007-04-11
12
Affects Status Importance Assigned to Milestone
ltsp (Ubuntu)
Medium
Oliver Grawert
Feisty
Undecided
Oliver Grawert

Bug Description

if you log in directly on an ltsp server after having used a thin client on the same server with the same account, the login hangs, apparently gnome-session cant handle a virtual alsa device that has no backend connected, a workaround is to use the ltsp-sound script to unset the pulse config if no thin client is used and pulse isnt installed on the server

Oliver Grawert (ogra) wrote :

The fix is to replace /etc/X11/Xsession.d/80_ltsp-sound with the following script, this should go into feisty-updates:

if [ -n "$LTSP_CLIENT" ]; then
        /usr/bin/asoundconf set-pulseaudio
else
    if [ !$(which pulseaudio) ]; then
            /usr/bin/asoundconf unset-pulseaudio
    fi
fi

I also got stung by this bug, thus setting to confirmed

Changed in ltsp:
assignee: nobody → ogra
status: Unconfirmed → Confirmed
Oliver Grawert (ogra) on 2007-04-18
Changed in ltsp:
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Comments about SRU:

* Please get this fixed and tested in gutsy first.
* The patch (r520) should be polished a bit: [ !$(which pulseaudio) ] => ! type pulseaudio >/dev/null 2>&1
  This avoids unsafe quoting, the lack of a test operator, and avoids a subshell.
* The changelog (r521) should not talk about 'added fixed script', but explain the change and the impact.

Changed in ltsp:
assignee: nobody → ogra
status: Unconfirmed → Needs Info
Martin Pitt (pitti) wrote :

No visible progress on this, so I unsubscribed ubuntu-sru for now. Please re-subscribe when this is fixed in gutsy and my other points in comment 3 are solved. Thank you!

This also seems to be quite serious and simple to fix, so let's get it into Tribe 4.

Changed in ltsp:
importance: Undecided → Medium
Scott Balneaves (sbalneav) wrote :

Fixed in my tree (v401)

Changed in ltsp:
status: Incomplete → Fix Committed
Oliver Grawert (ogra) wrote :

ltsp (5.0.22) gutsy; urgency=low
 ...
  * Closes Launchpad bug 105709: updated 80_ltsp-sound to address unsafe quoting.
...

Changed in ltsp:
status: In Progress → Fix Released

Please close for Feisty as Won't Fix? This goes for all the other Feisty bugs.

Hew McLachlan (hew) wrote :

Ubuntu Feisty Fawn is no longer supported, so a SRU will not be issued for this release. Marking Feisty as Won't Fix.

Changed in ltsp:
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers