Update Package request for lsvpd

Bug #1705582 reported by bugproxy on 2017-07-20
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Foundations Team
lsvpd (Ubuntu)
High
Canonical Foundations Team
Xenial
High
Canonical Foundations Team

Bug Description

SRU
<SRU test description missing>

---Problem Description---
Update Package request for lsvpd

---uname output---
Linux tuleta4u-lp9 4.10.0-27-generic #30~16.04.2-Ubuntu SMP Thu Jun 29 16:06:52 UTC 2017 ppc64le ppc64le ppc64le GNU/Linux

---Steps to Reproduce---
 lsvpd

Userspace tool common name: lsvpd

Please pull below patches for lsvpd package.

------------------
commit 7499dcc199da96befef7bb788d62e446833137b2
Author: Ankit Kumar <email address hidden>
Date: Mon Dec 7 11:59:05 2015 +0530

    lsvpd: Unique name for temp Device file given and file closed before deleting it.

    This piece of code used mkstemp to get unique name of file in that particular
    directory. As file name is not hardcoded, so parameter for device_close and
    device_open is changed to pass device location path.

    This patch also fixes the issue of opened file which is not closed by closing
    file descriptor.

    Signed-off-by: Ankit Kumar <email address hidden>
    [Removed redundant variable - Vasant]
    Signed-off-by: Vasant Hegde <email address hidden>

-----

Backported patch on top of 1.7.6 provided

tags: added: architecture-ppc64 bugnameltc-156877 severity-high targetmilestone-inin16043
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → lsvpd (Ubuntu)
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Foundations Team (canonical-foundations)
importance: Undecided → High
tags: added: upgrade-software-version
tags: added: triage-g
Manoj Iyer (manjo) on 2017-08-21
tags: added: triage-a
removed: triage-g
Changed in lsvpd (Ubuntu):
importance: Undecided → High
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Foundations Team (canonical-foundations)
Matthias Klose (doko) wrote :

the patch doesn't apply for 1.7.8

Changed in lsvpd (Ubuntu):
status: New → Incomplete
Changed in ubuntu-power-systems:
status: New → Incomplete
tags: added: triage-g
removed: triage-a

------- Comment From <email address hidden> 2017-08-22 05:52 EDT-------
(In reply to comment #7)
> the patch doesn't apply for 1.7.8

This request was created for 16.04. LTS release.

On 16.04.02 , We do have lsvpd-1.7.6. and hence this patch is backported on 1.7.6.

dpkg -l | grep lsvpd
ii lsvpd 1.7.6-0ubuntu3 ppc64el

For lsvpd-1.7.8, this patch is not required at all.

~Ankit

Matthias Klose (doko) wrote :

Ankit, the package is now uploading and waiting for review. Please complete the package description how to test this update

description: updated
Changed in lsvpd (Ubuntu):
status: Incomplete → In Progress
Steve Langasek (vorlon) on 2017-08-22
Changed in lsvpd (Ubuntu):
status: In Progress → Fix Released
Changed in lsvpd (Ubuntu Xenial):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in ubuntu-power-systems:
assignee: Canonical Foundations Team (canonical-foundations) → nobody
Manoj Iyer (manjo) on 2017-08-24
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Foundations Team (canonical-foundations)
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-08-24 00:58 EDT-------
(In reply to comment #10)
> Ankit, the package is now uploading and waiting for review. Please complete
> the package description how to test this update

This patch can be tested on system where,
Number of scsi device node (/dev/sg<X>) are more than total number of device node that can be opened at a time.(using open call)

The reason being is : In device_close call earlier we were just doing unlink of opened device file (/tmp/nodexyz) without closing descriptor which eventually will result in sort of file descriptor and database creation will failed as we won't have free descriptor to be given for creating database.

This issue can be observed only on system where scsi device node is more than the number of device file can be opened at a time on system.

Procedure to test:
1. run vpdupdate (on system with above details)

and vpdupdate will fail.

~Ankit

Hello bugproxy, or anyone else affected,

Accepted lsvpd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lsvpd/1.7.6-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lsvpd (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in ubuntu-power-systems:
status: Incomplete → Fix Committed
tags: added: id-5971a7c282b84c68f529da31

------- Comment From <email address hidden> 2017-10-08 21:57 EDT-------
Ankit verified the patch in

https://launchpad.net/ubuntu/+source/lsvpd/1.7.6-0ubuntu4

and closed the mirrored IBM bz.

tags: removed: verification-needed verification-needed-xenial
Steve Langasek (vorlon) on 2017-10-09
tags: added: verification-done-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsvpd - 1.7.6-0ubuntu4

---------------
lsvpd (1.7.6-0ubuntu4) xenial-proposed; urgency=medium

  * SRU: LP: #1705582
  * Unique name for temp Device file given and file closed before deleting it.

 -- Matthias Klose <email address hidden> Tue, 22 Aug 2017 12:55:39 +0200

Changed in lsvpd (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lsvpd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers