[Ubuntu 14.04.3] lsvpd package update

Bug #1461557 reported by bugproxy on 2015-06-03
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lsvpd (Ubuntu)
Undecided
Adam Conrad
Trusty
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

lsvpd package update:

This utility lists device Vital Product Data (VPD), which includes the following information and more: vendor, version, revision level, serial number. This utility has been tested on ppc64, ppc, and i386 platforms.

The upstream location is:
http://sourceforge.net/projects/linux-diag/files/lsvpd-new/
Patches required for 14.04.3 release:

== Comment: #4 - Janani V <email address hidden> - 2015-06-03 07:57:42 ==
From a1ea1852fc3706bb80a821d792c5ef174378c3a6 Mon Sep 17 00:00:00 2001
From: Vasant Hegde <email address hidden>
Date: Wed, 19 Nov 2014 15:39:00 +0530
Subject: [PATCH 1/4] VPD: Add OPAL version details

Recently we have added firmware/version property in DT for
PowerKVM platform which contains OPAL version details. Also
deprecated old firmware/git-id property.

Use this new property to get firmware version details. Also
for backward compitability purpose, if new property (version)
is not available then check for old property (git-id).

Output on old FW:
  *CL OPAL v3 d427354

Output on new FW:
  *CL OPAL skiboot-2.1.1-fw810.20-1

Signed-off-by: Vasant Hegde <email address hidden>
Reviewed-by: Janani Venkataraman <email address hidden>

== Comment: #5 - Janani V <email address hidden> - 2015-06-03 07:58:27 ==
From 0fd7d1f36ffdc1bcf408e29d499c08640cb8a074 Mon Sep 17 00:00:00 2001
From: Janani Venkataraman <email address hidden>
Date: Wed, 3 Jun 2015 06:40:09 -0500
Subject: [PATCH 2/4] Look up at Device-Tree to fill Model-Name for PowerNV
 host

In the case of PowerKVM host, the model name is picked up
from the device tree. In the powerVM machines, it is picked up
from cpu_mod_conv.conf

Sample output from PowerNV host:
[root@tul169p1 linux-diag-lsvpd]# ./lscfg
INSTALLED RESOURCE LIST

The following resources are installed on the machine.
+/- = Added or deleted from Resource List.
* = Diagnostic support not available.

  Model Architecture: ppc64
  Model Implementation: Multiple Processor, PCI Bus
  Model Name: 8286-41A, IBM Power System S814

Signed-off-by: Janani Venkataraman <email address hidden>
Signed-off-by: Vasant Hegde <email address hidden>

== Comment: #6 - Janani V <email address hidden> - 2015-06-03 07:59:17 ==
From 7e7638265464a46f9987c1529cfe3a338c87378b Mon Sep 17 00:00:00 2001
From: Janani <email address hidden>
Date: Thu, 4 Dec 2014 14:00:06 +0530
Subject: [PATCH 3/4] lsmcode: Read entire /proc/cpuinfo to fetch platform

The platform field in /proc/cpuinfo for both PowerKVM Guest and
PowerVM LPAR is pSeries. In order to fetch the right platform, we need
to read the entire file. If pSeries (emulated by qemu) is present in
the file, we can be sure the platform is PowerKVM Guest.

Signed-off-by: Janani Venkataraman <email address hidden>
Signed-off-by: Vasant Hegde <email address hidden>

== Comment: #7 - Janani V <email address hidden> - 2015-06-03 07:59:51 ==
From 39ed6501bb3a286600941b600ea40557f8f6a4d8 Mon Sep 17 00:00:00 2001
From: Janani <email address hidden>
Date: Wed, 28 Jan 2015 14:28:35 +0530
Subject: [PATCH 4/4] lsvpd: Defer the freeing of devSg

After calling basename, we need to defer freeing the pointer.

This is because the basename function may return pointers to statically
allocated memory which may be overwritten by subsequent calls. They may
return a pointer to some part of path and hence the string refered to
by the path should not be modified or freed until the pointer returned
by the function is no longer required.

Signed-off-by: Janani Venkataraman <email address hidden>
Signed-off-by: Kamalesh Babulal <email address hidden>
Reviewed-by: Naveen N. Rao <email address hidden>
[Removed redundant return - Vasant]
Signed-off-by: Vasant Hegde <email address hidden>

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-124145 severity-high targetmilestone-inin14043

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1461557/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Steve Langasek (vorlon) on 2015-06-03
Changed in ubuntu:
assignee: nobody → Adam Conrad (adconrad)
milestone: none → ubuntu-14.04.3
Adam Conrad (adconrad) on 2015-07-31
affects: ubuntu → lsvpd (Ubuntu)

Hello bugproxy, or anyone else affected,

Accepted lsvpd into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lsvpd/1.7.5-0ubuntu2~15.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lsvpd (Ubuntu Vivid):
status: New → Fix Committed
tags: added: verification-needed
Changed in lsvpd (Ubuntu):
status: New → Fix Committed
Changed in lsvpd (Ubuntu Trusty):
status: New → Fix Committed
Adam Conrad (adconrad) wrote :

Hello bugproxy, or anyone else affected,

Accepted lsvpd into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lsvpd/1.7.5-0ubuntu2~14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsvpd - 1.7.5-0ubuntu2

---------------
lsvpd (1.7.5-0ubuntu2) wily; urgency=medium

  * Upstream backports for hardware support and bugfix (LP: #1461557)
    - d/p/0001-VPD-Add-OPAL-version-details.patch:
      Add OPAL version details for PowerKVM.
    - d/p/0002-Look-up-at-Device-Tree-to-fill-Model-Name-for-PowerN.patch:
      Use the device tree to pick the right model name on PowerNV.
    - d/p/0003-lsmcode-Read-entire-proc-cpuinfo-to-fetch-platform.patch:
      Do a better job figuring out what platform we're on by reading cpuinfo.
    - debian/patches/0004-lsvpd-Defer-the-freeing-of-devSg.patch:
      Defer the freeing of devSg, because it gets passed to basename().

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 05 Aug 2015 01:02:55 -0400

Changed in lsvpd (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsvpd - 1.7.5-0ubuntu2~14.04

---------------
lsvpd (1.7.5-0ubuntu2~14.04) trusty; urgency=medium

  * Upstream backports for hardware support and bugfix (LP: #1461557)
    - d/p/0001-VPD-Add-OPAL-version-details.patch:
      Add OPAL version details for PowerKVM.
    - d/p/0002-Look-up-at-Device-Tree-to-fill-Model-Name-for-PowerN.patch:
      Use the device tree to pick the right model name on PowerNV.
    - d/p/0003-lsmcode-Read-entire-proc-cpuinfo-to-fetch-platform.patch:
      Do a better job figuring out what platform we're on by reading cpuinfo.
    - debian/patches/0004-lsvpd-Defer-the-freeing-of-devSg.patch:
      Defer the freeing of devSg, because it gets passed to basename().

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 05 Aug 2015 01:02:55 -0400

Changed in lsvpd (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lsvpd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsvpd - 1.7.5-0ubuntu2~15.04

---------------
lsvpd (1.7.5-0ubuntu2~15.04) vivid; urgency=medium

  * Upstream backports for hardware support and bugfix (LP: #1461557)
    - d/p/0001-VPD-Add-OPAL-version-details.patch:
      Add OPAL version details for PowerKVM.
    - d/p/0002-Look-up-at-Device-Tree-to-fill-Model-Name-for-PowerN.patch:
      Use the device tree to pick the right model name on PowerNV.
    - d/p/0003-lsmcode-Read-entire-proc-cpuinfo-to-fetch-platform.patch:
      Do a better job figuring out what platform we're on by reading cpuinfo.
    - debian/patches/0004-lsvpd-Defer-the-freeing-of-devSg.patch:
      Defer the freeing of devSg, because it gets passed to basename().

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 05 Aug 2015 01:02:55 -0400

Changed in lsvpd (Ubuntu Vivid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints