error messages from lsscsi

Bug #282518 reported by Christof Schmitt on 2008-10-13
8
Affects Status Importance Assigned to Milestone
lsscsi (Ubuntu)
Undecided
Chuck Short
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Chuck Short

Bug Description

Binary package hint: lsscsi

Running lsscsi on the current version of intrepid yields these error messages:

$ lsscsi
sdev_scandir_sort: left parse failed
sdev_scandir_sort: left parse failed
sdev_scandir_sort: left parse failed
sdev_scandir_sort: right parse failed
[target0:0:0]type? vendor? model? rev? -
[target2:0:0]type? vendor? model? rev? -
[0:0:0:0] disk ATA SAMSUNG SP1634N UZ10 -
[2:0:0:0] cd/dvd TSSTcorp CD/DVDW SH-S183A SB02 -

The package version:

Package: lsscsi
Priority: optional
Section: admin
Installed-Size: 152
Maintainer: Ubuntu MOTU Developers <email address hidden>
Original-Maintainer: Matt Taggart <email address hidden>
Architecture: i386
Version: 0.19-1
Depends: libc6 (>= 2.5-0ubuntu1)
Filename: pool/main/l/lsscsi/lsscsi_0.19-1_i386.deb
Size: 34398
MD5sum: c12e55e12fb48548faf38df28086a3da
SHA1: 3f9779076a561639bdd052c47049784568078bed
SHA256: 4854ef027b4bcdef5413ba726c23d8cf677213ffcd8faf5288ff802c818325cb
Description: list all SCSI devices (or hosts) currently on system
 Uses information in sysfs (linux kernels 2.6.0 and later) to list all
 scsi devices (or hosts) currently attached to the system. Options can
 be used to control the amount and form of information provided for each
 device.
Bugs: mailto:<email address hidden>
Origin: Ubuntu

$ lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

Downloading and installing the package lsscsi_0.21-0.1_i386.deb from http://sg.danny.cz/scsi/lsscsi.html fixes the problem. With this version, the output looks good:

$ lsscsi -t
[0:0:0:0] disk /dev/sda
[2:0:0:0] cd/dvd /dev/scd0

Probably the package in intrepid only needs updating to the current version.

Chuck Short (zulcss) wrote :

This is due to changes in the scsi subsystem. I was able tor reproduce this error on my machine. The new version fixes this error (0.21) and its made for kernels 2.6.24+.

Please sync the new lsscsi from debian unstable. If you have any questions please feel free to ask me.

Regards
chuck

Changed in lsscsi:
status: New → Confirmed
Steve Langasek (vorlon) wrote :

I assume that ubuntu-release has been subscribed to this bug because you're asking for a freeze exception. Please provide the information requested by <https://wiki.ubuntu.com/FreezeExceptionProcess>.

Chuck Short (zulcss) wrote :

This due to changes in the the SCSI subsystem in 2.6.27. I have backported the patch from jaunty which fixes this issue. I have attached the debdiff. There should be no regressions with this patch.

Steps to reproduce:

1. Install lsscsi
2. Run lsscsi
3. You will get results similar to above.

If you have any questions please let me know.

Regards
chuck

I did not find a prebuilt package, but i could verify that lsscsi_0.19.orig.tar.gz with lsscsi_0.19-1.diff.gz and the fix applied compiles and works as expected:

$ ./lsscsi
[0:0:0:0] disk ATA SAMSUNG SP1634N UZ10 -
[2:0:0:0] cd/dvd TSSTcorp CD/DVDW SH-S183A SB02 -

Thanks for the work, Chuck.

regards,

Christof

Martin Pitt (pitti) wrote :

Please fix in Jaunty ASAP.

Changed in lsscsi:
assignee: nobody → zulcss
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Just tested lsscsi_0.19-1ubuntu1_i386.deb. This package also works fine, the output is the same as in the test before.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsscsi - 0.19-1ubuntu1

---------------
lsscsi (0.19-1ubuntu1) intrepid-proposed; urgency=low

  * Added fixes for scsi subsystem changes in 2.6.27. (LP: #282518)

 -- Chuck Short <email address hidden> Wed, 03 Dec 2008 11:18:05 -0500

Changed in lsscsi:
status: Fix Committed → Fix Released
Chuck Short (zulcss) wrote :

This has been fixed for jaunty already.

chuck

Changed in lsscsi:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments