lsof got can't stat() tmpfs file system errors

Bug #192734 reported by Estro on 2008-02-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lsof (Ubuntu)
Undecided
Unassigned

Bug Description

I tried to use lsof and got the following errors, even when I logged in as root. Can somebody help? Here is my environment:

HW: Compaq Presario C714NR
OS: Linux Compaq23 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

Thanks,

Estro
=========================================
$ lsof /dev/sda2
lsof: WARNING: can't stat() tmpfs file system /dev/shm/var.run
      Output information may be incomplete.
lsof: WARNING: can't stat() tmpfs file system /dev/shm/var.lock
      Output information may be incomplete.

hieronymus (bugs-el-maghraby) wrote :

hi,

If got the same problem with an
"Linux Domino02 2.6.15-29-server #1 SMP Mon Sep 24 17:37:57 UTC 2007 i686 GNU/Linux"
running IBM Lotus Domino 7.

/usr/bin/lsof -n -P -S 5 -p 8502,8494,6974
lsof: WARNING: can't stat() tmpfs file system /dev/shm/var.run
      Output information may be incomplete.
lsof: WARNING: can't stat() tmpfs file system /dev/shm/var.lock
      Output information may be incomplete.

Anything new?

thank, too,

hieronymus

Same problem here:

root@pablo-server:~# lsof /tmp/
lsof: WARNING: can't stat() tmpfs file system /dev/shm/var.run
      Output information may be incomplete.
lsof: WARNING: can't stat() tmpfs file system /dev/shm/var.lock
      Output information may be incomplete.

root@pablo-server:~# uname -a
Linux pablo-server 2.6.22.19 #1 SMP Fri Feb 29 00:16:23 ARST 2008 i686 GNU/Linux

Thanks, Pablo.

William Roe (willroe) wrote :

Same here:

> lsof /home/simon
lsof: WARNING: can't stat() tmpfs file system /dev/shm/var.run
      Output information may be incomplete.
lsof: WARNING: can't stat() tmpfs file system /dev/shm/var.lock
      Output information may be incomplete.

> uname -a
Linux lanserv 2.6.22-14-386 #1 Tue Dec 18 07:34:24 UTC 2007 i686 GNU/Linux

Thanks,
Will

While trying to fix the issue, i found that i had the following filesystems mounted on my system (/proc/mounts):

tmpfs /dev/shm tmpfs rw,size=278528k 0 0
tmpfs /dev/shm/var.run tmpfs rw,nosuid,nodev,noexec,mode=755 0 0
tmpfs /dev/shm/var.lock tmpfs rw,nosuid,nodev,noexec 0 0
tmpfs /dev/shm tmpfs rw,size=278528k 0 0

So, i unmounted them, and left only tmpfs /dev/shm tmpfs rw,size=278528k 0 0 . It seems to be working fine now. Also you can try updating you're version of lsof.

Daniel T Chen (crimsun) on 2008-11-29
Changed in lsof:
status: New → Invalid
elichai2 (elichai2) on 2014-12-13
Changed in lsof (Ubuntu):
status: Invalid → Incomplete
status: Incomplete → Opinion
status: Opinion → Confirmed
elatllat (elatllat) wrote :

I can reliably reproduce this issue by restarting the remote service or server.
1) cifs should recover but instead is unusable until remount and starts flooding the server (other file systems have a errors=remount-ro option; cifs would benefit from a errors=remount option)
2) lsof should somehow list that cifs is attempting to use the mount

lsof | grep ws
lsof: WARNING: can't stat() cifs file system /media/ws
      Output information may be incomplete.

uname -a
Linux raspberrypi 4.9.24+ #993 Wed Apr 26 17:56:54 BST 2017 armv6l GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers