SIGBUS on panda board (armel)

Bug #653082 reported by LaMont Jones on 2010-10-01
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
lshw
Fix Released
Unknown
lshw (Debian)
Fix Released
Unknown
lshw (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lshw

On a panda board, any invocation of lshw dies with SIGBUS. dmesg has:
[40613.328338] Unhandled fault: external abort on non-linefetch (0x018) at 0x40155000

And "strace lshw" shows:
...
open("/dev/mem", O_RDONLY) = 3
open("/proc/efi/systab", O_RDONLY) = -1 ENOENT (No such file or directory)
mmap2(NULL, 32, PROT_READ, MAP_SHARED, 3, 0xe0) = 0x400b8000
--- SIGBUS (Bus error) @ 0 (0) ---
+++ killed by SIGBUS +++
Bus error

cpuinfo has:
cat /proc/cpuinfo
Processor : ARMv7 Processor rev 2 (v7l)
processor : 0
BogoMIPS : 2013.49

processor : 1
BogoMIPS : 1963.08

Features : swp half thumb fastmult vfp edsp thumbee neon vfpv3
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x1
CPU part : 0xc09
CPU revision : 2

Hardware : OMAP4430 Panda Board
Revision : 0020
Serial : 0000000000000000

John Garland (johnnybg) wrote :

lshw -disable dmi seems to work for me as a workaround

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lshw (Ubuntu):
status: New → Confirmed
Changed in lshw (Debian):
status: Unknown → New
Changed in lshw:
status: Unknown → New
Changed in lshw:
status: New → Fix Released
Changed in lshw (Debian):
status: New → Confirmed
Changed in lshw (Debian):
status: Confirmed → Fix Released
dann frazier (dannf) wrote :

This was fixed in Ubuntu during the saucy/13.10 cycle.

lshw (02.16-2) unstable; urgency=low

  * Closes: #525217
    - lshw: segfauls on armel (! /proc/efi/systab)
  * Closes: #707152
    - lshw can miscount cpus on devicetree platforms

 -- Ghe Rivero <email address hidden> Thu, 27 Jun 2013 04:10:58 -0400

Changed in lshw (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.