Ubuntu 17.10 blank CD or audio CD not detected

Bug #1720624 reported by corrado venturini on 2017-10-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lshw (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned
nautilus (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned
udisks2 (Ubuntu)
Undecided
Sebastien Bacher
Artful
Undecided
Sebastien Bacher

Bug Description

Audio CD are not detected while data CD and data DVD are detected.
When I insert a data CD or DVD I have a notification and I see the CD in files. With audio CD nothing happens.
Also empty CD and DVD are not detected.
No problem on same PC, different partition with Ubuntu 16.04.
I have the same problem on 3 different PC running Ubuntu 17.10.

I opened a question about this problem: https://answers.launchpad.net/ubuntu/+question/658807
and I was invited to open a bug.

In Ubuntu 16.04
when I insert a blank CD I see a box with a message 'You have just inserted a blank CD. Choose what application ...'
when I insert an audio CD I see a box with a message 'You have just inserted a Audio CD. Choose what application ...'

In Ubuntu 17.10
when I insert a blank CD or an Audio CD nothing happens so I can't access the CD.
when I insert a data CD od DVD I see a notification at the top of the screen and I can see the inserted CD in files.

In attachment:
screenshot of messages from Ubuntu 16.04
messages from 'sudo lshw -c disk' in Ubuntu 16.04
messages from 'sudo lshw -c disk' in Ubuntu 17.10

corrado@corrado-0926:~$ inxi -Fx
System: Host: corrado-0926 Kernel: 4.13.0-12-generic x86_64 bits: 64 gcc: 7.2.0
           Desktop: Gnome 3.26.0 (Gtk 3.22.21-0ubuntu1) Distro: Ubuntu Artful Aardvark (development branch)
Machine: Device: desktop Mobo: ASRock model: H110M-G/M.2 serial: N/A UEFI: American Megatrends v: P1.10 date: 05/11/2017
CPU: Dual core Intel Core i3-7100 (-HT-MCP-) arch: Skylake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15648
           clock speeds: max: 3900 MHz 1: 3900 MHz 2: 3900 MHz 3: 3900 MHz 4: 3900 MHz
Graphics: Card: Intel HD Graphics 630 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.3 ) driver: i915 Resolution: 1680x1050@59.88hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           version: 4.5 Mesa 17.2.1 Direct Render: Yes
Audio: Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-12-generic
Network: Card: Intel Ethernet Connection (2) I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:44:7b:86
Drives: HDD Total Size: 1000.2GB (6.2% used)
           ID-1: /dev/sda model: TOSHIBA_DT01ACA1 size: 1000.2GB
Partition: ID-1: / size: 32G used: 6.0G (20%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 37.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 239 Uptime: 3 min Memory: 782.8/7684.1MB Init: systemd runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.121) inxi: 2.3.37
corrado@corrado-0926:~$

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: lshw 02.18-0.1ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Oct 1 12:50:48 2017
InstallationDate: Installed on 2017-09-29 (2 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
SourcePackage: lshw
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) on 2017-10-01
tags: added: rls-aa-incoming
Doug McMahon (mc3man) on 2017-10-01
Changed in lshw (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) on 2017-10-02
Changed in nautilus (Ubuntu):
status: New → Invalid
Doug McMahon (mc3man) wrote :

If I downgrade udisks2 to udisks2_2.1.8-1ubuntu1 then inserting an audio cd works as expected as does the prompt or setting window for 'autoplay'
With the current udisks2 when inserting an audio cd the drive is not initialized though it tends to work if disc is in the drive when logging in (or fresh boot.

Files used for replacement, i.e. the working set -
gir1.2-udisks-2.0_2.1.8-1ubuntu1_amd64.deb
libudisks2-0_2.1.8-1ubuntu1_amd64.deb
udisks2_2.1.8-1ubuntu1_amd64.deb

Doug McMahon (mc3man) wrote :

this is closest Debian bug found,
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870399

However Debian has moved on to 2.7.3-4 so maybe no movement will be seen there.
Installing 2.7.3-4 here also produces expected results so likely 18.04 will be better..

Doug McMahon (mc3man) on 2017-10-03
Changed in lshw (Ubuntu):
status: Confirmed → Invalid
Iain Lane (laney) on 2017-10-03
Changed in udisks2 (Ubuntu Artful):
assignee: nobody → Sebastien Bacher (seb128)
tags: removed: rls-aa-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks2 (Ubuntu):
status: New → Confirmed
Changed in udisks2 (Ubuntu Artful):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 2.6.5-2ubuntu2

---------------
udisks2 (2.6.5-2ubuntu2) artful; urgency=medium

  * debian/patches/git_property_change.patch:
    - backport an upstream fix for how UDisksClient filters property
      changes, fixes handling of blank or audio cds (lp: #1720624)

 -- Sebastien Bacher <email address hidden> Fri, 06 Oct 2017 13:47:16 +0200

Changed in udisks2 (Ubuntu Artful):
status: Fix Committed → Fix Released

I installed the fix:
corrado@corrado-p7-1011:~$ apt policy udisks2
udisks2:
  Installed: 2.6.5-2ubuntu2
  Candidate: 2.6.5-2ubuntu2
  Version table:
 *** 2.6.5-2ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p7-1011:~$
but while in Ubuntu 16.04
when I insert a blank CD I see a box with a message 'You have just inserted a blank CD. Choose what application ...' and another box with 'Unable to mount blank CD-R disk' ...
when I insert an audio CD I see a box with a message 'You have just inserted a Audio CD. Choose what application ...'
now after installing maintenance and restarted the system I see the inserted CD in Files and on Desktop, but I have no message also I have 'Ask what to do' in Settings-Devices-Removable Media.

Sebastien Bacher (seb128) wrote :

@corrade, that's another issue, please open a new bug against gnome-settings-daemon about it. Also the setting dialog you show has the case for audio not blank, with what type of CD did you try?

If i set 'Do nothing' the disk icon appears on the desktop with the title 'audio disk'.
If i set 'Ask what to do' the disk icon appears on the desktop with the title 'audio disk' and a notification in the top bar.
If i set 'Rythmbox' the disk icon appears on the desktop with the title 'audio disk' and the Rythmbox window opens. See screenshot.

I have again the same/similar problem with Ubuntu 18.04, 18.10 and 19.04.
should i open a new bug?

On 1/17/19 3:13 PM, corrado venturini wrote:
> I have again the same/similar problem with Ubuntu 18.04, 18.10 and 19.04.
> should i open a new bug?
>
I would suspect so as this is fix released & personally see no current
issues in 18.04 .

If seeing this on a laptop you should confirm it's not a drive issue as
cd/dvd drives in laptops are generally low quality and fail in different
ways quite often.

I have same problem on 2 different desktop and 2 laptop.
CD/DVD is correctly detected but i don't have the message 'You have just inserted ... Chose what application to launch'

On same hardware different partition with Ubuntu Xenial inserting any CD/DVD I see a window saying: 'You have just inserted ... Chose what application to launch'

So the problem is not the same and i opened a new bug https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1812506

thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.