16.04 regression bug lshw -C memory does not display module info

Bug #1586473 reported by Damiön la Bagh on 2016-05-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lshw (Ubuntu)
Undecided
Unassigned

Bug Description

Summary:
There is yet another regression bug in 16.04. This time in the packaging of lshw. If you build lshw from source on 16.04LTS using apt-get source lshw the functionality is restored.

Problem:

In 14.04LTS sudo lshw -C memory shows the information necessary to view your memory modules without having to open the computer case.

product: KHX2666C15D4/8G
          vendor: Undefined
          physical id: 0
          serial: XXXXXXX
          slot: DIMM_A1
          size: 8GiB
          width: 64 bits
          clock: 2666MHz (0.4ns)

In 16.04LTS sudo lshw -C memory shows ano nothing more about the installed memory.
 *-memory
       description: System Memory
       physical id: 11
       slot: Systeem- of moederbord
       size: 32GiB

Proof of existence:

See these two articles on the subject.

http://wyldeplayground.net/ubuntu-ubuntu-16-04-aarch64-lshw-c-memory-did-not-show-memory-banks-info-correctly/

http://askubuntu.com/questions/433861/lshw-not-showing-individual-memory-bank-info/778321#778321

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lshw (Ubuntu):
status: New → Confirmed

I'm experiencing the same issue but it seems to be a general issue with all classes in lshw.

I have two identical systems with the same hardware and on my 14.04 server I can run

# lshw -C system
host01
    description: Rack Mount Chassis
    product: PowerEdge 1950 ()
    vendor: Dell Inc.
    serial: XXXXXXX
    width: 64 bits
    capabilities: smbios-2.5 dmi-2.5 vsyscall32
    configuration: boot=normal chassis=rackmount uuid=23454B4D-4800-1200-2323-C8A04E4C4832

and on the 16.04 server it only returns

# lshw -C system
host02
    description: Computer
    width: 64 bits
    capabilities: smbios-2.5 vsyscall32

I just noticed a new version of lshw ( 02.17-1.1ubuntu3.1 ) seems to have fixed this issue.

Changed in lshw (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Confirmed
Damiön la Bagh (kat-amsterdam) wrote :

Can confirm this bug has been fixed in the latest update of 16.04LTS

Changed in lshw (Ubuntu):
status: Confirmed → Fix Released
Damiön la Bagh (kat-amsterdam) wrote :

Big thank you to the team that fixed this!

Alecz20 (alexguzu) wrote :

This also (still) happens on 15.10 with lshw B.02.17 (02.17-1.1ubuntu3.1)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers