lsh-utils version 2.0.4-dfsg-8 failed to build in oneiric

Bug #831164 reported by Matthias Klose on 2011-08-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
heimdal (Debian)
Fix Released
Unknown
heimdal (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
lsh-utils (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

lsh-utils version 2.0.4-dfsg-8 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2704317

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2704317/+files/buildlog_ubuntu-oneiric-amd64.lsh-utils_2.0.4-dfsg-8_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 2175 lines into the build log:

make[2]: Leaving directory `/build/buildd/lsh-utils-2.0.4-dfsg/contrib'
make[2]: Entering directory `/build/buildd/lsh-utils-2.0.4-dfsg'
make[3]: Entering directory `/build/buildd/lsh-utils-2.0.4-dfsg'
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Leaving directory `/build/buildd/lsh-utils-2.0.4-dfsg'
make[2]: Leaving directory `/build/buildd/lsh-utils-2.0.4-dfsg'
make[1]: Leaving directory `/build/buildd/lsh-utils-2.0.4-dfsg'
dh_testdir
dh_testroot
dh_install -a --sourcedir=debian/tmp
cp: cannot stat `debian/tmp/usr/sbin/lsh-krb-checkpw': No such file or directory
dh_install: cp -a debian/tmp/usr/sbin/lsh-krb-checkpw debian/lsh-server//usr/sbin/ returned exit code 1
make: *** [binary-arch] Error 2
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary-arch gave error exit status 2
******************************************************************************
Build finished at 20110822-0700
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/lsh-utils-2.0.4-dfsg

Related branches

Matthias Klose (doko) on 2011-08-22
Changed in lsh-utils (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Magnus Holmgren (holmgren) wrote :

The cause of the failure is that multiarch support was added to heimdal, but the symlinks /usr/lib -> heimdal weren't moved accordingly. On the other hand the output from krb5-config --libs doesn't seem to be used correctly, and that should fixed.

Matthias Klose (doko) on 2011-09-03
tags: added: multiarch
Changed in heimdal (Debian):
status: Unknown → New
Matthias Klose (doko) on 2011-09-21
Changed in heimdal (Ubuntu Oneiric):
importance: Undecided → High
status: New → In Progress
milestone: none → ubuntu-11.10
status: In Progress → Fix Committed
Changed in lsh-utils (Ubuntu Oneiric):
status: Confirmed → In Progress
Changed in heimdal (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heimdal - 1.5~pre2+git20110804-1ubuntu3

---------------
heimdal (1.5~pre2+git20110804-1ubuntu3) oneiric; urgency=low

  * Fix .so and .a symlinks in heimdal-dev. Closes: #640278, LP: #831164.
 -- Matthias Klose <email address hidden> Wed, 21 Sep 2011 14:00:10 +0200

Changed in heimdal (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Matthias Klose (doko) wrote :

builds with fixed heimdal-dev

Changed in lsh-utils (Ubuntu Oneiric):
status: In Progress → Fix Released
Georg Rath (georg-rath) wrote :

I am not sure you fixed the symlinks the right way. I tried building openldap with heimdal-dev as a dependency (for the smbk5pwd module) and it didn't work, so I took the symlink fixing from the precise release of heimdal-dev and it worked like a charm.

The changes I ported are attached.
I am quite new to packaging, so any feedback would be appreciated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.