[SRU] lsdvd

Bug #1310049 reported by Geoff Clements on 2014-04-19
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
acidrip (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
lsdvd (Debian)
Fix Released
Unknown
lsdvd (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

The package doesn't work on trusty because of a bad patch

[Test Case]

Install the package on trusty

[Regression Potential]

None, the package is already fixed in debian and utopic.

[Other Info]

Since updating to Trusty lsdvd has been producing invalid python output, here's a snippet:

lsdvd = {
  '%s' : device'/dev/sr0',
  '%s' : title'HARRY_POTTER_GOBLET_OF_FIRE',
  '%s' : vmg_id'DVDVIDEO-VMG',
  '%s' : provider_id'WARNER_HOME_VIDEO',
  'track' : [
    {
      '%s' : ix1,
      '%s' : length9038.000,
      '%s' : vts_id'DVDVIDEO-VTS',
      '%s' : vts1,
      '%s' : ttn1,
      '%s' : fps25.00,
      '%s' : format'PAL',
      '%s' : aspect'16/9',
      '%s' : width720,
      '%s' : height576,
      '%s' : df'Letterbox',
      'palette' : [
        '92520000',
        '808080',
        '808080',
        '808080',
        '808080',
        '808080',
        '808080',
        'eb8080',
        '808080',
        'b08080',
        '808080',
        '808080',
        '808080',
        '808080',
        '808080',
        '808080',
      ],
...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lsdvd (Ubuntu):
status: New → Confirmed
Ole Streicher (olebole) wrote :

Since the package comes from Debian, I opened a bug on Debian for this: http://bugs.debian.org/746163

This can be fixed by the attached patch.

The attachment "lsdvd.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in lsdvd (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in acidrip (Ubuntu):
status: New → Confirmed
David Agudo (dagudoj) wrote :

I workaround this in acidrip by manually installing the lsdvd package from Precise (lsdvd_0.16-3ubuntu1_amd64)

François Marier (fmarier) wrote :

I've just applied the patch attached to this bug and added the resulting trusty package to my PPA:

https://launchpad.net/~fmarier/+archive/ubuntu/ppa

Jamin W. Collins (jcollins) wrote :

I can confirm that the patch does indeed fix the problem.

nixomose (spamme-deadpelican) wrote :

I can confirm that downgrading lsdvd to precise works.
I just don't get how something as fundamental and popular as ripping a dvd can be completely broken in a LTS release and nobody has any intention of fixing it. I terribly confused.

summary: - Invalid Python Output in Trusty
+ [SRU] lsdvd
Sebastien Bacher (seb128) wrote :
Changed in lsdvd (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released

nixomose, I changed this bug to SRU request, please follow the procedures described here [1] if you want the bug fixed in trusty. Thanks

[1] https://wiki.ubuntu.com/StableReleaseUpdates

description: updated
Marc Deslauriers (mdeslaur) wrote :

Someone needs to prepare a debdiff appropriate for an SRU into trusty containing all of the changes that went into the utopic package. I'm unsubscribing ubuntu-sponsors for now, since there is nothing here to sponsor.

Please attach a debdiff and when that is done, re-subscribe ubuntu-sponsors again.

Thanks.

Hi Marc, the debdiff is fairly trivial, and should be good the one listed there
https://launchpadlibrarian.net/174219383/lsdvd_0.16-4_0.16-5.diff.gz

(with just a little sed for the target release of course)

Timo Jyrinki (timo-jyrinki) wrote :

Hey! I've readied an upload on my patch pilot shift and I've tested that it now produces the same -Oy (Python) output as the utopic version, unlike before.

Could you test it on 14.04 LTS from:
sudo apt-add-repository ppa:timo-jyrinki/ppa
sudo apt update
sudo apt install lsdvd

Note that if you've installed a higher version number already, you will need to install the .deb directly from https://launchpad.net/~timo-jyrinki/+archive/ubuntu/ppa/+sourcepub/4444970/+listing-archive-extra instead.

The reason I ask for extra testing is that while modifying the patch as seen in the debdiff seems to affect the output, the Acidrip itself still does not seem to show anything for me when I "Load" the DVD video source. The lsdvd output on the command line seems to show the tracks etc. I tried other reverse dependencies of lsdvd, but couldn't find one that would be suitable for testing the python output change.

So, I'm not sure it's worth uploading if Acidrip doesn't get fixed by the update. On the other hand, I've never used Acidrip before, I'm using an external DVD drive, so it might be that it actually fixes the issue at hand but just doesn't work for me.

I'm ok uploading this if I get reports of it (as tested via my PPA) fixing the issue.

Changed in lsdvd (Ubuntu Trusty):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in lsdvd (Ubuntu Trusty):
status: New → Incomplete
Changed in lsdvd (Debian):
status: Fix Released → New
Changed in lsdvd (Debian):
status: New → Fix Released
Marc Deslauriers (mdeslaur) wrote :

Could someone please test and comment on the PPA package in comment #13?

Kees Cook (kees) wrote :

It's very broken for me, sorry. I recommend just pulling 17.0-1 from Debian. That works fine for me.

Kees Cook (kees) wrote :

errr, 0.17-1.

Timo Jyrinki (timo-jyrinki) wrote :

0.17-1 is in Ubuntu 14.10 and 15.04. Ubuntu 14.04 LTS would need a cherry-picked bugfix for this bug only that fits into Stable Release Updates guidelines: https://wiki.ubuntu.com/StableReleaseUpdates

Changed in lsdvd (Ubuntu Trusty):
assignee: Timo Jyrinki (timo-jyrinki) → nobody
Marc Deslauriers (mdeslaur) wrote :

Since the PPA package in comment #13 doesn't seem to work, once again, there is nothing to sponsor here.

I'm unsubscribing ubuntu-sponsors for now. Please attach a debdiff to fix this issue, and when that is done, re-subscribe ubuntu-sponsors again.

Thanks.

Changed in acidrip (Ubuntu):
status: Confirmed → Invalid
Changed in acidrip (Ubuntu Trusty):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.