LSB 4.0 support

Bug #370066 reported by Jeff Licquia on 2009-04-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lsb (Ubuntu)
Undecided
Steve Langasek
Hardy
Undecided
Steve Langasek
Jaunty
Undecided
Steve Langasek

Bug Description

Binary package hint: lsb

Attached is a patch to include the proper information for the lsb package to support LSB 4.0. A similar patch will be filed against Debian soon.

SRU justfication: with the release of LSB 4.0, third-party packages will begin to rely on its features, which will be relevant in the 8.04 LTS and 9.04 support timeframes.

TEST CASE: because Ubuntu packages are not LSB packages, there is very little testing to be done here of the LSB functionality per se, beyond what testing the LSB upstream will do to check for compliance with the LSB. However, in Ubuntu the lsb-base and lsb-release packages also provide core functionality for our init scripts and other bits of the system, so testing should be done to make sure systems still boot correctly after the update and appear to work correctly in general.

Jeff Licquia (jeff-licquia) wrote :
Changed in lsb (Ubuntu):
assignee: nobody → Ubuntu Foundations Team (ubuntu-foundations)
milestone: none → jaunty-updates
status: New → Triaged
Changed in lsb (Ubuntu Hardy):
status: New → Triaged
Changed in lsb (Ubuntu Jaunty):
milestone: none → jaunty-updates
status: New → Triaged
Changed in lsb (Ubuntu):
milestone: jaunty-updates → none
Changed in lsb (Ubuntu Hardy):
milestone: none → ubuntu-8.04.3
Steve Langasek (vorlon) on 2009-05-06
Changed in lsb (Ubuntu):
assignee: Ubuntu Foundations Team (ubuntu-foundations) → Steve Langasek (vorlon)
Theodore Ts'o (tytso) wrote :

Hi,

Is there an update for when the patch we supplied will be applied?

Many thanks!!

Steve Langasek (vorlon) wrote :

Hi Ted,

Sorry, this ran afoul of the Karmic UDS, which absorbed everyone's attention for the past couple of weeks. I'm drilling down into this now and should have package uploads done by the end of the day. The uploads for jaunty and hardy will still need to pass through at least minimal regression testing before publishing to the -updates pockets; and the foomatic-filters update in bug #376732 is still awaiting QA confirmation that it hasn't introduced regressions. Since the foomatic-filters update in particular is a functional change, I don't want to publish it to hardy-updates without confirmation that it doesn't introduce any major regressions, and I guess we wouldn't want to publish the lsb package there either until that bug is fixed.

BTW, Jeff, the patch linked above seems to have a cut-n-paste error for the new lsb-security package, claiming to be the "Linux Standards Base Printing specification". I assume that "Linux Standards Base Security specification" is correct?

Steve Langasek (vorlon) wrote :

lsb 4.0-0ubuntu1 uploaded to karmic. Changelog:

 lsb (4.0-0ubuntu1) karmic; urgency=low
 .
   * Merge from Debian unstable, remaining changes:
     - lsb-base-logging-ubuntu.sh: change log_{success,warning,failure}_msg()
       to use usplash_write "TEXT" instead of "STATUS" to avoid unreadable
       line-wrapping when using usplash in verbose mode.
     - Don't conflict with python (>= 2.6).
     - Depend on postfix rather than exim4 as preferred mail-transport-agent
       alternative.
     - Depend on libgl1-mesa-glx rather than libgl1-mesa as preferred libgl1
       alternative.
     - Since /etc/lsb-release overrides detected information, there's no
       need to try and detect that information if lsb-release contains
       everything we need. This saves us calling the hugely expensive
       apt-cache.
     - Add Ubuntu logging functions.
 .
   [ Jeff Licquia ]
   * Upgrade to support LSB 4.0.

Changed in lsb (Ubuntu):
status: Triaged → Fix Released

Steve Langasek wrote:
> BTW, Jeff, the patch linked above seems to have a cut-n-paste error for
> the new lsb-security package, claiming to be the "Linux Standards Base
> Printing specification". I assume that "Linux Standards Base Security
> specification" is correct?

Yes, thanks for catching that.

Colin Watson (cjwatson) wrote :

Accepted into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in lsb (Ubuntu Hardy):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in lsb (Ubuntu Jaunty):
status: Triaged → Fix Committed
Colin Watson (cjwatson) wrote :

Accepted into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Langasek (vorlon) on 2009-06-04
description: updated
tags: removed: verification-needed
Martin Pitt (pitti) wrote :

Added v-needed again, for some basic regression testing (lsb_release, etc.)

tags: added: verification-needed
Colin Watson (cjwatson) on 2009-06-04
Changed in lsb (Ubuntu Hardy):
assignee: nobody → Steve Langasek (vorlon)
Changed in lsb (Ubuntu Jaunty):
assignee: nobody → Steve Langasek (vorlon)
Steve Beattie (sbeattie) wrote :

I've installed lsb-base and lsb-release 4.0-0ubuntu0.8.04.1 from hardy-proposed and installed a large number of the packages that were listed in hardy's contents file as having a file under /etc/init.d and didn't see any different behavior between booting with the new version of lsb and the existing lsb 3.2 packages. Some other cursory testing with lsb_release and other stuff didn't show any differing behavior either.

Martin Pitt (pitti) wrote :

Also works fine here. Considering verified.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsb - 4.0-0ubuntu0.8.04.1

---------------
lsb (4.0-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * Upgrade to support LSB 4.0. LP: #370066

 -- Jeff Licquia <email address hidden> Thu, 30 Apr 2009 15:14:24 -0400

Changed in lsb (Ubuntu Hardy):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2009-06-29
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsb - 4.0-0ubuntu0.9.04.1

---------------
lsb (4.0-0ubuntu0.9.04.1) jaunty-proposed; urgency=low

  * Upgrade to support LSB 4.0. LP: #370066.

 -- Jeff Licquia <email address hidden> Thu, 30 Apr 2009 15:14:24 -0400

Changed in lsb (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in lsb (Ubuntu):
assignee: Steve Langasek (vorlon) → Mick bunching (micksta87)
Steve Langasek (vorlon) on 2016-11-17
Changed in lsb (Ubuntu):
assignee: Mick bunching (micksta87) → Steve Langasek (vorlon)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers