[Regression] Epson's printer driver packages cannot be installed as lsb package is not available anymore

Bug #1536353 reported by Nicolas DERIVE on 2016-01-20
194
This bug affects 40 people
Affects Status Importance Assigned to Milestone
lsb
Undecided
Unassigned
cups-filters (Ubuntu)
High
Till Kamppeter
Xenial
High
Unassigned
epson-inkjet-printer-escpr (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
lsb (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

[SRU justification]
Previous releases were compatible with third-party printer drivers provided in LSB package format (and also as .deb packages depending on the lsb package). As of 16.04, because the LSB specifies ABIs for various libraries that are no longer supported in Ubuntu as obsolete, the packages for the lsb modules have been dropped in both Debian and Ubuntu. This includes dropping of lsb-core, which is the component which provides the LSB-mandated ELF loader path - without which no lsb executable will work.

This SRU will restore the bare minimum of LSB compatibility necessary to support known third-party LSB printer driver packages on Ubuntu 16.04.

[Regression potential]
The reintroduced 'lsb' binary package is known to not fully satisfy the requirements for a complete LSB-compliant system. This is a regression vs. Ubuntu 14.04; so anyone using LSB packages on Ubuntu 14.04 who upgrades to Ubuntu 16.04 may have the upgrade succeed without any warning from the package manager.

As there are very few lsb packages in use in the wild, this is considered an acceptable regression, especially as this will land before the first 16.04 point release.

[Test case]
1. Download the epsion 201106w printer driver package from http://download.ebz.epson.net/dsc/op/stable/debian/dists/lsb3.2/main/binary-amd64/epson-inkjet-printer-201106w_1.0.1-1lsb3.2_amd64.deb
2. Install the package and confirm that its dependencies are not satisfiable.
3. Enable xenial-proposed.
4. Install the package again and confirm that the dependencies are satisfied.
5. Verify that /opt/epson-inkjet-printer-201106w/cups/lib/filter/epson_inkjet_printer_filter can be run without errors about missing lsb ld.so or missing libraries.

Starting with Xenial, lsb compatibility packages were dropped (besides lsb-release and lsb-base):

lsb (9.20150826) unstable; urgency=low

  * Drop all the LSB compatibility packages besides lsb-release and lsb-base
    - Drop packages-availability checking in lsb-release
    - Truncate README.Debian to a minimum
    - Document this in lsb-base.NEWS.Debian
  * Change the versioning number to avoid any ambiguity; use joeyh's
    version.date, with version being Debian next stable's

 -- Didier Raboud <email address hidden> Wed, 26 Aug 2015 12:00:00 +0200

The problem is that downloadable printer drivers (like the ones from Openprinting, but also from other available providers) that are suggested when installing a printer on Ubuntu depends on lsb, which is not available anymore:

epson-inkjet-printer-201106w:
 Dépend: lsb (>=3.2) but it is not installable

This triggers a regression where it is not possible to setup a printer this way (downloading a driver where no local driver is available) anymore.

I see two possible solutions:

- Add a proper replaces field to one of the remaining lsb-* packages, to hopefully fix missing lsb package (maybe it would be useful to also replace other compability packages that are not built anymore).

- Re-introduce LSB compatibility packages, but that might be an overkill.

Nicolas DERIVE (kalon33) wrote :

Also add system-config-printer, as this problem breaks part of it, and as it doesn't output any installation error whereas driver is not installed due to missing dep.

description: updated
Till Kamppeter (till-kamppeter) wrote :

I have posted on Debian's printing team mailing list about this problem and I have also CCed OdyX (Didier Rabaud), who both has uploaded the new LSB packahe and is the printing guru of Debian.

Till Kamppeter (till-kamppeter) wrote :

The removed package is mainly a meta package, a lot of dependencies and only very few files. Perhaps it is possible to add one new binary package named lsb-printing to either the lsb package, the system-config-printer package, or the cups-filters package (as the OpenPrinting printer drivers seem to be the only user of the LSB here).

OdyX, what do you think.

Till Kamppeter (till-kamppeter) wrote :

Should be fixed in cups-filters 1.8.2-2ubuntu2. There I have added two new binary packages, cups-filters-lsb and cups-filters-invalid-mta which temporarily replace the removed lsb-... LSB compatibility packages. This way LSB-based printer driver packages can be installed in Ubuntu Xenial (16.04).

Note that these packages will get removed later when we have a new concept for distribution-independent printer driver packages at OpenPrinting.

Changed in system-config-printer (Ubuntu):
status: New → Invalid
Changed in lsb (Ubuntu):
status: New → Invalid
Changed in lsb:
status: New → Invalid
Changed in cups-filters (Ubuntu):
status: New → Fix Released
Richard Elkins (texadactyl) wrote :

Please fix the lsb package (somehow) so that it is possible to install an Epson print driver. I can no longer print from Xenial. Fortunately for me, I have other computers which can access my Epson XP-410 printer but folks should not have to jump through hoops to print.

Please note that changes to cups-filters does not fix this bug.

Till Kamppeter (till-kamppeter) wrote :

Note that the package building/publishing process on the download servers has not finished yet. The package version is 1.8.2-2ubuntu2. The currently available version 1.8.2-2 does not contain the fix yet.

Richard Elkins (texadactyl) wrote :

Till,

My Epson XP-410 printer needs package epson-inkjet-printer-201106w which is dependent on package lsb. It sounds like you are saying:

1. Two new binary packages, cups-filters-lsb and cups-filters-invalid-mta will be available in the x64 main repo soon (post building/publishing).
2. Once they are, binary package epson-inkjet-printer-201106w will be dependent on cups-filters-lsb instead of lsb (part of the building/publishing process?).
3. Finally, when I attempt to install epson-inkjet-printer-201106w, this should work from now on until whatever go-to printer architecture exists in the future.

Sound right to you? Thanks.

Till Kamppeter (till-kamppeter) wrote :

Yes, that's it.

Richard Elkins (texadactyl) wrote :

Confirmed fixed and functional.

The user only sees cups-filters (version 1.8.2-2ubuntu2) installed as a binary package which is more transparent.

Thanks, Till.

Michael (mrzxvp5j-ubuntu) wrote :

I've got the latest package from the epson site (epson-inkjet-printer-escpr_1.6.4-1lsb3.2_amd64.deb) and was able to install the package on current Ubuntu 16.04. cups-filters is on 1.8.2-2ubuntu3.
However, I'm not able to print with my Epson ET-4550 because the epson-escpr-wrapper requires /lib64/ld-lsb-x86-64.so.3 which does not exists on my system.

Roderic Jones (rodericj) wrote :

This is still not working for me. I have Ubuntu 16.04 and Ubuntu Gnome 16.04 on different SSDs and neither of them will print using an Epson WF-3520.

The cups-filters packages installed are 1.8.3-2ubuntu2

I see that this effects other makes of printer (e.g. Brother) where the driver has to be downloaded.

Roderic Jones (rodericj) wrote :

I have wiped Ubuntu Gnome 16.04 and done a fresh install of Ubuntu 15.10.

the epson-printer-utility_1.0.0-1lsb3.2_amd64 installs and the printer works perfectly - so the defect must be in the 16.04 libraries

Roderic Jones (rodericj) on 2016-04-16
Changed in lsb:
status: Invalid → Confirmed
Richard Elkins (texadactyl) wrote :

Sorry, Till. The laptop can no longer access the Epson XP-410 printer. The laptop needs printer access. So, I installed Linux Mint which has the lsb package. No issues anymore for the user of this laptop.

Changed in lsb (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Invalid
Richard Elkins (texadactyl) wrote :

If I could change the "fix released" to "confirmed", I would but I cannot.

Sitsofe Wheeler (sitsofe) wrote :

Till: Could you undo fixed released on cups-filters? It looks like the cups-filters-lsb has already been deleted (http://www.ubuntuupdates.org/package/core/xenial/main/base/cups-filters-lsb ) but the epson debs still depend on lsb which doesn't exist.

Richard Elkins (texadactyl) wrote :

After re-installing Xubuntu 16.04 this morning, I was able to find a suitable driver for my Epson XP-410 printer by adding the package, printer-driver-escpr. There was no requirement for lsb as a prerequisite.

dpkg -L printer-driver-escpr
/.
/usr
/usr/lib
/usr/lib/printer-driver-escpr
/usr/lib/printer-driver-escpr/libescpr.so.1.0.0
/usr/lib/cups
/usr/lib/cups/driver
/usr/lib/cups/driver/escpr
/usr/lib/cups/filter
/usr/lib/cups/filter/epson-escpr
/usr/lib/cups/filter/epson-escpr-wrapper
/usr/share
/usr/share/cups
/usr/share/cups/ppd-updaters
/usr/share/cups/ppd-updaters/printer-driver-escpr.ppd-updater
/usr/share/doc
/usr/share/doc/printer-driver-escpr
/usr/share/doc/printer-driver-escpr/copyright
/usr/share/doc/printer-driver-escpr/changelog.Debian.gz
/usr/lib/printer-driver-escpr/libescpr.so.1

I would recommend that the other affected parties should try this approach with 16.04. Stay away from the Epson site downloads.

Michael (mrzxvp5j-ubuntu) wrote :

I tried the printer-driver-escpr package from Ubuntu 16.04 with my Epson ET-4550 and it works well.
Thanks Richard!

Richard Elkins (texadactyl) wrote :

Two different Epson printers are working with the printer-driver-escpr package.

affects: lsb → epson-inkjet-printer-escpr (Ubuntu)
Changed in epson-inkjet-printer-escpr (Ubuntu):
status: Confirmed → Fix Released
Changed in cups-filters (Ubuntu):
status: Fix Released → Confirmed
Changed in lsb (Ubuntu):
status: Invalid → Confirmed
Roderic Jones (rodericj) wrote :

I can confirm that this works but my printer (WF-3250) is not in the list. Experimentation is required. Work Force produces 25 blank sheets for the test print but the WF printers seem to work

Changed in lsb (Ubuntu):
importance: Undecided → Medium
Changed in epson-inkjet-printer-escpr (Ubuntu):
importance: Undecided → Medium
Changed in cups-filters (Ubuntu):
importance: Undecided → Medium
Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
Bruno Nova (brunonova) wrote :

The printer-driver-escpr package also works for my Epson Stylus SX425W printer.

However, I must say that installing the driver for this printer in 16.04 was not user-friendly at all.

The "wizard" for adding and installing the printer didn't present this package as a possible driver to install.
The only options were epson-nx420 (which fails to silently install due to the missing lsb package), and another one which didn't seem to include the driver I needed (I may be wrong).

Also, this package has a LOT LESS "Printer Options" than the epson-nx420 driver.

I had to install this package manually.
I only found it because of this bug report (and Google).

These drivers need to be easier to install, and the "wizard" needs to be more robust.
(The guys at the Epson repository should probably also do something about the "lsb" dependency, since this probably also affects Debian.)

Douglas Santos (douglasrpg) wrote :

Since this bug also affects Epson L355 driver (epson-inkjet-printer-201207w) and Epson XP-310, that needs lsb (>=3.2), and other printers as well, why not mark Bug #1573893 as a duplicate of this one?

aljosa (aljosa-p) wrote :

Ubuntu 16.04 fresh installation, Epson L365: both printer and scanner doesn't work.

Same for me, have an Epson L355.
Tip:
But I found a workaround for this particular printer:
Scanner: worked fine without any driver installation.
Printer: apparently, worked with the L375 driver (which visually seems to be the same printer, with only new bulk inks case).
But I first installed the printer-driver-escpr package -> sudo apt-get install printer-driver-escpr , which expanded the list of available printers of the driver installation menu through System Configurations -> Printers ->Add buttom.

gernophil (gernophil) wrote :

I'm also affected by this bug.

I'm using an EPSON Stylus Office BX535WD. The printer-driver-escpr package contains a driver for this printer, but there are very few settings available.

I used the "epson-inkjet-printer-201106w_1.0.1-1lsb3.2_amd64.deb" in wily which made most of the features - e.g. duplex printing - available.

However, this package also depends on lsb and is cannot be installed in xenial due to this bug. I also tried using the ppd-file from this package, but this doesn't work.

The official Epson printer drivers (for a model XP-322) installed correctly, but all prints stopped with the status "Filter failed". This occurs with both the epson-inkjet-printer-escpr (1.6.5-1lsb3.2) and epson-inkjet-printer-escpr (1.4.1-1lsb3.2) drivers from the Epson website and those installed automatically by the Ubuntu printers utility on Ubuntu version 16.04.

The driver printer-driver-escpr from the universe packages does however work fine.
, if possible, changing the default printer driver in the printers utility would prevent more people being affected if the official Epson drivers aren't going to be fixed soon.

Arup (arup-chowdhury) wrote :

I have the same issue, ESCPR doesn't support any of the CISS Epson printers like L200 or 800. My 800 worked fine under 14.04 with downloaded driver and utility. The later would allow check of ink status and do nozzle cleaning. Due to missing lsb-core both are impossible to be installed under 16.04. This fix is needed ASAP as many other Epson and non Epson printers are affected along with Google Earth and other programs like Maple etc.

I am also affected. I have an Epson L220 and the official drivers can't be installed under 16.04. The printer is not supported by printer-driver-escpr

Richard Elkins (texadactyl) wrote :

See message #16. Does this work for those still trying to find a usable Epson printer driver? It worked fine for a few of us. No need for "lsb".

1 comments hidden view all 133 comments
Douglas Santos (douglasrpg) wrote :

I think the Bug Description should be changed, since the information about lsb package (from Debian) is outdated, as the urgency is now "medium", and not "low":

lsb (9.20160110) unstable; urgency=medium

  * Merge the last Ubuntu diff

  [ Stéphane Graber & Dimitri John Ledkov ]
  * Add 01-upstart-lsb from the upstart package, and make executing rc.d
    scripts no-op if there is an upstart job for that script

 -- Didier Raboud <email address hidden> Sun, 10 Jan 2016 12:32:59 +0100

https://launchpad.net/debian/+source/lsb/+changelog

Richard Elkins (texadactyl) wrote :

I cannot understand why Xenial (16.04) dropped lsb in the first place given how much dependency exists. However, I have tried two of the suggested solutions and the printer-driver-escpr package provides basic printing functions for my Epson XP-410 (I lucked out).

I'll try to summarize this unhappy discussion:

1. Package printer-driver-escpr provides basic printer functions for some Epson printers but not all models.
2. Even when printer-driver-escpr succeeds, some Epson functions are missing (E.g. ink level inquiry).
3. Many (if not all) of the Epson site printer drivers are still dependent on lsb and its co-packages; customers have nearly zero leverage with Epson (I am still waiting for a 4-month-old request to them to stop using lsb functions). I have also called them and customer service "will get back to me".
4. There are other software (E.g. Google Earth) which needs lsb.

My request regarding the lsb packages of 15.10: PLEASE put them back into 16.04. They might be "outdated" in some peoples opinion but the users are at the mercy of 3rd party vendors who see no profit in expending energy in this regard.

Other thoughts?

I changed lsb to fix released, but it was an accident, I'm sorry.

I tried #16 solution but it doesn't worked for me

Changed in lsb (Ubuntu):
status: Confirmed → Fix Released
Nicolas DERIVE (kalon33) wrote :

@felipe-lew-yee-q please don't play with bug statuses. Let developers working on the problem change them... doing that you just make it disappear from their bug queue...

Change lsb status back to "confirmed".

Changed in lsb (Ubuntu):
status: Fix Released → Confirmed
Richard Elkins (texadactyl) wrote :

Work-around for everyone, I believe. I uninstalled my suggestion of message #16 and followed this myself.

1. Append the following line to /etc/apt/sources.list (E.g. sudo vi /etc/apt/sources.list):

 deb http://cz.archive.ubuntu.com/ubuntu trusty main

2. sudo apt update; sudo apt install lsb

3. Go to http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX

4. Enter your product name and "Linux" as the O/S. Click on the search sysmbol. Accept conditions and download the latest "printer driver" DEB file for your CPU architecture. Mine (XP-410) was the Epson Printer Utility for AMD64, dated 2016-04-12.

5. Install the downloaded DEB file (E.g. using gdebi). My gdebi installation log looked like this:

Epson Printer Utility Driver for Linux
 This is a Printer Utility program for Epson Printer Driver.
 Using this software, you can check ink levels, view error and other status... on EPSON Printers.
 For detail list of supported printer, please refer to below site:
 http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
 .
 (Converted from a rpm package by alien version 8.79ubuntu0.1.)
Do you want to install the software package? [y/N]:y
Selecting previously unselected package epson-printer-utility.
(Reading database ... 220307 files and directories currently installed.)
Preparing to unpack epson-printer-utility_1.0.0-1lsb3.2_amd64.deb ...
Unpacking epson-printer-utility (1.0.0-1lsb3.2) ...
Setting up epson-printer-utility (1.0.0-1lsb3.2) ...
Install Message > Described entry of LITE in services.
Install Message > Backup file is /etc/services.bak.
Install Message > Start /usr/lib/epson-backend/setup to change setup.
Processing triggers for libc-bin (2.23-0ubuntu3) ...

6. Using the "Add Printer" function from the "All Settings" application, add your printer. In my case, I found it on the Wifi network and the driver installation worked automatically.

===============================================================================

I hope that this helps the remaining folks with hardware and software installation issues due to the absence of the lsb packages.

It was easy to add the lsb packages to my 16.04 installation and I had no issues.

Arup (arup-chowdhury) wrote :

Suggestion from openprinting forums...

Firstly, install the package with dpkg -i , then change the dependency on lsb to lsb-base by editing /var/lib/dpkg/status and finding the epson package in that file. Then change the Depends: line to lsb-base so it looks like

Depends: lsb-base

Then run apt-get install -f to configure the dirver properly.

The second thing is, because this isn't a real LSB system (or, seems so to me) then you have to have a LSB compatible loader in /lib64 so we need to symlink the standard link loader instead.

As root, you would

ln -s /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3

This satisfies the loader for the printfilter.

After these steps, my networked XP-312 worked.

I suspect this to be the case for many of the LSB based Epson drivers on Ubuntu 16.04 (maybe earlier versions of Ubuntu as well, actually).

Yonsy (yonsy-s-p) wrote :

+1 Epson L375 in my case. previous comments works for me.

Arup (arup-chowdhury) wrote :

Tried all the solutions above including editing package status file but to no avail. Printer gets recognized under printer applet but no printout sadly. This is with my L800 thats working perfectly under 14.04.4LTS

Changed in cups-filters (Ubuntu):
assignee: nobody → Till Kamppeter (till-kamppeter)
importance: Medium → High
Richard Elkins (texadactyl) wrote :

Arup, are you sure that you haven't mixed the effects of #35 (openprinting forums) with the other work-arounds?

#34 is essentially like the 14.04 environment as far as lsb is concerned. It worked perfectly based on a clean install of 16.04 then adding 'deb http://cz.archive.ubuntu.com/ubuntu trusty main' to the apt sources.

Did you undo the effects of #35 before trying #34?

Arup (arup-chowdhury) wrote :

Richard, using old files from Trusty is exactly something I wouldn't like on a brand new LTS installation, in that case I will hold on to 14.04.4 LTS thats supported till 2019. I am sure an official solution would be out by then.

Changed in cups-filters (Ubuntu):
status: Confirmed → Fix Released
Changed in lsb (Ubuntu):
status: Confirmed → Fix Committed
tags: added: patch
tags: added: desktop-trello-import
Will Cooke (willcooke) on 2016-05-13
tags: removed: desktop-trello-import
vernario (recados-aka) on 2016-06-21
Changed in lsb (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2016-06-21
Changed in lsb (Ubuntu):
status: Fix Released → In Progress
Steve Langasek (vorlon) on 2016-06-21
Changed in cups-filters (Ubuntu Xenial):
status: New → Fix Released
Changed in epson-inkjet-printer-escpr (Ubuntu Xenial):
status: New → Fix Released
Changed in system-config-printer (Ubuntu Xenial):
status: New → Invalid
Steve Langasek (vorlon) on 2016-06-21
Changed in lsb (Ubuntu Xenial):
status: New → In Progress
Steve Langasek (vorlon) on 2016-06-21
description: updated
description: updated
Steve Langasek (vorlon) on 2016-06-22
description: updated
Steve Langasek (vorlon) on 2016-06-22
Changed in lsb (Ubuntu Xenial):
milestone: none → ubuntu-16.04.1
Martin Pitt (pitti) on 2016-06-23
Changed in lsb (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in lsb (Ubuntu):
status: In Progress → Fix Released
tags: added: regression-release
removed: regression
Changed in cups-filters (Ubuntu Xenial):
importance: Undecided → High
no longer affects: system-config-printer (Ubuntu)
no longer affects: system-config-printer (Ubuntu Xenial)
Changed in epson-inkjet-printer-escpr (Ubuntu Xenial):
importance: Undecided → Medium
Changed in lsb (Ubuntu Xenial):
importance: Undecided → Medium
tags: added: verification-done
removed: verification-needed
Changed in lsb (Ubuntu Xenial):
status: Fix Committed → Fix Released
53 comments hidden view all 133 comments

Installed lsb package and reinstalled epson's drivers. Not working. Printer setting identifies printer correctly(EPSON-L210-Series). but in Simple scan, an error"unable to connect to scanner" arise. when tried to change scanner there the scanner name is given as "Epson(unknown model)". It seems that there is something wrong with hardware detection/identification and/or communication gap between printer and scanner modules.

copersonus (copersonus) wrote :

HP P10006 printer will not print. updates lock me out of my computer and force me to reinstall. why are you releasing updates that do not have printer utilities????

Scan function of L210 multifunction is not working With the latest Ubuntu(Xubuntu 16.04) update.

Google earth also not working..

Douglas Santos (douglasrpg) wrote :

Aravind Gopal, I think you should try a fresh install. I have a Epson L355 working fine and Google Earth x64 working with a small issue (sometimes it closes right after launching, but on the 2nd time it works...).

Everyone who is not able to scan, please try scanning as root:

sudo simple-scan

sudo scanimage ...

Does this work?

Also run

strace scanimage -L > log 2>&1

and attach the "log" file (uncompressed) to this bug report.

In the "log" file search for lines containing "epson" or "EPSON". If they contain a path like

/opt/...epson.../.../libsane-XXX.so.1

or similar, run this library through ldd and post the output here:

ldd /opt/...epson.../.../libsane-XXX.so.1

Actually installed 16.04.1 again and updated, installed epson drivers.

"sudo simple-scan

sudo scanimage ..."
Not working.. simple scan opened but is not identifying the scanner, not working .

In "preferences" "Scan sources" is given as "Epson(unknown model)".

Please inform the location and name of log file(s).

"sudo simple-scan

sudo scanimage ..."
Not working.. simple scan opened but is not identifying the scanner, not working .

In "preferences" "Scan sources" is given as "Epson(unknown model)".

In the log file I did n't find any file/path with 'epson' under "/opt/" directory or sub directory. Need any other files/information.

Scan utilities not working..

On Tue, Aug 23, 2016 at 03:26:24PM -0000, Aravind Gopal wrote:
> In the log file I did n't find any file/path with 'epson' under "/opt/"
> directory or sub directory.

Then you don't have the printer driver installed that requires the lsb
package, and this is not a bug in the LSB package. You should file a new
bug report for your issue.

summary: - [regression] Printer drivers install is broken as lsb package is not
- available anymore
+ [Regression] epson-inkjet-printer-201106w package cannot be installed as
+ lsb package is not available anymore

Aravind, and anyone who has followed the instructions of comment #101. Please chack the "log" file from strace again whether you generally find lines with file paths with "epson" or "EPSON" in it. They do not need to contain "/opt/".

Run also ldd on these file paths.

summary: - [Regression] epson-inkjet-printer-201106w package cannot be installed as
- lsb package is not available anymore
+ [Regression] Epson's printer driver packages cannot be installed as lsb
+ package is not available anymore
Douglas Santos (douglasrpg) wrote :

Aravind, are you using Gutenprint + CUPS ? Didn't you try the official Epson drivers? Your printer uses the same driver I use here "201207w" for the printer and the "iscan 1.0.1" for the scanner.

Gluten print + cups install automatically when MFD printer is connected for the first time. Changed to epson driver.. Now 'simple scan' not loading, no error message , iscan and scanlite gives the same error message. restarted the system, printer but no use. Error persists.

printer driver changed to epson. reinstalled epson scan driver again, Simple scan can be opened through console, but cannot scan. Log file attached. ?field.comment=printer driver changed to epson. reinstalled epson scan driver again, Simple scan can be opened through console, but cannot scan. new Log file attached.

Printer driver is of epson. iscan, scanlite, simple scan is not scaning. Simple scan opens only though sudo and konsole. screenshot attached. iscan and scanlite shows error message.

Comment #107: Till Kamppeter.
lines with epson/epson log file when epson driver was the active printer driver.
1. open("/usr/lib/x86_64-linux-gnu/sane/libsane-epsonds.so.1", O_RDONLY) = 95
close(95) = 0
2. open("/usr/lib/x86_64-linux-gnu/sane/libsane-epsonds.so.1", O_RDONLY|O_CLOEXEC) = 95
3. open("./epsonds.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
4. open("/etc/sane.d/epsonds.conf", O_RDONLY) = 98
5. read(98, "# epsonds.conf\n#\n# here are some"..., 4096) = 221
6. open("/usr/lib/x86_64-linux-gnu/sane/libsane-epson2.so.1", O_RDONLY) = 98
close(98) = 0
7. open("/usr/lib/x86_64-linux-gnu/sane/libsane-epson2.so.1", O_RDONLY|O_CLOEXEC) = 98
8. open("./epson2.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
9. open("/etc/sane.d/epson2.conf", O_RDONLY) = 101
10. read(101, "# epson2.conf\n#\n# here are some "..., 4096) = 376
11. sendto(102, "EPSONP\0\377\0\0\0\0\0\0\0", 15, 0, {sa_family=AF_INET,
12. write(1, "device `epkowa:usb:004:003' is a"..., 71device `epkowa:usb:004:003' is a Epson (unknown model) flatbed scanner
) = 71

Aravind, and anyone who has scanning problems, please run the following commands:

dpkg -l | grep -i epson

and post the output here.

swami@swami-TA990FXE:~$ dpkg -l | grep -i epson
ii epson-inkjet-printer-201207w 1.0.0-1lsb3.2 amd64 EPSON L110/210/300/350/355/550/555 Series - Epson Inkjet Printer Driver
ii iscan 2.30.2-2 amd64 simple, easy to use scanner utility for EPSON scanners
swami@swami-TA990FXE:~$

Aravind, please run the following commands now

dpkg -L epson-inkjet-printer-201207w
dpkg -L iscan

and post the output here.

swami@swami-TA990FXE:~$ dpkg -L epson-inkjet-printer-201207w
/.
/opt
/opt/epson-inkjet-printer-201207w
/opt/epson-inkjet-printer-201207w/cups
/opt/epson-inkjet-printer-201207w/cups/lib
/opt/epson-inkjet-printer-201207w/cups/lib/filter
/opt/epson-inkjet-printer-201207w/cups/lib/filter/epson_inkjet_printer_filter
/opt/epson-inkjet-printer-201207w/lib64
/opt/epson-inkjet-printer-201207w/lib64/libEpson_201207w.so.1.0.0
/opt/epson-inkjet-printer-201207w/lib64/libEpson_201207w.MT.so.1.0.0
/opt/epson-inkjet-printer-201207w/watermark
/opt/epson-inkjet-printer-201207w/watermark/WEPCG07.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG00.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG08.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG02.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG01.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG09.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG03.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG04.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG06.EID
/opt/epson-inkjet-printer-201207w/watermark/WEPCG05.EID
/opt/epson-inkjet-printer-201207w/ppds
/opt/epson-inkjet-printer-201207w/ppds/Epson
/opt/epson-inkjet-printer-201207w/ppds/Epson/Epson-L550_Series-epson-driver.ppd.gz
/opt/epson-inkjet-printer-201207w/ppds/Epson/Epson-L300_Series-epson-driver.ppd.gz
/opt/epson-inkjet-printer-201207w/ppds/Epson/Epson-L350_Series-epson-driver.ppd.gz
/opt/epson-inkjet-printer-201207w/ppds/Epson/Epson-L355_Series-epson-driver.ppd.gz
/opt/epson-inkjet-printer-201207w/ppds/Epson/Epson-L110_Series-epson-driver.ppd.gz
/opt/epson-inkjet-printer-201207w/ppds/Epson/Epson-L555_Series-epson-driver.ppd.gz
/opt/epson-inkjet-printer-201207w/ppds/Epson/Epson-L210_Series-epson-driver.ppd.gz
/opt/epson-inkjet-printer-201207w/resource
/opt/epson-inkjet-printer-201207w/resource/Epson_201207w.MT.3.data
/opt/epson-inkjet-printer-201207w/resource/Epson_201207w.MT.5.data
/opt/epson-inkjet-printer-201207w/resource/Epson_201207w.MT.6.data
/opt/epson-inkjet-printer-201207w/resource/Epson_201207w.MT.4.data
/opt/epson-inkjet-printer-201207w/resource/Epson_201207w.MT.1.data
/opt/epson-inkjet-printer-201207w/resource/Epson_201207w.MT.2.data
/opt/epson-inkjet-printer-201207w/resource/Epson_201207w.1.data
/opt/epson-inkjet-printer-201207w/doc
/opt/epson-inkjet-printer-201207w/doc/COPYING.LIB
/opt/epson-inkjet-printer-201207w/doc/AUTHORS
/opt/epson-inkjet-printer-201207w/doc/COPYING
/opt/epson-inkjet-printer-201207w/doc/Manual.txt
/opt/epson-inkjet-printer-201207w/doc/README
/opt/epson-inkjet-printer-201207w/doc/COPYING.EPSON
swami@swami-TA990FXE:~$

swami@swami-TA990FXE:~$ dpkg -L iscan
/.
/usr
/usr/lib
/usr/lib/sane
/usr/lib/sane/libsane-epkowa.so.1.0.15
/usr/lib/sane/libsane-epkowa.la
/usr/lib/libesmod.so.2.0.0
/usr/lib/gimp
/usr/lib/gimp/2.0
/usr/lib/gimp/2.0/plug-ins
/usr/bin
/usr/bin/iscan
/usr/sbin
/usr/sbin/iscan-registry
/usr/share
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/iscan.1.gz
/usr/share/man/man5
/usr/share/man/man5/sane-epkowa.5.gz
/usr/share/man/man8
/usr/share/man/man8/iscan-registry.8.gz
/usr/share/locale
/usr/share/locale/de
/usr/share/locale/de/LC_MESSAGES
/usr/share/locale/de/LC_MESSAGES/iscan.mo
/usr/share/locale/es
/usr/share/locale/es/LC_MESSAGES
/usr/share/locale/es/LC_MESSAGES/iscan.mo
/usr/share/locale/fr
/usr/share/locale/fr/LC_MESSAGES
/usr/share/locale/fr/LC_MESSAGES/iscan.mo
/usr/share/locale/it
/usr/share/locale/it/LC_MESSAGES
/usr/share/locale/it/LC_MESSAGES/iscan.mo
/usr/share/locale/ja
/usr/share/locale/ja/LC_MESSAGES
/usr/share/locale/ja/LC_MESSAGES/iscan.mo
/usr/share/locale/ko
/usr/share/locale/ko/LC_MESSAGES
/usr/share/locale/ko/LC_MESSAGES/iscan.mo
/usr/share/locale/nl
/usr/share/locale/nl/LC_MESSAGES
/usr/share/locale/nl/LC_MESSAGES/iscan.mo
/usr/share/locale/pt
/usr/share/locale/pt/LC_MESSAGES
/usr/share/locale/pt/LC_MESSAGES/iscan.mo
/usr/share/locale/zh_CN
/usr/share/locale/zh_CN/LC_MESSAGES
/usr/share/locale/zh_CN/LC_MESSAGES/iscan.mo
/usr/share/locale/zh_TW
/usr/share/locale/zh_TW/LC_MESSAGES
/usr/share/locale/zh_TW/LC_MESSAGES/iscan.mo
/usr/share/locale/ar
/usr/share/locale/ar/LC_MESSAGES
/usr/share/locale/ar/LC_MESSAGES/iscan.mo
/usr/share/locale/en@quot
/usr/share/locale/en@quot/LC_MESSAGES
/usr/share/locale/en@quot/LC_MESSAGES/iscan.mo
/usr/share/locale/en@boldquot
/usr/share/locale/en@boldquot/LC_MESSAGES
/usr/share/locale/en@boldquot/LC_MESSAGES/iscan.mo
/usr/share/applications
/usr/share/applications/iscan.desktop
/usr/share/doc
/usr/share/doc/iscan
/usr/share/doc/iscan/README.gz
/usr/share/doc/iscan/NEWS.gz
/usr/share/doc/iscan/AVASYSPL.en.txt
/usr/share/doc/iscan/AVASYSPL.ja.txt
/usr/share/doc/iscan/changelog.Debian.gz
/usr/share/doc/iscan/AUTHORS
/usr/share/doc/iscan/copyright
/usr/share/doc/iscan/examples
/usr/share/doc/iscan/examples/xinetd.sane
/usr/share/doc/iscan/NEWS.ja.gz
/usr/share/doc/iscan/README.ja.gz
/usr/share/menu
/usr/share/menu/iscan
/etc
/etc/sane.d
/etc/sane.d/dll.d
/etc/sane.d/dll.d/iscan
/etc/sane.d/epkowa.conf
/var
/var/lib
/var/lib/iscan
/usr/lib/sane/libsane-epkowa.so.1
/usr/lib/libesmod.so.2
/usr/lib/gimp/2.0/plug-ins/iscan
swami@swami-TA990FXE:~$

Steve Langasek (vorlon) on 2016-08-24
tags: removed: regression-release

Aravind, now run the following commands:

ldd /usr/lib/sane/libsane-epkowa.so.1.0.15
ldd /usr/lib/libesmod.so.2.0.0
ldd /usr/bin/iscan
ldd /usr/sbin/iscan-registry
ldd /usr/lib/gimp/2.0/plug-ins/iscan

and also attach the files:

/etc/sane.d/dll.d/iscan
/etc/sane.d/epkowa.conf

swami@swami-TA990FXE:~$ ldd /usr/lib/sane/libsane-epkowa.so.1.0.15
        linux-vdso.so.1 => (0x00007ffcaf2d6000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f5ddeb44000)
        libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f5dde78a000)
        libusb-1.0.so.0 => /lib/x86_64-linux-gnu/libusb-1.0.so.0 (0x00007f5dde571000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f5dde369000)
        libltdl.so.7 => /usr/lib/x86_64-linux-gnu/libltdl.so.7 (0x00007f5dde15f000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f5dddf5a000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f5dddb91000)
        /lib64/ld-linux-x86-64.so.2 (0x00005597f7f0c000)
        libicuuc.so.55 => /usr/lib/x86_64-linux-gnu/libicuuc.so.55 (0x00007f5ddd7fd000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f5ddd5e2000)
        liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f5ddd3c0000)
        libudev.so.1 => /lib/x86_64-linux-gnu/libudev.so.1 (0x00007f5ddd3a0000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f5ddd182000)
        libicudata.so.55 => /usr/lib/x86_64-linux-gnu/libicudata.so.55 (0x00007f5ddb6cb000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f5ddb349000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f5ddb132000)
swami@swami-TA990FXE:~$

swami@swami-TA990FXE:~$ ldd /usr/lib/libesmod.so.2.0.0
        linux-vdso.so.1 => (0x00007ffd64bf6000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fa3ac91e000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fa3ac615000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fa3ac24b000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fa3ac035000)
        /lib64/ld-linux-x86-64.so.2 (0x00005654cdc4f000)
swami@swami-TA990FXE:~$

Download full text (5.1 KiB)

swami@swami-TA990FXE:~$ ldd /usr/bin/iscan
        linux-vdso.so.1 => (0x00007ffe45f23000)
        libesmod.so.2 => /usr/lib/libesmod.so.2 (0x00007fce69c36000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fce69a32000)
        libltdl.so.7 => /usr/lib/x86_64-linux-gnu/libltdl.so.7 (0x00007fce69827000)
        libgtk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0 (0x00007fce691dc000)
        libgdk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0 (0x00007fce68f27000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007fce68cd3000)
        libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007fce68ad1000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fce688c9000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fce685b7000)
        libsane.so.1 => /usr/lib/x86_64-linux-gnu/libsane.so.1 (0x00007fce683af000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fce6802d000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fce67d23000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fce67b0d000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fce678f0000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fce67526000)
        /lib64/ld-linux-x86-64.so.2 (0x0000561f19650000)
        libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007fce67322000)
        libpangocairo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangocairo-1.0.so.0 (0x00007fce67115000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fce66dda000)
        libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007fce66bd4000)
        libatk-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libatk-1.0.so.0 (0x00007fce669af000)
        libcairo.so.2 => /usr/lib/x86_64-linux-gnu/libcairo.so.2 (0x00007fce6669a000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0 (0x00007fce66478000)
        libgio-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007fce660f0000)
        libpangoft2-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 (0x00007fce65ed9000)
        libpango-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpango-1.0.so.0 (0x00007fce65c8d000)
        libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007fce65a4a000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007fce6583f000)
        libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007fce6563c000)
        libXi.so.6 => /usr/lib/x86_64-linux-gnu/libX...

Read more...

swami@swami-TA990FXE:~$ ldd /usr/sbin/iscan-registry
        not a dynamic executable
swami@swami-TA990FXE:~$

Download full text (4.6 KiB)

swami@swami-TA990FXE:~$ ldd /usr/lib/gimp/2.0/plug-ins/iscan
        linux-vdso.so.1 => (0x00007fff9cd5c000)
        libesmod.so.2 => /usr/lib/libesmod.so.2 (0x00007fdb72782000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fdb7257e000)
        libltdl.so.7 => /usr/lib/x86_64-linux-gnu/libltdl.so.7 (0x00007fdb72373000)
        libgtk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0 (0x00007fdb71d28000)
        libgdk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0 (0x00007fdb71a73000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007fdb7181f000)
        libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007fdb7161d000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fdb71415000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fdb71103000)
        libsane.so.1 => /usr/lib/x86_64-linux-gnu/libsane.so.1 (0x00007fdb70efb000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fdb70b79000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fdb7086f000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fdb70659000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fdb7043c000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fdb70072000)
        /lib64/ld-linux-x86-64.so.2 (0x00005560e4861000)
        libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007fdb6fe6e000)
        libpangocairo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangocairo-1.0.so.0 (0x00007fdb6fc61000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fdb6f926000)
        libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007fdb6f720000)
        libatk-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libatk-1.0.so.0 (0x00007fdb6f4fb000)
        libcairo.so.2 => /usr/lib/x86_64-linux-gnu/libcairo.so.2 (0x00007fdb6f1e6000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0 (0x00007fdb6efc4000)
        libgio-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007fdb6ec3c000)
        libpangoft2-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 (0x00007fdb6ea25000)
        libpango-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpango-1.0.so.0 (0x00007fdb6e7d9000)
        libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007fdb6e596000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007fdb6e38b000)
        libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007fdb6e188000)
        libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007fdb6df77000)
        libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007fdb6dd6c000)
        libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007fdb6db62000)
        libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007fdb6d95f000)
        libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007fdb6d75b000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007fdb6d549000)
        libffi.so....

Read more...

 /etc/sane.d/dll.d/iscan

/etc/sane.d/epkowa.conf

Richard (rimcaw) wrote :

No issue with Epson printer, problem with scanner.

$ dpkg -l | grep -i epson

ii epson-inkjet-printer-escpr 1.6.5-1lsb3.2 amd64 Epson Inkjet Printer Driver (ESC/P-R) for Linux
ii iscan 2.30.2-2 amd64 simple, easy to use scanner utility for EPSON scanners

Its a LSB problem? status?

What is the problem? , its hardware or software problem?. Is it possible to use the scanner? Status shows "fix released" and Importance "medium".
Confused........

Latest scanner driver from epson(Ver. 1.0.3(10-2016)) Installed. OS updated. Still Ubuntu 16.1 cannot identify Scanner hardware.

Installed latest driver for Epdon MFD L210 (Ver. 1.0.4) . updated Ubuntu 16.4.1. Still OS cannot identify scanner hardware.. Simple scan loads using console only.. please help

ratheeshekm (ratheeshekm) wrote :

My Epson MFD l210 also has the same problem with scanner functionality

Rajaneesh (rejanish) wrote :

Epson MFD do not function properly on Ubuntu 16.04.1.

ReInstalled latest XUbuntu (16.04.2) with latest Epson drivers. Result is the same. Could not scan. see screenshot photo . Where to file a bug like this. is it a mystery?

Displaying first 40 and last 40 comments. View all 133 comments or add a comment.