lsb_release crashed with IOError in getstatusoutput(): [Errno 10] No child processes (called by teamviewerd)

Bug #1094218 reported by hugo manuel do bem
656
This bug affects 121 people
Affects Status Importance Assigned to Milestone
lsb (Ubuntu)
Undecided
Unassigned
Precise
High
Barry Warsaw
Quantal
High
Barry Warsaw
Raring
High
Barry Warsaw

Bug Description

Add-ons: <email address hidden>:2.0.4,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:11.0,<email address hidden>:2.0.1,{972ce4c6-7e08-4474-a285-3208198ce6fd}:11.0
BuildID: 20120313141405
CrashTime: 1356689682
EMCheckCompatibility: true
FramePoisonBase: 00000000f0dea000
FramePoisonSize: 4096
InstallTime: 1356685662
Notes: OpenGL: X.Org R300 Project -- Gallium 0.4 on ATI RV515 -- 2.1 Mesa 8.0.2 -- texture_from_pixmap

ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SecondsSinceLastCrash: 18
StartupTime: 1356689673
Theme: classic/1.0
Throttleable: 1
URL: http://ubuntuforums.org/private.php?s=&pp=&folderid=0
Vendor: Mozilla
Version: 11.0

This report also contains technical information about the state of the application when it crashed.

ProblemType: CrashDistroRelease: Ubuntu 12.04
Package: lsb-release 4.0-0ubuntu20
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Fri Dec 28 09:42:36 2012
ExecutablePath: /usr/bin/lsb_release
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/lsb_release -a
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
PythonArgs: ['/usr/bin/lsb_release', '-a']SourcePackage: lsb
Title: lsb_release crashed with IOError in getstatusoutput(): [Errno 10] No child processes
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

[Impact]
SIGCHLD in lsb_release isn't handled correctly by Python causing the error code 10 IOError in some cases. Upstream Python has a fixed subprocess module, so switching from commands (where it is not fix) to subprocess (where it is fixed) should do the trick. Versions of lsb after precise are not affected because they use subprocess anyway, so this just backports that relatively mechanical change.

[Test Case]
Difficult to reproduce outside of teamviewer, but the following should work to verify that there is no regression: `lsb_release -a`

Also watch for no incidents involving the new package version at:
https://errors.ubuntu.com/problem/4eebfa6d3f91386f752207eeaf410b5a8ce81081

[Regression Potential]
If the patch to use subprocess is broken, then lsb_release may cease to work.

Revision history for this message
hugo manuel do bem (hugo-bem5) wrote :
tags: removed: need-duplicate-check
Changed in lsb (Ubuntu):
importance: Undecided → Medium
tags: added: lucid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lsb (Ubuntu):
status: New → Confirmed
Revision history for this message
Brian Murray (brian-murray) wrote :

All the duplicates of this bug report are from the same user.

 $ lp-bug-dupe-properties --reporter -b 1094218
LP: #1094218 has 4 duplicates
  kangarooo: 1094880 1095414 1095545 1096365

Which means that there are really 2 reporters of this bug.

description: updated
information type: Private → Public
Revision history for this message
Brian Murray (brian-murray) wrote :

There are a large number of occurrences of this at:

https://errors.ubuntu.com/bucket/?id=%2Fusr%2Fbin%2Flsb_release%3AIOError%3A%3Cmodule%3E%3Amain%3Acheck_modules_installed%3Agetoutput%3Agetstatusoutput

querying the instances further there are actually 85 unique system identifiers affected so it seems a bit more widespread.

Revision history for this message
Brian Murray (brian-murray) wrote :

Could somebody provide some more details regarding the conditions under which this crash occurred? What were you doing prior to receiving the notification? Thanks!

Revision history for this message
Claude Durocher (claude-d) wrote :

I think it might be related to teamviewer 8 beta : at the same time I had a crash, I had the following entries in TV8 log :

2013/01/17 08:28:00.372 1909 3064986432 S0 CTerminalServer::getPathToApplicationExe: executable is /opt/teamviewer8/tv_bin/TeamViewer
2013/01/17 08:28:00.372 1909 3064986432 S0 CTerminalServer::StartGUIProcess() Filename for GUI process is /opt/teamviewer8/tv_bin/TeamViewer
2013/01/17 08:28:00.383 1909 3064986432 S0 CTerminalServer::StartGUIProcess() Event 5 sent to GUI.
2013/01/17 08:29:33.558 1909 3044014912 S0 CConnectionThread::PingRouter(): Router Ping started
2013/01/17 08:29:33.559 1909 3044014912 S0 CKeepAliveThreadServer::SyncClients(): Clients:
2013/01/17 08:29:33.669 1909 3044014912 S0 CT5 CConnectionThread::CmdPingRouter(): Router Pong Received with following Hops: 367561857 349518642

TV8 now has a daemon and I think it reconnects periodically. Also, one of TV8 scripts tvw_main runs lsb_release -a.

$ ll /var/crash/

total 20
drwxrwsrwt 2 root whoopsie 4096 jan 17 08:31 ./
drwxr-xr-x 14 root root 4096 jan 16 18:26 ../
-rw-r----- 1 claudio whoopsie 9240 jan 17 08:28 _usr_bin_lsb_release.1000.crash
-rw-rw-r-- 1 claudio whoopsie 0 jan 17 08:31 _usr_bin_lsb_release.1000.upload
-rw------- 1 whoopsie whoopsie 0 jan 17 08:44 _usr_bin_lsb_release.1000.uploaded

Revision history for this message
Brian Murray (brian-murray) wrote :

Thanks for that additional information. However, I don't see anything suspicious in tv_main. Here is the function that calls lsb_release.

function LogStartupInfo()
{
  exec 2>&1 # redirect stderr

  echo "TeamViewer: $TV_VERSION"
  echo "Profile: $HOME ($LOGNAME)"
  echo "Desktop: $DESKTOP_SESSION"

  if [ -x "$(type -p lsb_release)" ] ; then # log information about the Linux distribution
    lsb_release -a
    make_path "$WINEPREFIX/drive_c"
    lsb_release -ds > "$WINEPREFIX/drive_c/distrelease"
  else
    echo /etc/*-release
    for rfile in /etc/*-release ; do # echo the head of the first valid *-release file
      if [ -e "$rfile" ] ; then
        cat $rfile | head -n 10
        break
      fi
    done
  fi

  validateUser || return 1 # die if sudo

  echo "ok"
}

Revision history for this message
Brian Murray (brian-murray) wrote :

Can you check the md5sum of /usr/bin/lsb_release? Also maybe python is installed in your wine environment?

Revision history for this message
Claude Durocher (claude-d) wrote :

$ lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

$ lsb_release -ds

Ubuntu 12.04.1 LTS

$ md5sum /usr/bin/lsb_release

2764a9a9e8170152e63cd1ba62bf954a /usr/bin/lsb_release

file $WINEPREFIX/drive_c/distrelease contains the following text:

debian_version, lsb-release, os-release

I don't see any python in the wine env (teamviewer has it's own wine). Right now I have the following python programs running :

hp-systray
fogger-lens
unity-lens-video
unity-scope-video-remote
ubuntuone-syncdaemon
software-center
aptd

I had a second look at the crash file and found this :

PythonArgs: ['/usr/bin/lsb_release', '-a']
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/lsb_release", line 96, in <module>
     main()
   File "/usr/bin/lsb_release", line 63, in main
     verinfo = lsb_release.check_modules_installed()
   File "/usr/lib/python2.7/dist-packages/lsb_release.py", line 102, in check_modules_installed
     output = commands.getoutput("dpkg-query -f '${Version} ${Provides}\n' -W %s 2>/dev/null" % PACKAGES)
   File "/usr/lib/python2.7/commands.py", line 50, in getoutput
     return getstatusoutput(cmd)[1]
   File "/usr/lib/python2.7/commands.py", line 61, in getstatusoutput
     sts = pipe.close()
 IOError: [Errno 10] No child processes

Don't know it this helps.

Revision history for this message
Steve (stvw) wrote :

Same error - occurs continuously after TeamViewer 8 beta was installed

Revision history for this message
audunpoi (audun-didgeridoo) wrote :

Have teamviewer8 and get this error continuously also

Revision history for this message
xxvirusxx (condor20-05) wrote :

Same error, Teamviewer 8 installed.

Revision history for this message
Tom Fallon (kiweegie) wrote :

Same issue here:

Teamviewer 8 beta installed version 8.0.16675 (wine-1.5.19)

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

$ md5sum /usr/bin/lsb_release
2764a9a9e8170152e63cd1ba62bf954a /usr/bin/lsb_release

I've reported to teamviewer support also.

Regards, Tom

Revision history for this message
Kangarooo Jānis (kangarooo) wrote :

What has this bug including Firefox addons info has to do with Teamviewer? How this can be related to bugs with Teamviewer?

Revision history for this message
Claude Durocher (claude-d) wrote :

I removed TV8 a couple of days ago and I don't get the error anymore so it really is related to TeamViewer.

Revision history for this message
Juan Jose Amor Iglesias (jjamor) wrote :

I confirm the same bug, and I also have installed teamviewer 8 beta.

Now, I uninstalled TV 8 and bug stopped.

Revision history for this message
komnik (komnik64-gmail) wrote :

I am also having the same crash about 4-6 times per week, I also have recently installed teamviewer 8.

Revision history for this message
Daniel Stiefelmaier (mail-stiefelweb) wrote :

As far as I can tell, it lsb_release never crashes if 'teamviewer' is invoked by the user (menu or commandline), but sometimes if invoked by the daemon. I could imagine two reasons for this:
- lsb_release does not like the particular moment in which it is invoked (e.g. around the time the user logs in to his computer)
- lsb_release does not like the environment in which it is invoked. (when forking/setuid/executing, the daemon does not create the same environment that the user usually lives in)

Revision history for this message
Jimmy Merrild Krag (beruic) wrote :

How about hp-systray? Could that be a part of the issue as well?

Revision history for this message
Kevin Normoyle (knormoyle) wrote :

I recently installed teamviewer and have the same bug. It happened even though I wasn't running teamviewer.
however, teamviewer seems to run something. here is output from ps

$ ps aux | grep team
root 989 0.0 0.0 47456 4488 ? Ssl 23:31 0:00 /opt/teamviewer8/tv_bin/teamviewerd -f
kevin 1961 0.0 0.0 4660 1236 ? Ss 23:32 0:00 /opt/teamviewer8/tv_bin/wine/bin/wineserver

Revision history for this message
David García (dav.garcia) wrote :

I can't remember whether this bug appeared right after installing TeamViewer 8, but it is definetly installed on my Kubuntu 12.04:
   ii teamviewer 8.0.16675 TeamViewer (Remote Control Application)

Revision history for this message
Felipe Concha Avello (felipec84) wrote :

The bug is produced by the process teamviewerd how Kevin Normoyle writed, this process is stated by upstart with the configuration found in /etc/init/teamviewerd.conf

 $cat /etc/init/teamviewerd.conf
description "TeamViewer remote control daemon"

exec /opt/teamviewer8/tv_bin/teamviewerd -f

# lightdm: Ubuntu
# mdm: Mint (does not support upstart signals)
# prefdm: RedHat 6

start on (login-session-start or
   starting gdm or
   starting kdm or
   starting lightdm or
   starting lxdm or
   starting prefdm or
   starting xdm)

stop on (stopping gdm or
   stopping kdm or
   stopping lightdm or
   stopping lxdm or
   stopping prefdm or
   stopping xdm)

respawn
respawn limit 5 60

For a workaround I stoped the service from autostart with

# echo "manual" > /etc/init/teamviewerd.override

Witch disabled the service, but teamViwer don't start unless you do an
$ sudo service teamviewerd start

If someone can check with "expect" or another command can use the "/etc/init/teamviewerd.conf " to work It will be very useful.

Changed in lsb (Ubuntu):
status: Confirmed → Invalid
Steve Langasek (vorlon)
Changed in lsb (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Nurlan Akashayev (akanurlan) wrote :

I'm getting the same error when i switch tabs in chrome.

Revision history for this message
Kevin Normoyle (knormoyle) wrote :

More info from the teamviewer startup log
I looked here after ubuntu reported the error with ProcCmdline
/usr/bin/python -Es /usr/bin/lsb_release -

The date/time on the startup log was right around the error time.

TeamViewer: 8.0.17147
Profile: /home/kevin ()
Desktop:
Traceback (most recent call last):
  File "/usr/bin/lsb_release", line 96, in <module>
    main()
  File "/usr/bin/lsb_release", line 63, in main
    verinfo = lsb_release.check_modules_installed()
  File "/usr/lib/python2.7/dist-packages/lsb_release.py", line 102, in check_modules_installed
    output = commands.getoutput("dpkg-query -f '${Version} ${Provides}\n' -W %s 2>/dev/null" % PACKAGES)
  File "/usr/lib/python2.7/commands.py", line 50, in getoutput
    return getstatusoutput(cmd)[1]
  File "/usr/lib/python2.7/commands.py", line 61, in getstatusoutput
    sts = pipe.close()
IOError: [Errno 10] No child processes
ok
 -

looking at line 102 of the lsb_release.py, interestingly it says it's 'Debian specific at present'

# This is Debian-specific at present
def check_modules_installed():
    # Find which LSB modules are installed on this system
    output = commands.getoutput("dpkg-query -f '${Version} ${Provides}\n' -W %s 2>/dev/null" % PACKAGES)
    if not output:
        return []

I have no LSB modules on my system
$ lsb_release
No LSB modules are available.

Revision history for this message
Kevin Normoyle (knormoyle) wrote :

I put a print in lsb_release.py to see what the dpkg-query command is

then did
ipython
 import lsb_release
 lsb_release.check_modules_installed()

the print says:
dpkg-query -f '${Version} ${Provides}
' -W lsb-core lsb-cxx lsb-graphics lsb-desktop lsb-qt4 lsb-languages lsb-multimedia lsb-printing 2>/dev/null

(yes there's a \n in the string ..see the def check_modules_installed() above)

here's commands.getoutput that's executing the dpkg-query. So somehow the pipe is closing before it's being told to by pipe.close?

def getoutput(cmd):
    """Return output (stdout or stderr) of executing cmd in a shell."""
    return getstatusoutput(cmd)[1]

# Ditto but preserving the exit status.
# Returns a pair (sts, output)
#
def getstatusoutput(cmd):
    """Return (status, output) of executing cmd in a shell."""
    import os
    pipe = os.popen('{ ' + cmd + '; } 2>&1', 'r')
    text = pipe.read()
    sts = pipe.close()
    if sts is None: sts = 0
    if text[-1:] == '\n': text = text[:-1]
    return sts, text

Revision history for this message
Coeur Noir (coeur-noir) wrote :

I won't be of any help how poorly skilled I am but encounter the same bug on amd64 and 12.04 - Unity & elementary OS beta 0.2 - both have TeamViewer 8.0.17147 with wine 1.5.19

Revision history for this message
Dave Parry (parrydm) wrote :

Some people above have mentioned TeamViewer 8. This is probably the cause in my case.

I installed TeamViewer a couple of days and have had a number of instances of this crash. This normally happens either when nothing else is happening (such as shortly after booting the machine and logging in) or when starting TeamViewer.
I have also experienced the system hanging on shutdown on three occasions.

I am running Ubuntu 12.04 LTS (upgraded from my original installation of 11.10). Prior to installing TeamViewer Ubuntu had never crashed.

Revision history for this message
Nephilim1973 (nephilim1973-e) wrote :

Hi guys, if you uninstall TeamViewer 8 Beta on Ubuntu, the message
"wine: / home/USERNAME/.config/teamviewer8 is not owned by you"
appears.

Probably this helps by finding the issue ?!?!?!

Regards.

Revision history for this message
smauleon (smauleon) wrote :

Same error, Ubuntu 12.04 64bit, and Teamviewer 8 installed. It appears after login, no need to launch Teamviewer.

Regards

Revision history for this message
hepsoe (hepsoe) wrote :

I have the same issue with 32-bit Ubuntu 12.04 and TeamViewer 8.

I made the following change in /usr/lib/python2.7/commands.py

Line 61:
Was before: sts = pipe.close()
Is now: if pipe is not None: sts = pipe.close()

Result: The error went away. (tried 3 reboots without any errors)

Since I'm totally unfamiliar with Python I hope someone who knows what they are doing will consider whether this could be a valid fix to this problem.

Revision history for this message
Barry Warsaw (barry) wrote :

My first reaction is to ask whether the people experiencing this are using an lsb_release that has the proper -Es flags on its #! line. Looking at the versions reported on the errors.u.c page above, it looks like it is (i.e. precise-updates version 4.0-0ubuntu20.2 as the SRUd patch to the #! line). You can double check this by doing `head /usr/bin/lsb_release` and verifying that it's got the -Es flag.

However, from the original bug description, this is suspicious:

ProcCmdline: /usr/bin/python /usr/bin/lsb_release -a

There's no -Es there. If you were to call lsb_release explicitly like so: `/usr/bin/python /usr/bin/lsb_release -a` then you would be omitting the -Es flag and allowing environmental factors to potentially break it.

In https://bugs.launchpad.net/ubuntu/+source/lsb/+bug/1094218/comments/7 bdmurray posts the script function where lsb_release is called, and it looks like it's calling it via $PATH and "lsb_release", so assuming the -Es flag is in the #! line, that *should* be okay, unless whatever $PATH is involved is finding a different -- and broken -- lsb_release. One thing you could try there is replacing `lsb_release` with `/usr/bin/lsb_release` in that function and see if it makes a difference, assuming of course that your /usr/bin/lsb_release has -Es in its #! line.

I don't know for sure that this is the problem, but let's rule this out before digging in further.

Revision history for this message
Barry Warsaw (barry) wrote :

I should note that apparently Lucid's version (4.0-0ubuntu8.1) didn't get the fix for the #! line, so if you're seeing this problem on Lucid, you might try manually adding -Es to the end of the #! line.

Revision history for this message
hepsoe (hepsoe) wrote :

After checking that the file /usr/bin/lsb_realease contains the -Es flag I undid my changes from post #30.
I have not received the error after that.

So it seems like Barry Warsaw was spot on regarding the -Es flag.

I updated my machine after making the changes in #30, so I cannot tell whether the -Es flag was included in that update or if it was actually there before. All I can say is that with the -Es flag I no longer receive this error.

Revision history for this message
xoristzatziki (simsonbike-bugs) wrote :

Problem in my computer occured AFTER installing teamviewer 8 (installed as teamviewer:i386).
Solved after uninstalling it.
I also had teamviewer 7.

Revision history for this message
Jaume Sabater (jsabater) wrote :

I am also hitting this bug in Ubuntu 12.04 x86_64 with TeamViewer 8.0.17147 installed.

Revision history for this message
David Agudo (dagudoj) wrote :

Same error in Ubuntu 12.04 x86_64 with TeamViewer.

-Es flag present:

~$ head /usr/bin/lsb_release
#!/usr/bin/python -Es

Revision history for this message
Cedric (cedric-brandenbourger-deactivatedaccount-deactivatedaccount) wrote :

After i changed the owner of the .config/teamviewer8 folder to root. The daemon started without any problems.
I got an error then when starting teamviewer on the desktop.
For me it's an owner / right issue.

Revision history for this message
Cedric (cedric-brandenbourger-deactivatedaccount-deactivatedaccount) wrote :

I think i found a solution, but i would be happy if somebody could confirm me this.

in /opt/teamviewer8/tv_bin/script/tvw_main

i changed these lines

function LogStartupInfo()
{
  exec 2>&1 # redirect stderr

  echo "TeamViewer: $TV_VERSION"
  echo "Profile: $HOME ($LOGNAME)"
  echo "Desktop: $DESKTOP_SESSION"

  if [ -x "$(type -p lsb_release)" ] ; then # log information about the Linu
x distribution
    #lsb_release -a <----------------------------------------comment out
    make_path "$WINEPREFIX/drive_c"
    echo "Ubuntu 12.04.2 LTS" > "$WINEPREFIX/drive_c/distrelease" <----------------------------------------change to your distribution
    #lsb_release -ds > "$WINEPREFIX/drive_c/distrelease" <----------------------------------------comment out
  else
    echo /etc/*-release
    for rfile in /etc/*-release ; do # echo the head of the first val
id *-release file
      if [ -e "$rfile" ] ; then
        cat $rfile | head -n 10
        break

i never got back the error until now
somebody else could try it. teamviewer is working without any problems

Revision history for this message
gerlos (gerlosgm) wrote :

I can confirm that Cedric's solution worked for me. But I'd prefer not hard coding the distribution name in the script.

So this is how I changed /opt/teamviewer8/tv_bin/script/tvw_main, it should work even after you upgrade your distribution to a new release, as long /etc/lsb_release file is upgraded fine:

function LogStartupInfo()
{
  exec 2>&1 # redirect stderr

  echo "TeamViewer: $TV_VERSION"
  echo "Profile: $HOME ($LOGNAME)"
  echo "Desktop: $DESKTOP_SESSION"

  if [ -x "$(type -p lsb_release)" ] ; then # log information about the Linu
x distribution
    #lsb_release -a
    make_path "$WINEPREFIX/drive_c"
    cat /etc/lsb-release | grep DESCRIPTION | cut -f2 -d= | sed 's/\"//g' > "$WINEPREFIX/drive_c/distrelease"
  else
    echo /etc/*-release
    for rfile in /etc/*-release ; do # echo the head of the first val
id *-release file
      if [ -e "$rfile" ] ; then
        cat $rfile | head -n 10
        break

Revision history for this message
Cedric (cedric-brandenbourger-deactivatedaccount-deactivatedaccount) wrote :

Ok i changed it to

cat /etc/lsb-release | grep DESCRIPTION | cut -f2 -d'"'

Thanks gerlos, i think we can close this bug

Revision history for this message
Angelos Pikoulas (agelos-pikoulas) wrote :

I had the same problem, ever since I installed Teamviewer 8.0.17147 on Kubuntu 12.0.4 LTS

I also confirm problem is solved after applying Cedric (cedric-brandenbourger) / gerlos (gerlosgm) solution.

Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Did the TeamViewer support get back on your request(s)? cat:ing would seem safer since there are some problems here, and it looks like /etc/lsb-release should be LSB mandated and about everywhere: https://code.google.com/p/inxi/source/browse/modules/data/distro-version-data.txt?r=1703

Regarding this actual lsb bug, it does not seem completely fixed as people with python -Es / latest version still get the problem. So I wouldn't mark this as fixed before there is certainty of understanding the bug.

summary: lsb_release crashed with IOError in getstatusoutput(): [Errno 10] No
- child processes
+ child processes (called by teamviewerd)
Revision history for this message
Strategos (psamaras1) wrote :

To clear out my small confusion with comments #39 and #40:

It is changes on 2 lines of code
1. Open file as root: "/opt/teamviewer8/tv_bin/script/tvw_main"
2. Find section: function LogStartupInfo()
3. Change current code:

if [ -x "$(type -p lsb_release)" ] ; then # log information about the Linux distribution
    lsb_release -a
    make_path "$WINEPREFIX/drive_c"
    lsb_release -ds > "$WINEPREFIX/drive_c/distrelease"
  else

to look like this:

if [ -x "$(type -p lsb_release)" ] ; then # log information about the Linux distribution
    #lsb_release -a # TempFix(Bug#1094218)
    make_path "$WINEPREFIX/drive_c"
    cat /etc/lsb-release | grep DESCRIPTION | cut -f2 -d= | sed 's/\"//g' > "$WINEPREFIX/drive_c/distrelease" # TempFix(Bug#1094218)

4. Save file

Please confirm or alter as needed.

Revision history for this message
Cedric (cedric-brandenbourger-deactivatedaccount-deactivatedaccount) wrote :

Yes, exactly

Revision history for this message
Michael Fox (commerce-i) wrote :

Can someone explain why post #43 would fix the problem? Specifically:
1) What is the reason for commenting out "lsb_release -a"
2) When I run the "lsb_release -ds" command from the command line, I get the same output as the cat ... sommand substituted above, namely "Ubuntu 12.04.2 LTS". Yet I have the same crash.

Before I go changing something, I'd like to know why.

FYI:
$ which lsb_release
/usr/bin/lsb_release

$ head /usr/bin/lsb_release
#!/usr/bin/python -Es

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

$ lsb_release -ds
Ubuntu 12.04.2 LTS

Thanks much.

Revision history for this message
Cedric (cedric-brandenbourger-deactivatedaccount-deactivatedaccount) wrote :

@Michael Fox

1) What is the reason of keeping "lsb_release -a" in this script?

2) This is what was intended! Look at the description of the bug:"lsb_release crashed with IOError in getstatusoutput()".
The bug is not about "cat" but about to avoid lsb_release!

Revision history for this message
Michael Fox (commerce-i) wrote :

Thanks Cedric.

1) According to the comment in the code, the script writer evidently wanted to log information about the distro. I presume this was done to help the TeamViewer folks in their troubleshooting.
2) O.K. Understood. Thanks. The reason for my question was that there are a few posts above that say the bug should now be closed. But this workaround merely avoids lsb_release. It doesn't fix the crash in lsb_release. That's why I was confused. I'm not familiar with the Ubuntu protocol for managing bugs but I hope at some point the root cause would be addressed.

Thanks for responding. I'm glad I found this excellent resource.

Revision history for this message
Brian Murray (brian-murray) wrote :

This bug could be closed for Ubuntu because it is not an issue with lsb_release itself, however with how lsb_release is being called by teamviewer. Something about the way the environment is setup by teamviewer's software is causing it to crash, and subsequently this is not something the Ubuntu development team can fix. It would be helpful if someone who cares about this issue were to bring this matter to the attention of the TeamViewer developers.

Revision history for this message
Gaurish Sharma (gslive) wrote :

For bugfix, I think at best Ubuntu can do is handle this crash gracefully. perhaps a simple message should to be known to all teamview users that there are compability issues with TeamView 8 beta. Don't proceed, unless you know what you are doing

Revision history for this message
daniel venema (d-venema) wrote :

I also had this bug on Ubuntu 12.04 frequently apparently because I used Teamviewer 8 beta (8.0.16675 on Wine1.5.19). The bug mostly popped up after starting a terminal window.
After deleting the beta through the Ubuntu software and removing the Teamviewer folders in my .config, and installing the current version 8.0.17147 (same Wine version) there were no more bugs so far.

Revision history for this message
daniel venema (d-venema) wrote :

I have to withdraw my previous comment on this bug. Unfortunately upgrading to the latest version of Teamviewer (non-beta) did not solve the lsb_release bug on my box. Still get the same error.
Today, after a cold startup within 2 minutes the Ubuntu error window pops up.

Revision history for this message
sid (sidly) wrote :

im not sure if this helps or not when i started skype i got this bug as soon as it finished loading i got the crash

Revision history for this message
Brian Murray (brian-murray) wrote : Re: [Bug 1094218] Re: lsb_release crashed with IOError in getstatusoutput(): [Errno 10] No child processes (called by teamviewerd)

On Thu, Apr 25, 2013 at 12:04:03AM -0000, sid wrote:
> im not sure if this helps or not when i started skype i got this bug as
> soon as it finished loading i got the crash

Where did you obtain skype from and on what release did you notice this?

Changed in lsb (Ubuntu):
importance: Medium → Critical
Steve Langasek (vorlon)
Changed in lsb (Ubuntu):
importance: Critical → Medium
Revision history for this message
Mattijs Riekerk (mattijs-riekerk) wrote :

I submitted a ticket today at TeamViewer. I assume other people did as well...

Reply:
Thank you for contacting us. This is an automated response confirming the receipt of your ticket. One of our agents will get back to you as soon as possible. For your records, the details of the ticket are listed below. When replying, please make sure that the ticket ID is kept in the subject line to ensure that your replies are tracked appropriately.

   Ticket ID:
   Subject: lsb_release crashed with IOError in getstatusoutput(): [Errno 10] No child processes

Best regards,

TeamViewer Support Team

Now we need to wait...

Revision history for this message
robb990099 (rebrown) wrote :

I also have the current version 8.0.17147 and find that the error occurs on a cold boot but not on a reboot.
Part of the puzzle?
HTH.

Revision history for this message
Esteban Adrián Pérez (dgeaperez) wrote :

#39 works for me...
Thanks!

Revision history for this message
Rion (rion4ik) wrote :

#39

more simple way

(. /etc/lsb-release; echo $DISTRIB_DESCRIPTION) > "$WINEPREFIX/drive_c/distrelease"

Revision history for this message
Caleb Howland (menzador) wrote :

#39, with #40's edit, works. Now on to TeamViewer's end of the puzzle.

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

From #57:

  $ . /etc/lsb-release; echo $DISTRIB_DESCRIPTION
  Ubuntu 12.04.2 LTS

From #39:

  $ cat /etc/lsb-release | grep DESCRIPTION | cut -f2 -d= | sed 's/\"//g'
  Ubuntu 12.04.2 LTS

From #40:

  $ cat /etc/lsb-release | grep DESCRIPTION | cut -f2 -d'"'
  Ubuntu 12.04.2 LTS

The solution from #57 (first above) is simpler and better.

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

Really, the bug appeared after I installed TeamViewer 8 (www.teamviewer.com).
Then I did a facilitator patch workground based on comments above. Follows.

Download tvw_main.patch in /opt/teamviewer8/tv_bin/script/ dir and:

$ cd /opt/teamviewer8/tv_bin/script

# patch apply
$ sudo patch < tvw_main.patch
patching file tvw_main

# or undo patch
$ sudo patch -R < tvw_main.patch
patching file tvw_main

Ref.:

 - [in portuguese] O Guia de Dez Minutos de diff e patch
    http://www.fnbrandao.com.br/blog/2012/01/o-guia-de-dez-minutos-de-diff-e-patch/

 - [in english] The Ten Minute Guide to diff and patch
    http://jungels.net/articles/diff-patch-ten-minutes.html

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Workground based on comments above" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

More info:

$ whereis lsb_release
lsb_release: /usr/bin/lsb_release /usr/bin/X11/lsb_release /usr/share/man/man1/lsb_release.1.gz

$ lsb_release -d
Description: Ubuntu 12.04.2 LTS

$ lsb_release -ds
Ubuntu 12.04.2 LTS

Revision history for this message
Christian Henz (chrhenz) wrote :

I think this may actually a bug in Python's pipe implementation in connection with SIGCHLD handling?

A similar issue [http://bugs.python.org/issue9127] was fixed in the subprocess module, but lsb_release in Ubuntu still uses os.popen function via the commands module - which are both deprecated and actually removed in Python 3. Maybe they have not fixed the issue in that deprecated code.

I have replace the lsb_release script and lsb_release.py module with the versions from upstream [http://anonscm.debian.org/gitweb/?p=collab-maint/lsb.git], which were already ported to the subprocess module. I can currently no longer reproduce the issue.

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

Interestingly, the patch of the workground above (#62 and #61) had resolved the issue "temporarily" only.

Christian Henz (chrhenz)
tags: removed: patch
Revision history for this message
Barry Warsaw (barry) wrote :

@chenz in #64 - good catch. We looked at errors.ubuntu.com and while there are a few related reports of this problem in versions of lsb later than precise-upgrades version 4.0-0ubuntu20.2, we think these are version mismatches. We see orders of magnitude more reports against precise's version.

So, I'm going to SRU a fix which switches from commands to subprocess, since 1) this is closer to the change in the code post-precise anyway, and 2) it's easier to make this change than to fix Python 2.7's commands module.

We also have a suspicion that this problem *could* be the root cause of LP: #982082 although we have no direct evidence of that. Call it a hunch. We'll see if reports of that problem get reduced when this SRU lands.

Changed in lsb (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
status: Confirmed → In Progress
description: updated
Barry Warsaw (barry)
Changed in lsb (Ubuntu):
status: In Progress → Invalid
Changed in lsb (Ubuntu Precise):
status: New → In Progress
Changed in lsb (Ubuntu Quantal):
status: New → In Progress
Changed in lsb (Ubuntu Raring):
status: New → In Progress
Changed in lsb (Ubuntu Precise):
importance: Undecided → High
Changed in lsb (Ubuntu Quantal):
importance: Undecided → High
Changed in lsb (Ubuntu Raring):
importance: Undecided → High
Changed in lsb (Ubuntu):
importance: Medium → Undecided
assignee: Barry Warsaw (barry) → nobody
Changed in lsb (Ubuntu Precise):
assignee: nobody → Barry Warsaw (barry)
Changed in lsb (Ubuntu Quantal):
assignee: nobody → Barry Warsaw (barry)
Changed in lsb (Ubuntu Raring):
assignee: nobody → Barry Warsaw (barry)
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello hugo, or anyone else affected,

Accepted lsb into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/lsb/4.0-0ubuntu27.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in lsb (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in lsb (Ubuntu Quantal):
status: In Progress → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello hugo, or anyone else affected,

Accepted lsb into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/lsb/4.0-0ubuntu26.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lsb (Ubuntu Precise):
status: In Progress → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello hugo, or anyone else affected,

Accepted lsb into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/lsb/4.0-0ubuntu20.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Mark Murphy (mokmeister) wrote :

Installed edubuntu 12.04 on this machine a few days ago, installed teamviewer 8.0.17147 this morning, got "lsb_release..." error.

Enabled proposed repository, did an apt-get update and apt-get dist-upgrade to see what new upgrades were available, cancelled, and installed python2.7, python 2.7-minimal and lsb-release. Have restarted laptop (both by rebooting and shut down / power on) a few times and have not seen the error again, so it looks like this has worked for me.

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

I still do not quite understand* how to make pine and so I am not yet using the proposed repository. Those interested in testing the fix, read these references:

- https://wiki.ubuntu.com/Testing/EnableProposed
- https://help.ubuntu.com/community/PinningHowto

Complement:

- https://help.ubuntu.com/community/UbuntuBackports

* I am brazilian and my native language is portuguese.

Revision history for this message
Bruno Medeiros (brunojcm) wrote :

I could not find lsb on proposed repo:

bruno.medeiros@brunojcm-notebook:~$ apt-cache policy lsb
lsb:
  Installed: 4.0-0ubuntu20.2
  Candidate: 4.0-0ubuntu20.2
  Version table:
 *** 4.0-0ubuntu20.2 0
        500 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.0-0ubuntu20 0
        500 http://br.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

Trying to install anyway give me an error:

bruno.medeiros@brunojcm-notebook:~$ sudo apt-get install lsb/precise-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'precise-proposed' for 'lsb' was not found

Revision history for this message
Barry Warsaw (barry) wrote : Re: [Bug 1094218] Re: lsb_release crashed with IOError in getstatusoutput(): [Errno 10] No child processes (called by teamviewerd)

On Jun 17, 2013, at 01:48 PM, Bruno Medeiros wrote:

>I could not find lsb on proposed repo:
>
>bruno.medeiros@brunojcm-notebook:~$ apt-cache policy lsb
>lsb:
> Installed: 4.0-0ubuntu20.2
> Candidate: 4.0-0ubuntu20.2
> Version table:
> *** 4.0-0ubuntu20.2 0
> 500 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
> 100 /var/lib/dpkg/status
> 4.0-0ubuntu20 0
> 500 http://br.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
>
>Trying to install anyway give me an error:
>
>bruno.medeiros@brunojcm-notebook:~$ sudo apt-get install lsb/precise-proposed
>Reading package lists... Done
>Building dependency tree
>Reading state information... Done
>E: Release 'precise-proposed' for 'lsb' was not found

http://people.canonical.com/~ubuntu-archive/pending-sru.html

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

alexandre$ apt-cache policy lsb
lsb:
  Instalado: 4.0-0ubuntu20.3
  Candidato: 4.0-0ubuntu20.3
  Tabela de versão:
 *** 4.0-0ubuntu20.3 0
        100 http://br.archive.ubuntu.com/ubuntu/ precise-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     4.0-0ubuntu20.2 0
        500 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
     4.0-0ubuntu20 0
        500 http://br.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

Boot machine and session's start with no error in lsb. But a error in unity-greeter. Maybe it was before already. There was more than one error in the session's start, before. I had stopped of looking the "details" of those bugs.

Revision history for this message
Brian Murray (brian-murray) wrote :

Bruno - Does precise-proposed exist in your /etc/apt/sources.list file?

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

Today is the second day with no errors in lsb. The "crash" of the unity-greeter appears to be sporadic; I reported it as bug #1192400 . Brian, thank you.

Revision history for this message
Dale Spanheimer (dspanheimer) wrote :

I had also received the crash reports each day after installing TeamViewer 8 under Ubuntu 12.04. I had also seen a couple of problems with the way TeamViewer was not updating screens correctly on the client. Today, I happened to look farther down the details screen on the crash reporter screen and noticed it had an entry that said
UnreportableReason
  You have some obsolete package versions installed.
and it mentioned python, python-minimal,python2.7,python2.7-minimal. Ubuntu update upgraded those packages this morning and the screen refresh is now working correctly in TeamViewer, so I will not be surprised if it also resolves the lsb_release errors, but I will have to wait for the next couple of days to see if it does indeed make those crashes go away.

Revision history for this message
peddanet (peddanet) wrote :

For me the bug fix of ~brian-murray worked for me fine!

There was only a problem that my graphic card driver was not working any more after the procedure, but that was maybe only due to my misunderstanding of the procedure.

Brian was describing well, but some steps need further information!

Anyway, the workaround works well, and I confirm the proposed changes to lsb_release....

Revision history for this message
peddanet (peddanet) wrote :

Unfortunately today the error occured again, and even if I have installed teamviewer, I do not think, it is above explained problem. It crashes every session 0-2 times and I have absolutely no clue why. It occurs independently which program I start or not, besides Hplipopen, firefox and thunderbird. Sky is not started yet (not even as a background process) and so does teamviewer...

So I have to take back my comment #78, I am sorry.

Revision history for this message
Lian Sebe (csebe) wrote :

Hi guys,

Suffering from this too. Just installed a freshly downloaded Ubuntu 12.04 LTS on my new 64bit Dell 17R laptop. Crash started to appear after installing latest TeamViewer.
Any more info you might need, let me know.

Cheers,
Lian

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

Lian, the package of the proposed repository is OK. You can to make "pinning" — https://help.ubuntu.com/community/PinningHowto:

1) sudo touch /etc/apt/preferences.d/lucid-proposed-100
2) sudo chmod 755 /etc/apt/preferences.d/lucid-proposed-100
3) Edit the file with this content:
Package: *
Pin: release a=precise-proposed
Pin-Priority: 100
4) Mark the "proposed" repository
       See this old picture: https://help.ubuntu.com/community/Repositories/Ubuntu#Updates_Tab
       Read if prefer: https://wiki.ubuntu.com/Testing/EnableProposed
5) sudo apt-get update
6) Simulate: sudo apt-get upgrade -s
7) None? Then the "pinning" is OK.
8) sudo apt-get install lsb/precise-proposed

tags: added: verification-done-precise
Revision history for this message
Eduar Arley Cardona (eduar47) wrote :

Hi.

Updating from proposed fixed my problem.

$ sudo dpkg -l | grep lsb
ii lsb-base 4.0-0ubuntu20.2 Linux Standard Base 4.0 init script functionality
ii lsb-core 4.0-0ubuntu20.2 Linux Standard Base 4.0 core support package
ii lsb-invalid-mta 4.0-0ubuntu20.2 Linux Standard Base sendmail dummy
ii lsb-release 4.0-0ubuntu20.3 Linux Standard Base version reporting utility

$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

@eduar47, the "apt-cache policy lsb" command would be sufficient.

Revision history for this message
Dale Spanheimer (dspanheimer) wrote :

Referencing comment #77, while updating the mentioned python packages did correct some of the weird problems in TeamViwer itself (so it was worth doing) it did not correct the lsb_release errors. I did install the precise-proposed changes as per brian-murray, and the errors have indeed disappeared for me as well. Thanks for the fix!

Revision history for this message
Rangga (rangga101-gmail) wrote :

Tried the fix posted on #39.
Work well for me:
Ubuntu 12.04.2 amd64, Teamviewer 8

Revision history for this message
Judit Fülöp (fulop-judit-o) wrote :

It's only a permission problem. In /opt/teamviewer8/tv_bin/script/tvw_main script there is a line:
 lsb_release -ds > "$WINEPREFIX/drive_c/distrelease"
But the /opt/teamviewer8/tv_bin/wine/drive_c has write permission only for root. So I did this:
 sudo chmod o+w /opt/teamviewer8/tv_bin/wine/drive_c
and the error message disappeared.

Revision history for this message
Alexandre Magno (alexandre-mbm) wrote :

@fulop-judit-o, in your case... but there is the bug 1094218 (or there was it).

Revision history for this message
Bruno Medeiros (brunojcm) wrote :

I could enable the proposed properly and the fix works for me too on precise. Could it be pushed to precise-updates? What's missing?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsb - 4.0-0ubuntu20.3

---------------
lsb (4.0-0ubuntu20.3) precise-proposed; urgency=low

  * lsb_release.py: Use the subprocess module instead of the commands
    module to work around Python SIGCHLD handler issue9127. LP: #1094218
 -- Barry Warsaw <email address hidden> Thu, 06 Jun 2013 17:21:04 -0400

Changed in lsb (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote :

There has not been any positive verification of the fix for this bug in Ubuntu 12.10 (quantal) but looking at the Ubuntu Error tracker we do not see any significant new crashes about the version in -proposed.

https://errors.ubuntu.com/api/1.0/most-common-problems/?format=json&version=4.0-0ubuntu26.2&package=lsb&period=month&limit=10&first_appearance=True

Additionally, looking at the original error there are no occurrences of the crash with this version so I think it is worth releasing to Ubuntu 12.10.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsb - 4.0-0ubuntu26.2

---------------
lsb (4.0-0ubuntu26.2) quantal-proposed; urgency=low

  * lsb_release.py: Use the subprocess module instead of the commands
    module to work around Python SIGCHLD handler issue9127. LP: #1094218
 -- Barry Warsaw <email address hidden> Thu, 13 Jun 2013 10:22:16 -0400

Changed in lsb (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote :

There has not been any positive verification of the fix for this bug in Ubuntu 13.04 (Raring) but looking at the Ubuntu Error tracker we do not see any significant new crashes about the version in -proposed.

https://errors.ubuntu.com/api/1.0/most-common-problems/?format=json&version=4.0-0ubuntu27.1&package=lsb&period=month&limit=10&first_appearance=True

Additionally, looking at the original error there are no occurrences of the crash with this version so I think it is worth releasing to Ubuntu 13.04.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsb - 4.0-0ubuntu27.1

---------------
lsb (4.0-0ubuntu27.1) raring-proposed; urgency=low

  * lsb_release.py: Use the subprocess module instead of the commands
    module to work around Python SIGCHLD handler issue9127. LP: #1094218
 -- Barry Warsaw <email address hidden> Thu, 06 Jun 2013 16:35:30 -0400

Changed in lsb (Ubuntu Raring):
status: Fix Committed → Fix Released
Revision history for this message
oblong (bob-oblong) wrote :

I initially did the permission fix per comment #86; that solved the problem (I was getting the error at boot time; 12.04 LTS; TeamViewer 8 installed).

Then I read (and actually understood #89, so I undid the permission change, ran Update Manager, noticed that lsb (4.0-0ubuntu20.3) was there, and updated.

No error on reboot!

Thanks to all who worked on this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.