Merge logwatch from Debian unstable for 22.04

Bug #1946872 reported by Bryce Harrington
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
logwatch (Ubuntu)
Undecided
Bryce Harrington

Bug Description

Upstream: 7.5.6
Debian: 7.5.5-1
Ubuntu: 7.5.5-1ubuntu3

Debian typically updates logwatch every 5 months on average, but it was last updated 21.01 and looks overdue. Check back in on this monthly.

### New Debian Changes ###

logwatch (7.5.5-1) unstable; urgency=medium

  * New upstream version 7.5.5

 -- Willi Mann <email address hidden> Sun, 31 Jan 2021 19:58:46 +0100

logwatch (7.5.4-1) unstable; urgency=medium

  * New upstream version 7.5.4 (closes: #970684)
  * d/control: Update Homepage field (closes: #956666)
  * d/control: Update Standards-Version from 4.4.1 to 4.5.0
  * Switch to debhelper compat level 11 (from 9)

 -- Willi Mann <email address hidden> Sun, 04 Oct 2020 20:40:40 +0200

logwatch (7.5.2-1) unstable; urgency=medium

  * New upstream version 7.5.2
  * Refresh patches, drop patches included upstream
  * Upgrade policy 4.3.0 -> 4.4.1 (no changes)

 -- Willi Mann <email address hidden> Sun, 12 Jan 2020 12:25:08 +0100

logwatch (7.5.0-2) unstable; urgency=high

  * s/s/kernel: fix typo. closes: 917836

 -- Willi Mann <email address hidden> Sat, 09 Mar 2019 18:14:03 +0100

logwatch (7.5.0-1) unstable; urgency=medium

  * New upstream version
    - closes: 855539 fixed unmatched entries in SSH
    - closes: 905018 match postfix-policyd-spf-python logs
    - closes: 915617 make regex compatible with newer perl versions
    - closes: 824034 fixes handling of ignore_services handling in secure
  * d/control: Remove Suggests on fortune-mod as the zz-fortune script was removed
  * d/control: update standards version 4.1.4 -> 4.3.0 (no changes)
  * exim: parse 'SMTP protocol error in 'AUTH LOGIN'' lines, closes: 886000
  * dovecot: adapt for newer sieve log format, closes: 906045
  * secure: Ignore systemd 'Session /d+ logged out' messages, closes: 907512
  * dovecot: Ignore diagnostic mailbox operation logging.

 -- Willi Mann <email address hidden> Sun, 30 Dec 2018 10:17:30 +0100

logwatch (7.4.3+git20180713-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/changelog: Remove trailing whitespaces
  * d/control: Remove trailing whitespaces
  * d/rules: Remove trailing whitespaces
  * d/watch: Use https protocol

  [ Willi Mann ]
  * New upstream version 7.4.3+git20180713
    - Handle sshd 'key negotiation failed' log messages (closes: 880595)
  * Rebase debian patches
  * Adapt Vcs-* fields as repo moved to salsa
  * update standards version 3.9.8 -> 4.1.4 (no changes)
  * Ignore ecrypt messages in cron (Closes: 862337)
  * scripts/mdadm: Fix parsing of mdadm.conf, properly handle '<ignore>'
    (Closes: 907319)
  * Document workaround for non-conforming SMTP output. (Closes: 871473)
  * Switch to debhelper compat level 9

 -- Willi Mann <email address hidden> Tue, 02 Oct 2018 19:52:16 +0200

logwatch (7.4.3+git20161207-2) unstable; urgency=medium

  * Revert upstream's change of the declared mail charset.
    The declared mail charset in mails from Logwatch was recently changed from
    iso-8859-1 to utf-8. This commit reverts this change to address concerns
    about invalid UTF-8 encodings. (closes: 849531)

 -- Willi Mann <email address hidden> Sat, 21 Jan 2017 17:44:03 +0100

logwatch (7.4.3+git20161207-1) unstable; urgency=medium

  * Imported Upstream version 7.4.3+git20161207
    - kernel: fix parsing of oom killer messages. closes: #833350
  * Refresh patches, remove patches included upstream
  * build_tar.sh: Update to work with GIT repository
  * postfix: Fix unaligned output

 -- Willi Mann <email address hidden> Fri, 16 Dec 2016 20:15:26 +0100

logwatch (7.4.3-2) unstable; urgency=medium

  * s/s/amavis: Fix perl warning 'redundant argument in sprintf'.
    closes: 819572
  * dovecot: Ignore 'Logged out' and 'Debug' lines. closes: #840956, #840952

 -- Willi Mann <email address hidden> Wed, 02 Nov 2016 19:32:35 +0100

logwatch (7.4.3-1) unstable; urgency=medium

  * Imported Upstream version 7.4.3
  * d/control: Update Standards-Version 3.9.6 -> 3.9.8

 -- Willi Mann <email address hidden> Sat, 30 Apr 2016 14:40:57 +0200

### Old Ubuntu Delta ###

logwatch (7.5.5-1ubuntu3) impish; urgency=medium

  * d/tests: Add autopkgtest DEP8 tests (LP: #1679329):
    - d/t/control: New file.
    - d/t/basic-checks: Test basic configuration and version.
    - d/t/syntax-check: Perl syntax checking for the logwatch's scripts.
    - d/t/detail: Check the amount of output when using low, med and
      high values with the detail flag.
    - d/t/su-l-check: Check if properly report when a user become root.
      + d/t/data/su-l: Log portion used in this test.
    - d/t/apparmor-unmatched-entries : Test for not logging as unmatched
      some lines for apparmor audit in kern.log.
      + d/t/data/unmatched-entries-apparmor_kern.log: Log portion
        used in the test (LP #1577948).
    - d/t/packages-and-report: Check if the corresponding section
      is present into logwatch report for a list of packages/services
      (now only for sshd).

 -- Miriam España Acebal <email address hidden> Thu, 29 Jul 2021 16:53:01 +0200

logwatch (7.5.5-1ubuntu2) hirsute; urgency=medium

  * d/p/0010-zz-zfs-detect-zfs-location.patch: Use explicit paths for
    finding zfs and zpool executables.
    (LP: #1880211)

 -- Bryce Harrington <email address hidden> Wed, 14 Apr 2021 20:11:05 +0000

logwatch (7.5.5-1ubuntu1) hirsute; urgency=medium

  * Merge with Debian unstable. Remaining changes:
    - Drop libsys-cpu-perl and libsys-meminfo-perl from Recommends to
      Suggests as they are in universe.
    - d/p/0014-zz-sys-Suppress-warnings-if-Sys-CPU-or-Sys-MemInfo-a.patch:
      zz-sys: Suppress warnings if Sys::CPU or Sys::MemInfo are missing.
      These are not installed by default in Ubuntu's logwatch packaging.
      (LP #1890749)
    - d/p/0015-pam_unix-Ignore-issues-about-etc-securetty-being-mis.patch:
      pam_unix: Ignore issues about /etc/securetty being missing.
      (LP #1890751)
  * Dropped:
    - d/p/0011-postfix-Ignore-Resolved-loghost-to-127.0.0.1.patch:
      postfix: Ignore Resolved loghost to 127.0.0.1.
      (LP: #1583705)
      [Taken upstream]
    - d/p/0012-postfix-Handle-backwards-compatible-mode.patch:
      postfix: Handle backwards-compatible mode.
      (LP #1583705)
      [Taken upstream]
    - d/p/0013-secure-Ignore-warnings-about-gnome-keyring-daemon-it.patch:
      secure: Ignore warnings about gnome-keyring-daemon items already
      registered.
      (LP #1890752)
      [Taken upstream]
    - d/p/0017-audit-Apparmor-DENIED-entries-don-t-always-include-p.patch
      audit: Don't handle 'unconfined' profile changes distinct from ordinary loads
      [Taken upstream]
    - d/p/0018-audit-Handle-apparmor-errors-on-DENIED-messages.patch:
      audit: Treat Denial Errors same as Denied
      (LP #1577948)
      [Taken upstream]
    - d/p/0019-exim-Handle-self-signed-certs-warnings.patch:
      exim: Handle self-signed certs warnings.
      (LP #1892269)
      [Taken upstream]
    - d/p/0020-dhcpd-Ignore-lease-age-under-threshold-messages.patch:
      dhcpd: Ignore lease age under threshold messages
      (LP #1578001)
      [Taken upstream]
    - d/p/0021-audit-use-the-term-ALLOWED-instead-of-Grants.patch:
      audit: use the term ALLOWED instead of Grants
      (LP #1577948)
      [Taken upstream]

 -- Bryce Harrington <email address hidden> Tue, 23 Feb 2021 18:54:42 +0000

Bryce Harrington (bryce)
Changed in logwatch (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
Bryce Harrington (bryce)
description: updated
Changed in logwatch (Ubuntu):
milestone: none → ubuntu-21.11
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers