Logwatch package points to wrong location for zfs utils

Bug #1880211 reported by Stephen Sewell
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
logwatch (Ubuntu)
Fix Released
Medium
Bryce Harrington
Xenial
Fix Released
Medium
Bryce Harrington
Bionic
Fix Released
Medium
Bryce Harrington
Focal
Fix Released
Medium
Bryce Harrington
Groovy
Fix Released
Medium
Bryce Harrington

Bug Description

[Impact]
Logwatch fails to print info for ZFS due to invalid paths to binaries.

[Test Case]
With ZFS installed, run logwatch and note the missing ZFS information.

$ sudo apt-get install zfsutils-linux
$ sudo logwatch --detail Low --range all --service zz-zfs --output stdout

In the bugged version, this produces no output.

With a successful configuration, you will see something such as:

 --------------------- ZFS Report Begin ------------------------

 /dev/zfs and /proc/self/mounts are required.
 Try running 'udevadm trigger' and 'mount -t proc proc /proc' as root.

 ---------------------- ZFS Report End -------------------------

[Regression Potential]
Since logwatch filters logs for errors pertinent to administrators,
standard things to watch out for are undesired changes in this filtering
behavior, such as flagging or failing to flag issues differently than
before, other than the specific messages being filtered with this
change.

[Discussion]
In /usr/share/logwatch/scripts/services/zz-zfs line 54 and 55 are the following.
my $pathto_zpool = $ENV{'pathto_zpool'} || '/usr/sbin/zpool';
my $pathto_zfs = $ENV{'pathto_zfs'} || '/usr/sbin/zfs';

In Ubuntu, the zfs utilities are in /sbin, not /usr/sbin. This causes logwatch to not print info for ZFS even if you're using it.

The fix is just to point to /sbin instead. This is what fixed it for me.

my $pathto_zpool = $ENV{'pathto_zpool'} || '/sbin/zpool';
my $pathto_zfs = $ENV{'pathto_zfs'} || '/sbin/zfs';

Related branches

Revision history for this message
Thomas Hill (t-hill) wrote :

Could you let us know what version of Ubuntu you're using?

Revision history for this message
Stephen Sewell (sewells) wrote :

% lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.4 LTS
Release: 18.04
Codename: bionic

Thomas Hill (t-hill)
tags: added: bionic
Revision history for this message
Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Next steps: we need to determine if this is fixed upstream already, or if a patch needs to be sent upstream. And we need to know if this is fixed in the current development release of Ubuntu. We need to understand the status of these before we can consider patching 18.04.

Changed in logwatch (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Paride Legovini (paride) wrote :

Hi,

The /usr/sbin/zpool path is still present in zz-zfs in upstream's master branch, however I'm not sure they'll consider it an actual issue, as other distros may very well install the zfstools in /usr/sbin.

This is however a non-issue in Ubuntu >= 19.04, as it installs by default in "usrmerge" mode, i.e. with /bin and /sbin being symlinks to the directories with the same name in /usr. So I think this is an issue only for Bionic, and there are in my opinion the premises for a SRU.

tags: added: server-next
Revision history for this message
Paride Legovini (paride) wrote :

Stephen: installing the 'usrmerge' package will convert your system to the merged /usr directories scheme and is likely to make this issue go away. However I am not suggesting you suggesting you to take this path, as there is no way back. Please do it only after estimating the risks of the operation.

Revision history for this message
Stephen Sewell (sewells) wrote :

I don’t think I’ll install usermerge, but it’s good to know this will be fixed after 19.04. In the meantime, I’ve worked around it by editing the script locally.

Revision history for this message
Paride Legovini (paride) wrote :

Actually it's a non-issue only in >=19.04 *new installs*, as the usrmerge conversion is not forced as part of the upgrade process, so we can't just ignore the issue in the newer releases.

I filed an upstream bug [1]. Ideally this will get fixed upstream and the new Ubuntu releases will pick up the fixed package after its release. In Bionic and Focal we can pick the relevant commit and SRU it.

[1] https://sourceforge.net/p/logwatch/bugs/83/

Paride Legovini (paride)
tags: removed: server-next
Revision history for this message
Bryce Harrington (bryce) wrote :

This is fixed upstream now.

Revision history for this message
rich painter (painterengr) wrote :

Same problem occurs with logwatch 7.4.2-1ubuntu1 in U 16:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial

fix is the same.

regards
rich

Revision history for this message
Paride Legovini (paride) wrote :

Upstream fix:

https://sourceforge.net/p/logwatch/git/ci/01136a8b3e14a58660db6cc39138d3e40a852737/

This is not part of Groovy yet as upstream didn't tag a new version yet. The scope of the patch is very limited and clear, it think it can quality for a Xenial and Bionic SRU.

In Focal things could be different if:

 - Upstream releases version 7.5.4
 - Debian picks it up
 - We verify that it qualifies as a bugfix microrelease [1].

Upstream has no note on its version schema. We already have a delta for logwatch in all the supported releases, so it's probably easier to just SRU the patch.

[1] https://wiki.ubuntu.com/StableReleaseUpdates#New_upstream_microreleases

tags: added: server-next
Revision history for this message
Bryce Harrington (bryce) wrote :

This fix is included in the 7.5.4-0ubuntu1 I merged last week

Changed in logwatch (Ubuntu Groovy):
status: Triaged → Fix Released
Bryce Harrington (bryce)
description: updated
Bryce Harrington (bryce)
Changed in logwatch (Ubuntu Focal):
status: New → In Progress
Changed in logwatch (Ubuntu Bionic):
status: New → In Progress
Changed in logwatch (Ubuntu Xenial):
status: New → In Progress
Changed in logwatch (Ubuntu Groovy):
assignee: nobody → Bryce Harrington (bryce)
Changed in logwatch (Ubuntu Focal):
assignee: nobody → Bryce Harrington (bryce)
Changed in logwatch (Ubuntu Bionic):
assignee: nobody → Bryce Harrington (bryce)
Changed in logwatch (Ubuntu Xenial):
assignee: nobody → Bryce Harrington (bryce)
Changed in logwatch (Ubuntu Focal):
importance: Undecided → Medium
Changed in logwatch (Ubuntu Bionic):
importance: Undecided → Medium
Changed in logwatch (Ubuntu Xenial):
importance: Undecided → Medium
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Stephen, or anyone else affected,

Accepted logwatch into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/logwatch/7.5.2-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in logwatch (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Stephen, or anyone else affected,

Accepted logwatch into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/logwatch/7.4.3+git20161207-2ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in logwatch (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Stephen, or anyone else affected,

Accepted logwatch into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/logwatch/7.4.2-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in logwatch (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Revision history for this message
Bryce Harrington (bryce) wrote :

Verified this in in xenial, bionic, and focal in LXC. I needed to adapt the test case for each distro due to changes in zfs behavior on each:

  - On xenial, can run the test case as-is, via 'apt-get install zfs'
  - On bionic, must instead install 'apt-get install zfsutils-linux', but otherwise works ok
  - On focal, installing zfsutils-linux in lxc results in a failure regarding the service not starting, however the zfs tool itself is installed in the expected place, so for purposes of this SRU is verified.

tags: added: verification-done verification-done-bionic verification-done-focal verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-xenial
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logwatch - 7.5.2-1ubuntu1.1

---------------
logwatch (7.5.2-1ubuntu1.1) focal; urgency=medium

  [ Bryce Harrington ]
  * d/p/0020-dhcpd-Ignore-lease-age-under-threshold-messages.patch:
    dhcpd: Ignore lease age under threshold messages
    (LP: #1578001)
  * d/p/0019-exim-Handle-self-signed-certs-warnings.patch:
    exim: Handle self-signed certs warnings.
    (LP: #1892269)
  * d/p/0018-audit-Treat-Denial-Errors-same-as-Denied.patch:
    audit: Treat Denial-Errors same as Denied.
    (LP: #1577948)
  * d/p/0017-audit-Apparmor-DENIED-entries-don-t-always-include-p.patch:
    audit: Apparmor DENIED entries don't always include parent=N.
    (LP: #1577948)
  * d/p/0015-pam_unix-Ignore-issues-about-etc-securetty-being-mis.patch:
    pam_unix: Ignore issues about /etc/securetty being missing.
    (LP: #1890751)
  * d/p/0014-zz-sys-Suppress-warnings-if-Sys-CPU-or-Sys-MemInfo-a.patch:
    zz-sys: Suppress warnings if Sys::CPU or Sys::MemInfo are missing.
    These are not installed by default in Ubuntu's logwatch packaging.
    (LP: #1890749)
  * d/p/0013-secure-Ignore-warnings-about-gnome-keyring-daemon-it.patch:
    secure: Ignore warnings about gnome-keyring-daemon items already
    registered.
    (LP: #1890752)
  * d/p/0012-postfix-Handle-backwards-compatible-mode.patch:
    postfix: Handle backwards-compatible mode.
    (LP: #1583705)
  * d/p/0011-postfix-Ignore-Resolved-loghost-to-127.0.0.1.patch:
    postfix: Ignore Resolved loghost to 127.0.0.1.
    (LP: #1583705)
  * d/p/0010-00-debspecific-disable-su-reporting-in-secure.diff.patch:
    Use $PATH to determine location of zpool and zfs.
    (LP: #1880211)

  [ Lucas Kanashiro ]
  * d/p/0021-audit-use-the-term-ALLOWED-instead-of-Grants.patch:
    audit: use the term ALLOWED instead of Grants.
    (LP: #1577948)

 -- Bryce Harrington <email address hidden> Thu, 03 Sep 2020 04:22:00 +0000

Changed in logwatch (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for logwatch has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logwatch - 7.4.3+git20161207-2ubuntu1.2

---------------
logwatch (7.4.3+git20161207-2ubuntu1.2) bionic; urgency=medium

  [ Bryce Harrington ]
  * d/p/0020-dhcpd-Ignore-lease-age-under-threshold-messages.patch:
    dhcpd: Ignore lease age under threshold messages
    (LP: #1578001)
  * d/p/0018-audit-Treat-Denial-Errors-same-as-Denied.patch:
    audit: Treat Denial-Errors same as Denied.
    (LP: #1577948)
  * d/p/0017-audit-Apparmor-DENIED-entries-don-t-always-include-p.patch:
    audit: Apparmor DENIED entries don't always include parent=N.
    (LP: #1577948)
  * d/p/0014-zz-sys-Suppress-warnings-if-Sys-CPU-or-Sys-MemInfo-a.patch:
    zz-sys: Suppress warnings if Sys::CPU or Sys::MemInfo are missing.
    These are not installed by default in Ubuntu's logwatch packaging.
    (LP: #1890749)
  * d/p/0012-postfix-Handle-backwards-compatible-mode.patch:
    postfix: Handle backwards-compatible mode.
    (LP: #1583705)
  * d/p/0011-postfix-Ignore-Resolved-loghost-to-127.0.0.1.patch:
    postfix: Ignore Resolved loghost to 127.0.0.1.
    (LP: #1583705)
  * d/p/0010-00-debspecific-disable-su-reporting-in-secure.diff.patch:
    Use $PATH to determine location of zpool and zfs.
    (LP: #1880211)

  [ Karl Stenerud ]
  * d/p/ssh-ignore-disconnected.patch:
    sshd: ignore disconnected from user USER
    (LP: #1644057)

 -- Bryce Harrington <email address hidden> Thu, 03 Sep 2020 04:21:53 +0000

Changed in logwatch (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logwatch - 7.4.2-1ubuntu1.1

---------------
logwatch (7.4.2-1ubuntu1.1) xenial; urgency=medium

  [ Bryce Harrington ]
  * d/p/0020-dhcpd-Ignore-lease-age-under-threshold-messages.patch:
      dhcpd: Ignore lease age under threshold messages
      (LP: #1578001)
  * d/p/0018-audit-Treat-Denial-Errors-same-as-Denied.patch:
    audit: Treat Denial-Errors same as Denied.
    (LP: #1577948)
  * d/p/0017-audit-Apparmor-DENIED-entries-don-t-always-include-p.patch:
    audit: Apparmor DENIED entries don't always include parent=N.
    (LP: #1577948)
  * d/p/0014-zz-sys-Suppress-warnings-if-Sys-CPU-or-Sys-MemInfo-a.patch:
    zz-sys: Suppress warnings if Sys::CPU or Sys::MemInfo are missing.
    These are not installed by default in Ubuntu's logwatch packaging.
    (LP: #1890749)
  * d/p/0012-postfix-Handle-backwards-compatible-mode.patch:
    postfix: Handle backwards-compatible mode.
    (LP: #1583705)
  * d/p/0011-postfix-Ignore-Resolved-loghost-to-127.0.0.1.patch:
    postfix: Ignore Resolved loghost to 127.0.0.1.
    (LP: #1583705)
  * d/p/0010-00-debspecific-disable-su-reporting-in-secure.diff.patch:
    Use $PATH to determine location of zpool and zfs.
    (LP: #1880211)

  [ Karl Stenerud ]
  * d/p/ssh-ignore-disconnected.patch:
    sshd: ignore disconnected from user USER
    (LP: #1644057)

 -- Bryce Harrington <email address hidden> Thu, 03 Sep 2020 04:21:50 +0000

Changed in logwatch (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
rich painter (painterengr) wrote :

I'm running Ubuntu 16.04.7 LTS 64bit and Logwatch 7.4.2.
My root user has /sbin in the path and when I run zpool I don't have to prefix it with the path.

Still to make this logwatch section work, I had previously edited my /usr/share/logwatch/scripts/services/zz-zfs on lines 54 and 55 to have the a different path "/sbin/zpool" and "/sbin/zfs" some time back.

However recently logwatch stopped reporting the ZFS section. For some strange reason file zz-zfs lines 54 and 55 now say:
my $pathto_zpool = $ENV{'pathto_zpool'} || 'zpool';
my $pathto_zfs = $ENV{'pathto_zfs'} || 'zfs';

And $pathto_zpool gets set to zpool. But the test on line 59 takes the "exit 0". This test for existence requires a path!!! So whoever changed this did this wrong!

I AGAIN have changed these lines to:
my $pathto_zpool = $ENV{'pathto_zpool'} || '/sbin/zpool';
my $pathto_zfs = $ENV{'pathto_zfs'} || '/sbin/zfs';

and all is working!

Revision history for this message
Robie Basak (racb) wrote :

Reopening based on the claim in the previous comment. Bryce, please could you take a look?

Changed in logwatch (Ubuntu Xenial):
status: Fix Released → New
Revision history for this message
Stephen Sewell (sewells) wrote :

Sorry for the delay, I finally got around to trying to verify myself. It doesn't appear fixed to me either.

root@ubuntu:/etc# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic

root@ubuntu:/etc# dpkg -s logwatch | grep -i version
Version: 7.4.3+git20161207-2ubuntu1.2

I took out my local fix yesterday and this is what I received in my log summary this morning.

 ---------------------- Disk Space End -------------------------

 ###################### Logwatch End #########################

Normally this is where the zfs stuff would be. E.g.

---------------------- Disk Space End -------------------------

 --------------------- ZFS Report Begin ------------------------

 Total ZFS pools: 1
 Total filesystems: 24 (24 mounted)
 Total snapshots: 5845
 Total volumes: 0
...

Revision history for this message
Bert Van de Poel (bhack) wrote :

I'm experiencing the same problem as comment #20 describes. Paths have been replaced with just command names, but those won't work for the tests performed. I'm on Ubuntu 18.04 however, so this I think the status should also be changed for bionic. I actually expect this is broken in all versions listed.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in logwatch (Ubuntu Xenial):
status: New → Confirmed
Revision history for this message
Stephen Sewell (sewells) wrote :

Back in #4, Paride speculated that this would be resolved in Ubuntu >= 19.04. I did a clean install of 20.04 last week and this is still an issue there.

Bryce Harrington (bryce)
description: updated
Revision history for this message
Stephen Sewell (sewells) wrote :

If its helpful, the proper output looks like this.

 --------------------- ZFS Report Begin ------------------------

 Total ZFS pools: 1
 Total filesystems: 24 (24 mounted)
 Total snapshots: 1926
 Total volumes: 0

 ------------------- ZFS Pool Summary -------------------

   Pool Name Size (MiB) Used (MiB) Free (MiB) Dedup
   tank 18979225.6 5767168.0 13212057.6 1.00x 30%

 --------------------------------------------------------

 ------------------- ZFS Pool Status -------------------

   pool: tank
  state: ONLINE
   scan: scrub repaired 0B in 0 days 03:59:20 with 0 errors on Sun Mar 14 04:23:21 2021
 config:

        NAME STATE READ WRITE CKSUM
        tank ONLINE 0 0 0
          raidz2-0 ONLINE 0 0 0
            sdb ONLINE 0 0 0
            sdc ONLINE 0 0 0
            sdd ONLINE 0 0 0
            sde ONLINE 0 0 0

 errors: No known data errors

 -------------------------------------------------------

 ---------------------- ZFS Report End -------------------------

Bryce Harrington (bryce)
Changed in logwatch (Ubuntu Xenial):
status: Confirmed → In Progress
Revision history for this message
Bryce Harrington (bryce) wrote :

The intention of upstream's fix appears to want to rely on $PATH for running zpool and zfs, however as mentioned in comment #20, the test after the setting needs a full path:

my $pathto_zpool = $ENV{'pathto_zpool'} || '/usr/sbin/zpool';
...
if (!-x $pathto_zpool) {
   # Doesn't support ZFS
   exit 0;
}

Perl's '-x' operator works on files/filehandles (c.f. https://perldoc.perl.org/functions/-X), and does not take $PATH into account, as can be seen in this trivial test case:

    logwatch-sru-lp1880211-xenial+16.04:~$ cat testcase
    #!/usr/bin/perl
    if (-x '/usr/bin/less') { print "abspath ok\n"; } else { print "abspath nak\n"; }
    if (-x 'less') { print "relpath ok\n"; } else { print "relpath nak\n"; }

    logwatch-sru-lp1880211-xenial+16.04:~$ perl testcase
    abspath ok
    relpath nak

For what upstream intends, I suspect the "proper" fix would be to use something like Perl's searchpath() (c.f. https://metacpan.org/pod/File::SearchPath). In Ubuntu searchpath() is provided by the libfile-searchpath-perl binary package which unfortunately is only available from universe. Fortunately, in this case we can make the assumption that the tool will only be in /sbin or /usr/sbin, and just look in those spots rather than the full path formally.

Changed in logwatch (Ubuntu Bionic):
status: Fix Released → In Progress
Changed in logwatch (Ubuntu Focal):
status: Fix Released → In Progress
Changed in logwatch (Ubuntu Groovy):
status: Fix Released → In Progress
Changed in logwatch (Ubuntu):
status: Fix Released → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logwatch - 7.5.5-1ubuntu2

---------------
logwatch (7.5.5-1ubuntu2) hirsute; urgency=medium

  * d/p/0010-zz-zfs-detect-zfs-location.patch: Use explicit paths for
    finding zfs and zpool executables.
    (LP: #1880211)

 -- Bryce Harrington <email address hidden> Wed, 14 Apr 2021 20:11:05 +0000

Changed in logwatch (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Stephen, or anyone else affected,

Accepted logwatch into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/logwatch/7.5.2-1ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in logwatch (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
removed: verification-done verification-done-focal
Changed in logwatch (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed-groovy
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Stephen, or anyone else affected,

Accepted logwatch into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/logwatch/7.5.4-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in logwatch (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
removed: verification-done-xenial
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Stephen, or anyone else affected,

Accepted logwatch into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/logwatch/7.4.2-1ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in logwatch (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
removed: verification-done-bionic
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Stephen, or anyone else affected,

Accepted logwatch into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/logwatch/7.4.3+git20161207-2ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Bryce Harrington (bryce) wrote :

On all target releases, I've reproduced the bug with the old logwatch version, and verified the issue is resolved with the new logwatch version.

tags: added: verification-done verification-done-bionic verification-done-focal verification-done-groovy verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-groovy verification-needed-xenial
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logwatch - 7.5.4-0ubuntu3.1

---------------
logwatch (7.5.4-0ubuntu3.1) groovy; urgency=medium

  * d/p/0010-zz-zfs-detect-zfs-location.patch: Use explicit paths for
    finding zfs and zpool executables.
    (LP: #1880211)

 -- Bryce Harrington <email address hidden> Wed, 14 Apr 2021 20:09:47 +0000

Changed in logwatch (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logwatch - 7.5.2-1ubuntu1.2

---------------
logwatch (7.5.2-1ubuntu1.2) focal; urgency=medium

  * Replace zfs/zpool executable detection change with fixed version.
    - Add d/p/0010-zz-zfs-detect-zfs-location.patch
    - Drop d/p/0010-00-debspecific-disable-su-reporting-in-secure.diff.patch
    (LP: #1880211)

 -- Bryce Harrington <email address hidden> Fri, 16 Apr 2021 16:05:11 +0000

Changed in logwatch (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logwatch - 7.4.3+git20161207-2ubuntu1.3

---------------
logwatch (7.4.3+git20161207-2ubuntu1.3) bionic; urgency=medium

  * Replace zfs/zpool executable detection change with fixed version.
    - Add d/p/0010-zz-zfs-detect-zfs-location.patch
    - Drop d/p/0010-00-debspecific-disable-su-reporting-in-secure.diff.patch
    (LP: #1880211)

 -- Bryce Harrington <email address hidden> Wed, 14 Apr 2021 19:32:23 +0000

Changed in logwatch (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logwatch - 7.4.2-1ubuntu1.2

---------------
logwatch (7.4.2-1ubuntu1.2) xenial; urgency=medium

  * Replace zfs/zpool executable detection change with fixed version.
    - Add d/p/0010-zz-zfs-detect-zfs-location.patch
    - Drop d/p/0010-00-debspecific-disable-su-reporting-in-secure.diff.patch
    (LP: #1880211)

 -- Bryce Harrington <email address hidden> Wed, 07 Apr 2021 15:14:57 -0700

Changed in logwatch (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers