Sync logilab-common 0.50.1-1 (universe) from Debian unstable (main)

Bug #585329 reported by Stefano Rivera
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
logilab-common (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync logilab-common 0.50.1-1 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:

logilab no longer has an issue with Python 2.6 and won't try to install things
to /usr/local.

Changelog entries since current maverick version 0.45.2-1ubuntu2:

logilab-common (0.50.1-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - removed XB-Python-Version from binary stanza
  * debian/copyright
    - upstream switched from GPLv2 to LPGLv2.1, updating information accordingly
  * debian/{control, rules, patches/*}
    - removed dpatch, no more needed
  * debian/rules
    - remove the dummy __init__.py after do has built, else epydoc refuses to
      build it
    - use py_setup_install_args, including python.mk
  * debian/control
    - bump versione b-d on python (to properly support --install-layout=deb)

 -- Sandro Tosi <email address hidden> Wed, 28 Apr 2010 20:33:21 +0200

logilab-common (0.49.0-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - drop Suggests on python-pyodbc, now the database layer is moved in another
      package
  * debian/patches/10_remove_distutils_version_check.dpatch
    - updated for new upstream code
  * debian/rules
    - explicitly tell where the tests are, so also 'data' dir is found and tests
      run as expected; now we can start looking at tests failures as valid ones;
      Closes: #571688

 -- Sandro Tosi <email address hidden> Tue, 23 Mar 2010 00:12:31 +0100

logilab-common (0.48.1-1) unstable; urgency=low

  * New upstream release
  * debian/rules
    - use '*-packages' when removing test dir

 -- Sandro Tosi <email address hidden> Sat, 27 Feb 2010 09:38:47 +0100

logilab-common (0.48.0-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - suggests python-pyodbc
    - added python-egenix-mxdatetime to b-d-i to enable part of test suite
  * debian/copyright
    - updated upstream and Debian packaging copyright years
  * debian/{control, rules}
    - added dpatch
  * debian/patches/10_remove_distutils_version_check.dpatch
    - remove the check for distutils version, and the removal of
      --install-layout=deb; thanks to Jakub Wilk for the report; Closes: #571478
  * debian/README.source
    - added

 -- Sandro Tosi <email address hidden> Fri, 26 Feb 2010 20:41:19 +0100

logilab-common (0.46.0-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - bump Standards-Version to 3.8.4 (no changes needed)

 -- Sandro Tosi <email address hidden> Sat, 30 Jan 2010 10:37:09 +0100

Benjamin Drung (bdrung)
Changed in logilab-common (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logilab-common - 0.50.1-1

---------------
logilab-common (0.50.1-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - removed XB-Python-Version from binary stanza
  * debian/copyright
    - upstream switched from GPLv2 to LPGLv2.1, updating information accordingly
  * debian/{control, rules, patches/*}
    - removed dpatch, no more needed
  * debian/rules
    - remove the dummy __init__.py after do has built, else epydoc refuses to
      build it
    - use py_setup_install_args, including python.mk
  * debian/control
    - bump versione b-d on python (to properly support --install-layout=deb)

logilab-common (0.49.0-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - drop Suggests on python-pyodbc, now the database layer is moved in another
      package
  * debian/patches/10_remove_distutils_version_check.dpatch
    - updated for new upstream code
  * debian/rules
    - explicitly tell where the tests are, so also 'data' dir is found and tests
      run as expected; now we can start looking at tests failures as valid ones;
      Closes: #571688

logilab-common (0.48.1-1) unstable; urgency=low

  * New upstream release
  * debian/rules
    - use '*-packages' when removing test dir

logilab-common (0.48.0-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - suggests python-pyodbc
    - added python-egenix-mxdatetime to b-d-i to enable part of test suite
  * debian/copyright
    - updated upstream and Debian packaging copyright years
  * debian/{control, rules}
    - added dpatch
  * debian/patches/10_remove_distutils_version_check.dpatch
    - remove the check for distutils version, and the removal of
      --install-layout=deb; thanks to Jakub Wilk for the report; Closes: #571478
  * debian/README.source
    - added

logilab-common (0.46.0-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - bump Standards-Version to 3.8.4 (no changes needed)
 -- Stefano Rivera <email address hidden> Wed, 28 Apr 2010 20:33:21 +0200

Changed in logilab-common (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers