Support for Mozilla Location Service (A-GPS)

Bug #1648077 reported by Johannah Sprinz
40
This bug affects 10 people
Affects Status Importance Assigned to Milestone
UBports System Image
Fix Released
Undecided
Ricardo
location-service (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Currently, A-GPS is only available on commercial UT-devices through Nokia HERE. This is a real problem for users of community ports (like those provided by ubports.com). Also, the HERE service is closed source and proprietary, that's kind of odd for the free operating system we all want Ubuntu Touch to be.

I suggest that we try to implement the Mozilla Location Service, which is a free and open source location service: https://location.services.mozilla.com/

There is a bounty on Bountysource on this: https://www.bountysource.com/issues/39808752-support-for-mozilla-location-service-a-gps

Tags: bounty
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in location-service (Ubuntu):
status: New → Confirmed
Yrjö Selänne (yselnne)
tags: added: bounty
Revision history for this message
extraymond@gmail.com (extraymond) wrote :

This will definitely help ports like ubport greatly, and it can enable roms to be more feature complete if a-gps is enabled.

Many people use 2nd-hand or refurbished cellphone as car navigator or such, if a-gps is enabled, I bet the desire to port more devices into ubuntu will be higher.

Changed in ubports-meta:
status: New → Fix Released
assignee: nobody → Ricardo (ing-mendoza-ricardo)
Changed in location-service (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers