FTBFS in zesty

Bug #1640320 reported by Dimitri John Ledkov on 2016-11-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
location-service (Ubuntu)
High
Unassigned

Bug Description

FTBFS in zesty during a no change rebuild against new boost

Please see build logs at: https://launchpad.net/ubuntu/+source/location-service/3.0.0+16.10.20160912-0ubuntu2

Please help fix this

[ 10%] Building CXX object src/location_service/com/ubuntu/location/CMakeFiles/ubuntu-location-service-connectivity.dir/connectivity/wireless_network.cpp.o
cd /<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/obj-x86_64-linux-gnu/src/location_service/com/ubuntu/location && /usr/bin/g++ -DCOM_UBUNTU_LOCATION_SERVICE_HAVE_NET_CPP=1 -DCOM_UBUNTU_LOCATION_SERVICE_HAVE_UBUNTU_PLATFORM_HARDWARE_API -DCOM_UBUNTU_LOCATION_SERVICE_PROVIDERS_GEOCLUE -DCOM_UBUNTU_LOCATION_SERVICE_PROVIDERS_GPS -Dubuntu_location_service_connectivity_EXPORTS -I/<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/3rd-party -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/json-c -I/<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/include/location_service -I/<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/src/location_service -I/<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/obj-x86_64-linux-gnu/src/location_service -I/usr/include/ubuntu -g -O2 -fdebug-prefix-map=/<<BUILDDIR>>/location-service-3.0.0+16.10.20160912=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -std=c++11 -Wall -fno-strict-aliasing -pedantic -Wextra -fPIC -Wno-error=unused-local-typedefs -fPIC -o CMakeFiles/ubuntu-location-service-connectivity.dir/connectivity/wireless_network.cpp.o -c /<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/src/location_service/com/ubuntu/location/connectivity/wireless_network.cpp
In file included from /<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/src/location_service/com/ubuntu/location/providers/gps/sntp_client.h:21:0,
                 from /<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/src/location_service/com/ubuntu/location/providers/gps/sntp_client.cpp:19:
/<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/src/location_service/com/ubuntu/location/providers/gps/android_hardware_abstraction_layer.h:57:14: error: ‘vector’ in namespace ‘std’ does not name a template type
         std::vector<std::string> xtra_hosts
              ^~~~~~
/<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/src/location_service/com/ubuntu/location/providers/gps/android_hardware_abstraction_layer.h:59:10: warning: extra ‘;’ [-Wpedantic]
         };
          ^
/<<BUILDDIR>>/location-service-3.0.0+16.10.20160912/src/location_service/com/ubuntu/location/providers/gps/android_hardware_abstraction_layer.h:66:18: error: ‘vector’ in namespace ‘std’ does not name a template type
     virtual std::vector<char> download_xtra_data(const Configuration& config) = 0;
                  ^~~~~~
make -f po/CMakeFiles/pofiles_70.dir/build.make po/CMakeFiles/pofiles_70.dir/depend

Related branches

Brian Morton (rokclimb15) wrote :

I don't see evidence of this error in the amd64 build log at https://launchpadlibrarian.net/298782129/buildlog_ubuntu-zesty-amd64.location-service_3.0.0+16.10.20160912-0ubuntu2_BUILDING.txt.gz. However, the package does FTBFS due to this bug https://bugs.launchpad.net/ubuntu/+source/googletest/+bug/1644062

Looks like it may need some CMakeLists changes to be compatible with GoogleTest 1.8

Tiago Stürmer Daitx (tdaitx) wrote :

I believe that the failed builds were re-run since the first report by Dimitri and then failed due to googletest. After fixing the googletest issues then we end up with another FTBFS caused by missing 'vector' includes.

I have added a merge proposal with the fixes in place.

Changed in location-service (Ubuntu):
status: New → Confirmed
Balint Reczey (rbalint) on 2017-03-22
Changed in location-service (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Balint Reczey (rbalint)
Balint Reczey (rbalint) wrote :

The CMake part did not work for me, but the attached patch does.
I kept the vector related part giving credit in d/changelog. Thanks!

Balint Reczey (rbalint) wrote :

Now it contains the build-dependency changes as well, tested with sbuild and ratt

The attachment "debdiff for fixing all build issues" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in location-service (Ubuntu):
importance: Undecided → High
Balint Reczey (rbalint) wrote :

Thomas will merge the fix from bzr and will take care of zesty landing thus this debdiff is obsolete.

ping please :)
mir has been accepted, we have only two packages left now

Nish Aravamudan (nacc) wrote :

Based upon c#6 unsubscribing ubuntu-sponsors.

Balint Reczey (rbalint) on 2017-04-06
Changed in location-service (Ubuntu):
assignee: Balint Reczey (rbalint) → nobody
status: In Progress → Confirmed

this is the last blocker for boost 1.61 removal.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package location-service - 3.0.0+16.10.20160912-0ubuntu3

---------------
location-service (3.0.0+16.10.20160912-0ubuntu3) artful; urgency=high

  [ Tiago Stürmer Daitx ]
  * Fix zesty FTBFS by adding the missing vector includes

  [ Balint Reczey ]
  * Build-depend on googletest instead of google-mock and libgtest-dev
  * Don't FTBFS with google-mock installed (LP: #1640320)
  * Don't ship google test files in binary packages

 -- Balint Reczey <email address hidden> Thu, 23 Mar 2017 12:04:47 +0000

Changed in location-service (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers