rc-proposed location is way out in comparison to ota6

Bug #1500918 reported by Dave Morley on 2015-09-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
location-service (Ubuntu)
Critical
Alberto Mardegan

Bug Description

DESCRIPTION:
Ota 6 accurately positions me on the wednesfield road in rc-proposed it is positioning me in Mount Road this is approximately 11 miles across town.

STEPS:
1. install rc-proposed
2. Open locations or pull down on the nearby scope

EXPECTED:
I expect rc-proposed to match ota6

ACTUAL:
The positioning is approximately 11 miles out

https://goo.gl/maps/RZ5K3EzhG262

VERSIONS:
current build number: 525
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en-proposed
last update: 2015-09-29 14:44:52
version version: 525
version ubuntu: 20150929
version device: 20150821-736d127
version custom: 20150925-901-35-40-vivid

This equates to Image 135 on rc-proposed + custom tarball

Also is the same on Arale with custom tarball and confirmed on:

current build number: 124
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en
last update: 2015-09-29 15:20:36
version version: 124
version ubuntu: 20150929
version device: 20150818-0b38025
version custom: 20150814-887-8-46

Dave Morley (davmor2) on 2015-09-29
tags: added: qa-manual-testing
Dave Morley (davmor2) on 2015-09-29
description: updated
Pat McGowan (pat-mcgowan) wrote :

see also https://bugs.launchpad.net/ubuntu/+source/location-service/+bug/1500039 for a similar but different description

Changed in location-service (Ubuntu):
assignee: nobody → Jim Hodapp (jhodapp)
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Changed in location-service (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
assignee: Jim Hodapp (jhodapp) → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) wrote :

Hi Dave, I wonder if you would be able to collect more logs?

Edit /etc/init/ubuntu-espoo-service.conf and /etc/init/ubuntu-location-service.override and change the start sequence to add some env vars:
    export GLOG_v=200
    export GLOG_logtostderr=1
before the exec. Reboot, and start the app. You should have some log files under /var/log/upstart/ubuntu-espoo-service.log and /var/log/upstart/ubuntu-location-service.log

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Alberto Mardegan (mardy) wrote :

Additional comment from Dave: "mardy: after a few minutes I update and the location is then fairly accurate"

tags: added: regression-proposed
Dave Morley (davmor2) wrote :

This seems to be fixed with the recent landing for OTA8

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → ww46-2015
status: New → Fix Committed
Changed in location-service (Ubuntu):
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers