location is inaccurate

Bug #1426307 reported by Jean-Baptiste Lallement on 2015-02-27
170
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Canonical Phone Foundations
location-service (Ubuntu)
High
Thomas Voß
Vivid
Undecided
Unassigned
location-service (Ubuntu RTM)
High
Thomas Voß

Bug Description

current build number: 122
device name: krillin
channel: ubuntu-touch/devel-proposed
alias: ubuntu-touch/vivid-proposed
last update: 2015-02-25 15:06:29
version version: 122
version ubuntu: 20150225
version device: 20150210-95b6a9f
version custom: 20150225

Location is inaccurate, it thinks that I'm several kilometres away from my actual location, in the middle of the sea.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubuntu-location-service-bin 2.1+15.04.20150126.1-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.16.1-0ubuntu2
Architecture: armhf
Date: Fri Feb 27 11:10:42 2015
InstallationDate: Installed on 2015-02-25 (2 days ago)
InstallationMedia: Ubuntu Vivid Vervet (development branch) - armhf (20150225-020204)
SourcePackage: location-service
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.init.ubuntu.location.service.conf: 2015-02-10T21:38:59

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
tags: added: lt-blocker lt-category-visible
Pat McGowan (pat-mcgowan) wrote :

This may be fixed now that gs is on reliably?

Changed in canonical-devices-system-image:
assignee: nobody → Canonical Phone Foundations (canonical-phonedations-team)
importance: Undecided → High
milestone: none → ww13-2015
status: New → Confirmed
tags: removed: lt-blocker
Jean-Baptiste Lallement (jibel) wrote :

It is still a problem on recent builds (krillin #154 and previous)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in location-service (Ubuntu):
status: New → Confirmed
Changed in location-service (Ubuntu):
importance: Undecided → High
tags: added: lt-blocker
Franck (alci) wrote :

I'm affected as well, on a BQ Aquaris (update version 20).

LionelB (retweet) wrote :

BQ Aquaris version 20 also. I reported elsewhere that GeoIP is over-riding GPS in NearBy after restart. This was correcting on refresh but now it has refreshed to a remembered GPS rather than to the current GPS fix.
GPS on HERE maps works fine.

tags: added: bq
Changed in location-service (Ubuntu RTM):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Thomas Voß (thomas-voss)
ockels (ockels) wrote :

Also confirmed here onBQ aquaris 20 too. GPS only signal fails. No usable signal whatsoever. Just took a walk from half an hour with GPS and location both turned on and the phone in my hand. Tested with the following apps: location service test, bikemap and heremaps. All my other devices found the location within seconds or minutes.

GPS position source is valid: true
Coordinate is valid: false
Latitude: nan
Longitude:nan
Altitude: nan
Supported methods: All/multiple
Preferred methods: Satellite
horizontalAccuracyValid: false
horizontalAccuracy(m): nan
verticalAccuracyValid:false
Latitude is valid: false
Longitude is valid: false
Altitude is valid: false
Position source error: NoError

Changed in canonical-devices-system-image:
milestone: ww13-2015 → ww17-2015
Luksus (lukas-baubkus) wrote :

BQ aquaris r21:
My impression is that GPS isn't working at all.
Every found location data comes from the wifi/mobile location service.

Thomas Voß (thomas-voss) wrote :

If possible, could someone please provide the following information: https://wiki.ubuntu.com/Process/Merges/TestPlan/location-service#Forensics

Luksus (lukas-baubkus) wrote :

Here I have some outputs and logs...
Sometimes the Terminal-app crashed, if I selected some text and touched it.
After this the output of "ubuntu-location-serviced-cli --bus system --get --property visible_space_vehicles" gave me an error and I was not able to deactivate/reactivate the GPS or wifi-location-thing - the switches just jumped back.

Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Confirmed
Changed in location-service (Ubuntu RTM):
assignee: Thomas Voß (thomas-voss) → Manuel de la Peña (mandel)
Changed in location-service (Ubuntu):
assignee: nobody → Manuel de la Peña (mandel)
Changed in canonical-devices-system-image:
milestone: ww17-2015 → ww22-2015
Pat McGowan (pat-mcgowan) wrote :

Comparing mako/rtm with arale/vivid
with Wifi off on each, both show inaccurate locaiton based ont he towers although the locations are not identical, each around 1/4 mi away.

With wifi turned on mako/rtm gets a very accurate reading
Wifi wifi turned on arale/vivid location does not change.

output from sudo GLOG_logtostderr=1 GLOG_v=100 ubuntu-location-serviced --testing --bus system shows wifi aps are visible

Changed in canonical-devices-system-image:
importance: High → Critical
Changed in location-service (Ubuntu):
importance: High → Critical

As said in <https://wiki.ubuntu.com/Bugs/Bug%20importances>, this bug doesn't meet the criteria for being marked as critical.

Changed in location-service (Ubuntu RTM):
importance: High → Critical
Changed in location-service (Ubuntu):
importance: Critical → High
Changed in location-service (Ubuntu RTM):
importance: Critical → High
Pat McGowan (pat-mcgowan) wrote :

With all due respect this bug is a release blocker and I think meets criteria of
"Severely affects applications beyond the package responsible for the root cause"
as a map cannot get your location which makes it unuseable

Changed in location-service (Ubuntu):
assignee: Manuel de la Peña (mandel) → Thomas Voß (thomas-voss)
Changed in location-service (Ubuntu RTM):
assignee: Manuel de la Peña (mandel) → Thomas Voß (thomas-voss)
Pat McGowan (pat-mcgowan) wrote :

Testing with silo 5
with the updated lib the location is a bit better
The updated Here provider prevents the service from starting and no indicator is shown

Pat McGowan (pat-mcgowan) wrote :

I tired the silo on an arale with no SIM card
I never get a location so I suspect its still not using Wifi aps

Thomas Voß (thomas-voss) wrote :

Please note that you are likely not using the right package from the silo due to:

phablet@ubuntu-phablet:/tmp/build$ apt-cache policy libubuntu-location-service2
libubuntu-location-service2:
  Installed: 2.1+15.04.20150427.1-0ubuntu1
  Candidate: 2.1+15.04.20150427.1-0ubuntu1
  Version table:
     2.1+15.04.20150527-0ubuntu1 0
        500 http://ppa.launchpad.net/ci-train-ppa-service/landing-005/ubuntu/ vivid/main armhf Packages
 *** 2.1+15.04.20150427.1-0ubuntu1 0
       1001 http://ppa.launchpad.net/ci-train-ppa-service/stable-phone-overlay/ubuntu/ vivid/main armhf Packages
        100 /var/lib/dpkg/status
     2.1+15.04.20150226-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ vivid/universe armhf Packages

I'm preparing a standalone silo for this fix to also untangle from the other fixes in silo 5.

Launchpad Janitor (janitor) wrote :
Download full text (15.3 KiB)

This bug was fixed in the package location-service - 2.1+15.10.20150528.3-0ubuntu1

---------------
location-service (2.1+15.10.20150528.3-0ubuntu1) wily; urgency=medium

  [ Thomas Voß ]
  * Make sure we always hand a lock owning its mutex to
    on_access_point_added. (LP: #1426307)

location-service (2.1+15.04.20150427.1-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * Make sure that cached modems are considered as well when calculating
    connection characteristics.

location-service (2.1+15.04.20150424-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * Improve the selection of the bag of providers to ensure that the
    locations used are within a reasonable time margin.
  * Remove the pimpl implementation from the providers and hide their
    public headers because they should only be used within the project.

  [ Thomas Voß ]
  * Increase default timeout for downloading gps xtra data. (LP:
    #1447161)

location-service (2.1+15.04.20150417-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * If an exception is thrown from the io_executor run method it must be
    caught, logger and continued with the main loop.

location-service (2.1+15.04.20150226-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * Launchpad automatic translations update. added: po/af.po po/bg.po
    po/sk.po
  * New rebuild forced.

  [ thomas-voss ]
  * Account for dbus interface breakage in NM from 0.9.8.8 -> 0.9.10.0.

location-service (2.1+15.04.20150213-0ubuntu1) vivid; urgency=medium

  [ thomas-voss ]
  * Automatically clean up session store for dead clients. (LP:
    #1418033)

location-service (2.1+15.04.20150126.1-0ubuntu1) vivid; urgency=low

  [ thomas-voss ]
  * Make the remote::Provider::Stub fail loudly on construction if the
    other side is not reachable. Relax the exception in
    location::Daemon::main and do not exit if instantiating a provider
    fails. (LP: #1414591)

location-service (2.1+15.04.20150125~rtm-0ubuntu1) 14.09; urgency=low

  [ CI Train Bot ]
  * Resync trunk

  [ thomas-voss ]
  * Add an interface for querying settings by key. Add an implementation
    leveraging boost::property_tree to provide settings. (LP: #1362765)
  * Allow for enabling/disabling providers. Wire up engine state changes
    to enabling/disabling of providers. (LP: #1392399)

location-service (2.1+15.04.20150113~rtm-0ubuntu1) 14.09; urgency=low

  [ thomas-voss ]
  * Print details about visible space vehicles to the gps provider test
    case. (LP: #1408984)

location-service (2.1+15.04.20150106~rtm-0ubuntu1) 14.09; urgency=low

  [ thomas-voss ]
  * Fix #1394204 by: (LP: #1394204)

  [ Ubuntu daily release ]
  * New rebuild forced

location-service (2.1+15.04.20141110.1-0ubuntu1) vivid; urgency=low

  [ thomas-voss ]
  * Make sure that devices being added/removed by NetworkManager are
    handled correctly. (LP: #1390490)

location-service (2.1+15.04.20141105.1-0ubuntu1) vivid; urgency=low

  [ CI bot ]
  * Resync trunk

  [ Kevin DuBois ]
  * The headers shipped in libubuntu-location-service-...

Changed in location-service (Ubuntu):
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package location-service 2.1+15.04.20150529-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

location-service (2.1+15.04.20150529-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * Ensure that the trust store is started when is needed.

location-service (2.1+15.10.20150528.3-0ubuntu1) wily; urgency=medium

  [ Thomas Voß ]
  * Make sure we always hand a lock owning its mutex to
    on_access_point_added. (LP: #1426307)

location-service (2.1+15.04.20150427.1-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * Make sure that cached modems are considered as well when calculating
    connection characteristics.

location-service (2.1+15.04.20150424-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * Improve the selection of the bag of providers to ensure that the
    locations used are within a reasonable time margin.
  * Remove the pimpl implementation from the providers and hide their
    public headers because they should only be used within the project.

  [ Thomas Voß ]
  * Increase default timeout for downloading gps xtra data. (LP:
    #1447161)

location-service (2.1+15.04.20150417-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * If an exception is thrown from the io_executor run method it must be
    caught, logger and continued with the main loop.

 -- CI Train Bot <email address hidden> Fri, 29 May 2015 08:11:15 +0000

Changed in location-service (Ubuntu RTM):
status: Confirmed → Fix Released
Sayonara Player Team (lucioc) wrote :

Thanks for your work. Position can be determined after 2 minutes now without Nokia Here and without SIM card. Even when it's cloudy it's pretty accurate

Hi Lucio :)
Are you talking about the time that the GPS takes for get accuracy?
Please, could you confirm me if the "Sensor Status" app (from the Store)
works in the same way too?
Best regards and thanks in advance!

Sayonara Player Team (lucioc) wrote :

Hi, maybe I crowed to soon. I rebooted this morning and everything was the same. I always test with the Sensor Status app and an additional app I wrote by myself.

I don't get any data by the GPS sensor for about 10 minutes sometimes, sometimes no data at all. My 30€ mobile GPS device works fine. But when I got the GPS fix, the location data is updated very often and everything works as expected. The accuracy of the position is also perfect.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in location-service (Ubuntu Vivid):
status: New → Confirmed
Sayonara Player Team (lucioc) wrote :

The bug is not reproducable for me anymore (using rc-proposed r37). So thanks for your work

Sayonara Player Team (lucioc) wrote :

I just figured out that GPS is working perfectly in Portugal and Spain but not in Germany. Mobile data connection and wifi are completely turned off and location is available after 10-30 seconds. In Germany there is no location available at all. Maybe it depends on the mobile provider, maybe on the different time zone. Is there a way to check how many satellites can be contacted? And what the phone is actually doing while searching for satellites? And especially where. I am using stable release r8.

Hi Lucio :)
Did you try it in Portugal and it worked fine and it is not working in
Germany?
Could you try the app Sensor Status and give me the feedback? It will tell
you about the accuracy.
I think there is not more information available abaout satellites :(
Best regards

--
Sent using Dekko from my Ubuntu device

wdoekes (walter+ubuntu) wrote :

I've never had GPS location work without the HERE functions enabled. As soon as I disable it (I have to restart for a change to take effect) I get *no* location info whatsoever. (I have waited for weeks to get a GPS lock, to no avail.)

The SensorsStatus tool tells me (when HERE is enabled) that I only have Horizontal accuracy, and that drifts between 8m and 250m.

Location: Netherlands
SIMs/network: dual sim and lots of wifi around
Version: latest Ubuntu 15.04 r24 (20150713) on the Aquaris BQ 4.5

Sayonara Player Team (lucioc) wrote :

Hi Costales,

Yes, it's working perfectly in Portugal/Spain but not in Germany. Even if I get some fix sometimes it's lost 5min later. The accuracy in Portugal drifts between 2m and 20m. In Germany there's no data at all visible in this app.
I don't accept it to use a service like Nokia's HERE, because in the mountains e.g. there is no wifi. My wifi is usually turned off if I'm not at home, in order to save battery. And as I see here, I don't even need it.

I think it's neccessary to create the possibility to see some debug output. Another way to improve this function might be the possibility to enter the rough position in order to find satellites faster.

Greetings, Lucio

Hi Lucio,

> Yes, it's working perfectly in Portugal/Spain but not in Germany.

A big location change could take a lot of time, the same as the first app
startup. Could you leave it near to a window or in the car without movement?

>
> The accuracy in Portugal drifts between 2m and 20m.

Yes, 2,5m is the best possible for a mobile GPS.

>
> In Germany there's no data at all visible in this app.

It's weird :( The 26% of users are from Germany and no body reported this.

>
> I don't accept it to use a service like Nokia's HERE

Do you have the Nokia HERE disabled? You have to enable it :( It's the
unique way the GPS will work.
Could be this the origin of the problem?

>
> I think it's neccessary to create the possibility to see some debug
> output. Another way to improve this function might be the possibility to
> enter the rough position in order to find satellites faster.

Yes, I need to think in something about current GPS data :)

>
> Greetings, Lucio

Best regards and thanks for your feedback!

donfranio (frank-scherrer) wrote :

Hi there,

I can also confirm: WiFi on, Nokia HERE on, no location data received in normal Apps or "SensorStatus".
What can I do?

Does someone still need some debugging Data?

cheers
Frank

Thomas Voß (thomas-voss) wrote :

Not right now, thanks for the offer, though. We have plenty of debug data and walk through the issues one by one. I will post updates and further bugs here to keep people up to date.

Hi, since I have returned to Germany, GPS is working worse than in Spain
and Portugal.
In cities ok (if you have time to sit down and wait between 5 and 10
minutes). But in rural areas where no wifi is available you have no chance.
And those are the places where you really need GPS for hiking or bike
tours.
Btw, what happened to the Nokia Here dialog in ota 6? I cannot find it
anymore. See attachment.

Regards, Lucio

On Monday, 28 September 2015 16:04:01 CEST, donfranio wrote:
> Hi there,
>
> I can also confirm: WiFi on, Nokia HERE on, no location data
> received in normal Apps or "SensorStatus".
> What can I do?
>
> Does someone still need some debugging Data?
>
> cheers
> Frank
>

--
Sent using Dekko from my Ubuntu device

Sayonara Player Team (lucioc) wrote :

And yes, we definitly need debug output

On Monday, 28 September 2015 16:04:01 CEST, donfranio wrote:
> Hi there,
>
> I can also confirm: WiFi on, Nokia HERE on, no location data
> received in normal Apps or "SensorStatus".
> What can I do?
>
> Does someone still need some debugging Data?
>
> cheers
> Frank
>

--
Sent using Dekko from my Ubuntu device

Oliver Grawert (ogra) wrote :

@lucio, are you sure you are using the official stable (or rc-proposed) channel for your device ? note that the dialog (and the HERE backend) is only available in the right channels (i.e. the ones that get shipped on the devices with a paid license), it is not in the community builds (i.e. the /ubuntu channels) ....

i see the option on both, MX4 and Aquaris 4.5 on rc-proposed

Hello Oliver,
I am not using the krillin stable channel, if you meant that. I once ran
into a endless reboot loop and I had to flash again. Since then I have
been using the ota-releases (currently r9). Before that I had real
problems with GPS and after that I immediatly went to Poortugal and
Spain and everything worked really really great. In Germany it does not.
In the cities ok, but not in rural areas. I am an outdoor fan and the
GPS simply does not work there. Maybe I get a location fix there. But
after screenlock turns on it's like roulette if I'd ever be able to get
a fix again...

I don't wanna troll here or play the angry-man but I made the experience
that with a Garmin or Android device it is working without Wifi and/or
SIM card. Even the BQ Aquaris 4.5 I am using works with Android. And I
just feel betrayed that I bought the Ubuntu version of a phone and the
only sensor that is working reliably is the accelerometer.

I am a developer and Linux enthusiast, too. This is the reason because I
bought this phone. And I just wanna share my experience with the
developer in order to help him increasing the qos. But I could do better
if I'd know how to get debug output or if there'd be a lower level
possibility instead of QML to gather information about the GPS device.

Greetings, Lucio

On 09/28/2015 05:47 PM, Oliver Grawert wrote:
> @lucio, are you sure you are using the official stable (or rc-proposed)
> channel for your device ? note that the dialog (and the HERE backend) is
> only available in the right channels (i.e. the ones that get shipped on
> the devices with a paid license), it is not in the community builds
> (i.e. the /ubuntu channels) ....
>
> i see the option on both, MX4 and Aquaris 4.5 on rc-proposed
>

Oliver Grawert (ogra) wrote :

@lucio i only was commenting on the screenshot, the only way to end up without the "HERE" option there is if you flashed a community image instead of the stable or rc-proposed one. this UI option is tied directly to the existence of the HERE AGPS backend existing on disk, if this is not there you are likely only using plain GPS for location detection. (note that the HERE app is completely separate from this issue)

Nelux (manolollr) wrote :

Sorry for my poor English.

There is a way to view Satellite information.

https://wiki.ubuntu.com/Process/Merges/TestPlan/location-service#Forensics

Execute this command in terminal

ubuntu-location-serviced-cli --bus system --get --property visible_space_vehicles

Visible space vehicles:
 (type: gps, prn: 5, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 41 deg, elevation: 186 deg)
 (type: gps, prn: 13, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 74 deg, elevation: 24 deg)
 (type: gps, prn: 15, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 50 deg, elevation: 310 deg)
 (type: gps, prn: 17, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 8 deg, elevation: 119 deg)
 (type: gps, prn: 18, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 8 deg, elevation: 321 deg)
 (type: gps, prn: 19, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 6 deg, elevation: 58 deg)
 (type: gps, prn: 20, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 52 deg, elevation: 267 deg)
 (type: gps, prn: 21, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 5 deg, elevation: 297 deg)
 (type: gps, prn: 24, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 23 deg, elevation: 257 deg)
 (type: gps, prn: 28, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 51 deg, elevation: 67 deg)
 (type: gps, prn: 30, snr: 0, has_almanac_data: 0, has_ephimeris_data: 0, used_in_fix: 0, azimuth: 24 deg, elevation: 57 deg)

I think snr: 0 is the signal range. I'm in home, so all satellites have signal 0, but almost I can view satellite information.

If I disable Here positioning the command output is always empty:

Visible space vehicles:
<empty>

So it seems aGps is performed by Here. Without aGps it takes about 10-20 minutes to fix. My old Android Samgung Galaxy S+ without Wifi nor Sim takes this time to fix.

Is it possible to use information from the command in apps to show total/used in fix satellites? It would very good.

Thomas Voß (thomas-voss) wrote :

You want to track https://bugs.launchpad.net/ubuntu/+source/location-service/+bug/1448180. The fix will surface satellite visibility information to applications.

Thomas Voß (thomas-voss) wrote :

Also note that the cli output is currently broken for the has_* and used_* flags due to https://bugs.launchpad.net/ubuntu/+source/location-service/+bug/1453661

Sayonara Player Team (lucioc) wrote :

Thank you for your work. You did a great job. Location detection is super fast and accurate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers