Not yet available but configured providers should be added as soon as they become available

Bug #1415029 reported by Thomas Voß on 2015-01-27
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
location-service (Ubuntu)
Critical
Thomas Voß
ubuntu-location-provider-here (Ubuntu)
High
Loïc Minier
ubuntu-location-provider-here (Ubuntu RTM)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Right now, the location service tries to instantiate configured providers at startup. In specific corner cases, some of the configured sensors might not be available and the service should be able to be notified when those providers become available.

In particular, this affects the wizard running on first boot, and subsequent login to the user session.

Related branches

description: updated
Changed in location-service (Ubuntu):
importance: Undecided → Critical
Loïc Minier (lool) on 2015-01-27
Changed in ubuntu-location-provider-here (Ubuntu):
assignee: nobody → Loïc Minier (lool)
status: New → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-location-provider-here - 0.1+15.04.20150127~rtm-0ubuntu1

---------------
ubuntu-location-provider-here (0.1+15.04.20150127~rtm-0ubuntu1) 14.09; urgency=low

  [ Loïc Minier ]
  * Sleep 5 and restart ubuntu-location-service after starting HERE
    stack when wizard completes; lets location-service pick up the new
    provider; LP: #1415029. (LP: #1415029)

  [ Ubuntu daily release ]
  * New rebuild forced

ubuntu-location-provider-here (0.1+15.04.20141110-0ubuntu1) vivid; urgency=low

  [ Loïc Minier ]
  * Wait for NM and oFono to be started before starting slpgwd due to a
    bug in location-service-connectivity API (LP 1390490); works around
    LP: #1389874. (LP: #1390490, #1389874)
 -- Ubuntu daily release <email address hidden> Tue, 27 Jan 2015 17:32:31 +0000

Changed in ubuntu-location-provider-here (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww09-2015
status: New → In Progress
Changed in canonical-devices-system-image:
assignee: nobody → Thomas Voß (thomas-voss)
John McAleely (john.mcaleely) wrote :

@tvoss, is this going to land this week for ww09 milestone?

John McAleely (john.mcaleely) wrote :

phablet@ubuntu-phablet:~$ dpkg -l | grep provider-here
ii ubuntu-location-provider-here 0.1+15.04.20150127~rtm-0ubuntu1 armhf HERE provider for the Ubuntu Location Service
phablet@ubuntu-phablet:~$ system-image-cli -i
current build number: 239
device name: krillin
channel: ubuntu-touch/ubuntu-rtm/14.09-proposed
last update: 2015-02-18 19:19:28
version version: 239
version ubuntu: 20150218
version device: 20150216-fe747ac
version custom: 20150216-561-29-186

Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Jonathan Cave (jocave) wrote :

Version: ubuntu-touch/stable/bq-aquaris.en r18 krillin

Just tried to switch to HERE supported location after having initially been set to GPS only. A reboot was required before the HERE app was able to find my location.

Pat McGowan (pat-mcgowan) wrote :

This fixed the wizard scenario but not when enabled in settings, will open a new bug.

Changed in canonical-devices-system-image:
status: Fix Released → Confirmed
Changed in ubuntu-location-provider-here (Ubuntu RTM):
status: Fix Released → Confirmed
Changed in canonical-devices-system-image:
milestone: ww09-2015 → ww11-2015
Pat McGowan (pat-mcgowan) wrote :

on second thought just reopened it

Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
milestone: ww11-2015 → ww13-2015
John McAleely (john.mcaleely) wrote :

@pat - is my understanding correct that the system-settings part you mention in #5 is fixed now in vivid?

Pat McGowan (pat-mcgowan) wrote :

I do not think the other scenario is fixed, assign to Bill t confirm

Changed in canonical-devices-system-image:
assignee: Thomas Voß (thomas-voss) → Bill Filler (bfiller)
Bill Filler (bfiller) on 2015-03-24
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Ken VanDine (ken-vandine) wrote :

@thomas-voss: Wouldn't it make more sense for the location-service to reload when it sees the property changes on accountsservice?

Thomas Voß (thomas-voss) wrote :

@ken-vandine: Sure, and we are already doing that for the wizard case. However, to make the overall solution more robust, we should be able to handle delayed/deferred providers flawlessly.

Ken VanDine (ken-vandine) wrote :

@thomas-voss: Sure, it should be robust, which is why I don't think system-settings should be restarting the service. It's one thing to do that at the end of the wizard upstart job, but we can't really do that during runtime.

Noemí (noemi-gallego) wrote :

Is there any posibility of this affecting google maps too?
It couln't determinate my position until I accepted the here conditions and rebooted the device.

Pat McGowan (pat-mcgowan) wrote :

Yes because if the Here provider is not loaded the only think available is gps which takes time to lock location. Anything on the system needing location is affected.

Bill Filler (bfiller) wrote :

marking system-settings task as invalid. The location-service should be monitoring for the signal and reloading when providers become ready

Changed in ubuntu-system-settings (Ubuntu):
status: New → Invalid
Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → Thomas Voß (thomas-voss)
Changed in ubuntu-system-settings (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in canonical-devices-system-image:
milestone: ww13-2015 → ww17-2015
Changed in canonical-devices-system-image:
milestone: ww17-2015 → ww18-2015
assignee: Thomas Voß (thomas-voss) → Canonical Phone Foundations (canonical-phonedations-team)
milestone: ww18-2015 → ww17-2015
milestone: ww17-2015 → ww18-2015
Changed in location-service (Ubuntu):
assignee: Thomas Voß (thomas-voss) → Manuel de la Peña (mandel)
Changed in canonical-devices-system-image:
milestone: ww18-2015 → ww22-2015
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package ubuntu-location-provider-here 0.1+15.04.20150529-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-location-provider-here (0.1+15.04.20150529-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * Empty commit to made the changes available for vivid.

ubuntu-location-provider-here (0.1+15.04.20150127~rtm-0ubuntu1) 14.09; urgency=low

  [ Loïc Minier ]
  * Sleep 5 and restart ubuntu-location-service after starting HERE
    stack when wizard completes; lets location-service pick up the new
    provider; LP: #1415029. (LP: #1415029)

  [ Ubuntu daily release ]
  * New rebuild forced

 -- CI Train Bot <email address hidden> Fri, 29 May 2015 08:11:27 +0000

Changed in ubuntu-location-provider-here (Ubuntu RTM):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-location-provider-here - 0.1+15.10.20150529-0ubuntu1

---------------
ubuntu-location-provider-here (0.1+15.10.20150529-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Manuel de la Pena ]
  * Empty commit to made the changes available for vivid.

ubuntu-location-provider-here (0.1+15.04.20150127~rtm-0ubuntu1) 14.09; urgency=low

  [ Loïc Minier ]
  * Sleep 5 and restart ubuntu-location-service after starting HERE
    stack when wizard completes; lets location-service pick up the new
    provider; LP: #1415029. (LP: #1415029)

  [ Ubuntu daily release ]
  * New rebuild forced

 -- CI Train Bot <email address hidden> Fri, 29 May 2015 08:11:27 +0000

Changed in ubuntu-location-provider-here (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: ww22-2015 → ww24-2015
Noemí (noemi-gallego) wrote :

It still reproduces on Vivid

Changed in canonical-devices-system-image:
milestone: ww24-2015 → ww28-2015
tags: added: location
Changed in canonical-devices-system-image:
assignee: Canonical Phone Foundations (canonical-phonedations-team) → John McAleely (john.mcaleely)
Changed in canonical-devices-system-image:
milestone: ww28-2015 → ww34-2015
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Thomas Voß (thomas-voss) wrote :

Okay, finally found time to revisit my previous patch. I think we should load providers asynchronously on service startup. With that, configured providers are just hints to the underlying machinery, and loading/announcement of providers ready for consumption is executed on a different thread.

Changed in location-service (Ubuntu):
assignee: Manuel de la Peña (mandel) → Thomas Voß (thomas-voss)
Pat McGowan (pat-mcgowan) wrote :

assuming this didnt land

Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016

I confirm it is not fixed in OTA8

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers