Please merge loadlin 1.6c.really1.6c.nobin-1 (universe) from Debian unstable (main)

Bug #295811 reported by Nathan Handler
2
Affects Status Importance Assigned to Milestone
loadlin (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Binary package hint: loadlin

Debian has a new version which needs to be merged.

 loadlin (1.6c.really1.6c.nobin-1) unstable; urgency=low

   * New maintainer. (closes: #487338)
   * Remove loadlin.exe and src/pgadjust.asm binary blobs.
   * Refactor debian/rules. (closes: #437484)
   * Add build-dependency on debhelper, cdbs and quilt
   * patches/10-setupfix.patch: New patch to extend max number of setup sectors
   to 40 to fix booting C setup.
   * patches/20-dynamic.patch and patch-srclinux: New patches to load pgadjust
   table in high memory too. (closes: #469533)
   * patches/30-yasm.patch: New patch to build loadlin.exe with yasm.
   (closes: #356055)
   * Add build-dependency on yasm (>= 0.7.0-2) for its TASM support.
   * debian/copyright: Add copyright information.
   * debian/control:
     + Set policy to 3.8.0.
     + Set DM-Upload-Allowed to yes.

 -- Samuel Thibault <email address hidden> Mon, 13 Oct 2008 01:57:45 +0200

Tags: merge

Related branches

Changed in loadlin:
assignee: nobody → nhandler
importance: Undecided → Wishlist
status: New → In Progress
Revision history for this message
Nathan Handler (nhandler) wrote :
Download full text (12.8 KiB)

loadin fails to build from source.

I: using fakeroot in build.
Current time: Mon Nov 24 16:30:07 CST 2008
pbuilder-time-stamp: 1227565807
Building the build Environment
 -> extracting base tarball [/var/cache/pbuilder/base.tgz]
 -> creating local configuration
 -> copying local configuration
 -> mounting /proc filesystem
 -> mounting /dev/pts filesystem
 -> policy-rc.d already exists
Obtaining the cached apt archive contents
Installing the build-deps
 -> Attempting to satisfy build-dependencies
 -> Creating pbuilder-satisfydepends-dummy package
Package: pbuilder-satisfydepends-dummy
Version: 0.invalid.0
Architecture: i386
Maintainer: Debian Pbuilder Team <email address hidden>
Description: Dummy package to satisfy dependencies with aptitude - created by pbuilder
 This package was created automatically by pbuilder and should
Depends: debhelper, cdbs, quilt, zip, yasm (>= 0.7.0-3)
dpkg-deb: building package `pbuilder-satisfydepends-dummy' in `/tmp/satisfydepends-aptitude/pbuilder-satisfydepends-dummy.deb'.
Reading package lists...
Building dependency tree...
Reading state information...
aptitude is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Selecting previously deselected package pbuilder-satisfydepends-dummy.
(Reading database ... 10484 files and directories currently installed.)
Unpacking pbuilder-satisfydepends-dummy (from .../pbuilder-satisfydepends-dummy.deb) ...
dpkg: dependency problems prevent configuration of pbuilder-satisfydepends-dummy:
 pbuilder-satisfydepends-dummy depends on debhelper; however:
  Package debhelper is not installed.
 pbuilder-satisfydepends-dummy depends on cdbs; however:
  Package cdbs is not installed.
 pbuilder-satisfydepends-dummy depends on quilt; however:
  Package quilt is not installed.
 pbuilder-satisfydepends-dummy depends on zip; however:
  Package zip is not installed.
 pbuilder-satisfydepends-dummy depends on yasm (>= 0.7.0-3); however:
  Package yasm is not installed.
dpkg: error processing pbuilder-satisfydepends-dummy (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pbuilder-satisfydepends-dummy
Reading package lists...
Building dependency tree...
Reading state information...
Initializing package states...
Writing extended state information...
The following NEW packages will be installed:
  autoconf{a} automake1.7{a} autotools-dev{a} bsdmainutils{a} cdbs{a}
  debhelper{a} diffstat{a} fdupes{a} file{a} gettext{a} gettext-base{a}
  groff-base{a} html2text{a} intltool{a} intltool-debian{a} libexpat1{a}
  libhtml-parser-perl{a} libhtml-tagset-perl{a} libhtml-tree-perl{a}
  libmagic1{a} liburi-perl{a} libwww-perl{a} libxml-parser-perl{a} m4{a}
  man-db{a} po-debconf{a} quilt{a} yasm{a} zip{a}
The following partially installed packages will be configured:
  pbuilder-satisfydepends-dummy
0 packages upgraded, 29 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/9538kB of archives. After unpacking 30.9MB will be used.
Writing extended state information...
debconf: delaying package configuration, since apt-ut...

Changed in loadlin:
assignee: nhandler → nobody
status: In Progress → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package loadlin - 1.6c.really1.6c.nobin-1ubuntu1

---------------
loadlin (1.6c.really1.6c.nobin-1ubuntu1) jaunty; urgency=low

  * Merge from Debian unstable (LP: #295811), remaining Ubuntu changes:
    - debian/rules: Remove 'dpkg-distaddfile $(loadlin_zip).zip
      byhand -' so that the package gets uploaded properly.
  * Build-depend against yasm (>= 0.7.1-0ubuntu2) for TASM support.
  * Fix FTBFS with Ubuntu toolchain:
    - debian/patch-stack_protector: make put_hex function static.
    - debian/rules: apply debian/patch-stack_protector patch.

loadlin (1.6c.really1.6c.nobin-1) unstable; urgency=low

  * New maintainer. (closes: #487338)
  * Remove loadlin.exe and src/pgadjust.asm binary blobs.
  * Refactor debian/rules. (closes: #437484)
  * Add build-dependency on debhelper, cdbs and quilt
  * patches/10-setupfix.patch: New patch to extend max number of setup sectors
  to 40 to fix booting C setup.
  * patches/20-dynamic.patch and patch-srclinux: New patches to load pgadjust
  table in high memory too. (closes: #469533)
  * patches/30-yasm.patch: New patch to build loadlin.exe with yasm.
  (closes: #356055)
  * Add build-dependency on yasm (>= 0.7.0-2) for its TASM support.
  * debian/copyright: Add copyright information.
  * debian/control:
    + Set policy to 3.8.0.
    + Set DM-Upload-Allowed to yes.

 -- Luca Falavigna <email address hidden> Tue, 25 Nov 2008 19:18:20 +0100

Changed in loadlin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers