The USE_TYPO_METRICS flag is not set in the OS/2 table of Latin Modern Math

Bug #1502701 reported by Fred-wang on 2015-10-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lmodern (Debian)
Fix Released
Unknown
lmodern (Ubuntu)
Undecided
Unassigned

Bug Description

Dear Maintainer,

lmodern contains version 1.950 of the modern font. In this version, the USE_TYPO_METRICS flag is not set in the OS/2 table of Latin Modern Math, which can lead to excessive line spacing. See http://www.microsoft.com/typography/otspec/os2.htm#fss

This bug is fixed upstream, please upgrade to version 1.959:
http://www.gust.org.pl/gustnews/news02-05-10-2014en

This bug is also fixed in Debian:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=799731

[ Rationale: Starting with Gecko 31, the typo metrics are used when either USE_TYPO_METRICS is set or the font contains a MATH table. However, starting with Gecko 43, it will only be used when USE_TYPO_METRICS is explicitly set:
https://bugzilla.mozilla.org/show_bug.cgi?id=947650#c0
https://bugzilla.mozilla.org/show_bug.cgi?id=1170782
https://bugzilla.mozilla.org/show_bug.cgi?id=1208776#user_story_readonly ]

Changed in lmodern (Debian):
status: Unknown → Fix Released
Fred-wang (fred-wang) wrote :

FYI, more people reported this issue when reading Wikipedia pages on Ubuntu:

https://bugzilla.mozilla.org/show_bug.cgi?id=1220465#c2
https://phabricator.wikimedia.org/T122400

Jérôme Kunegis (kunegis) wrote :

I managed to fix the bug by hand on my Ubuntu installation by doing the following:

* Download the latest version of the Latin Modern Math font from http://www.gust.org.pl/projects/e-foundry/lm-math
* You get a zipfile, unpack it. It contains documentation and a file 'latinmodern-math.otf'. Copy that file to ~/.fonts (which you must create if it doesn't exist yet)
* Restart Firefox

I'm using:
Ubuntu 14.04
Firefox 43.0
The MathML-fonts 2.1.1-signed plugin in Firefox
The MathML Font Settings 0.2.1-signed plugin in Firefox

Jérôme

David Venhoek (t-dav0d-a) wrote :

I can attest that this is (as of 29-06-2016) still an issue, and it makes mathematical reference material such as http://dlmf.nist.gov/10.6 somewhat annoying to read. a fix would be highly appreciated

For reference, this is on Ubuntu 14.04.4 LTS

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lmodern (Ubuntu):
status: New → Confirmed
Mateus Araújo (iris-n) wrote :

This bug is fixed from Xenial onwards. I changed the status to Fix Released.

Changed in lmodern (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.