fancontrol should have debconf prompt to run pwmconfig

Bug #884177 reported by Lars Noodén on 2011-10-31
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
lm-sensors (Ubuntu)
High
Unassigned

Bug Description

The fancontrol package needs to be cofigured before it works. This is somewhat automated by pwmconfig. The package should prompt and run pwmconfig for you when installed.

Lars Noodén (larsnooden) wrote :

It appears that the configuration file is missing.

$ ls /etc/fancontrol
ls: cannot access /etc/fancontrol: No such file or directory

Lars Noodén (larsnooden) wrote :

$ dpkg -L fancontrol
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/fancontrol
/usr/share/doc/fancontrol/copyright
/usr/share/doc/fancontrol/fancontrol.txt.gz
/usr/share/doc/fancontrol/changelog.Debian.gz
/usr/share/man
/usr/share/man/man8
/usr/share/man/man8/fancontrol.8.gz
/usr/share/man/man8/pwmconfig.8.gz
/usr/sbin
/usr/sbin/fancontrol
/usr/sbin/pwmconfig
/etc
/etc/init.d
/etc/init.d/fancontrol

Dave Walker (davewalker) on 2011-11-09
Changed in lm-sensors (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Lars Noodén (larsnooden) wrote :

Still present in Precise:

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

$ apt-cache policy fancontrol
fancontrol:
  Installed: (none)
  Candidate: 1:3.3.0-4ubuntu1
  Version table:
     1:3.3.0-4ubuntu1 0
        500 http://fi.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lm-sensors (Ubuntu Oneiric):
status: New → Confirmed
Aslakj (aslakj) wrote :

On an MacBookPro7,1 running oneiric.

$ sensors
applesmc-isa-0300
Adapter: ISA adapter
Exhaust : 0 RPM (min = 2000 RPM)
TB0T: +33.8°C
TB1T: +33.8°C
TB2T: +32.0°C
TC0D: +62.8°C
TC0P: +56.5°C
TN0D: +61.5°C
TN0P: +49.8°C
TN0S: +68.2°C
TN1D: +66.0°C
TN1F: +68.2°C
TN1G: +90.0°C
TN1S: +68.2°C
Th1H: +54.5°C
Ts0P: +32.8°C
Ts0S: +46.0°C

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +65.0°C (high = +105.0°C, crit = +105.0°C)
Core 1: +62.0°C (high = +105.0°C, crit = +105.0°C)

$ sudo /usr/sbin/pwmconfig
# pwmconfig revision 5857 (2010-08-22)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

$ sudo fancontrol
Loading configuration from /etc/fancontrol ...
Error: Can't read configuration file

$ ls -l /etc/fancontrol
ls: cannot access /etc/fancontrol: No such file or directory

Lars Noodén (larsnooden) wrote :

The problem is also present in Precise.

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

$ fancontrol
Loading configuration from /etc/fancontrol ...
Error: Can't read configuration file

$ apt-cache policy fancontrol
fancontrol:
  Installed: 1:3.3.0-4ubuntu1
  Candidate: 1:3.3.0-4ubuntu1
  Version table:
 *** 1:3.3.0-4ubuntu1 0
        500 http://fi.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Phillip Susi (psusi) wrote :

You must write a config file for it by hand or using pwmconfig.

no longer affects: lm-sensors (Ubuntu Oneiric)
no longer affects: lm-sensors (Ubuntu Precise)
Changed in lm-sensors (Ubuntu):
status: Confirmed → Invalid
Lars Noodén (larsnooden) wrote :

Can there be a config file included in the default install that contains such a message? A pointer is needed to the solution somehow.

Phillip Susi (psusi) wrote :

Config files don't contain messages, they configure fancontrol to work. Is the man page not sufficient?

I suppose the package could have a debconf question that prompts you to run pwmconfig when you install it...

summary: - fancontrol cannot read its own configuration file
+ fancontrol should have debconf prompt to run pwmconfig
Changed in lm-sensors (Ubuntu):
status: Invalid → Triaged
description: updated
Lars Noodén (larsnooden) wrote :

Could a post-install script ask to run pwmconfig and then run it if the answer is yes?

Phillip Susi (psusi) wrote :

Yes, that's exactly the idea.

userdce (userdce) wrote :

In precise:

sudo fancontrol
Loading configuration from /etc/fancontrol ...
Error: Can't read configuration file

Grzemach (grzemach) wrote :

any update on this bug?

Lars Noodén (larsnooden) wrote :

No change. It's still there in 13.10 and this version of fancontrol:

$ apt-cache policy fancontrol
fancontrol:
  Installed: 1:3.3.3-1ubuntu1
  Candidate: 1:3.3.3-1ubuntu1
  Version table:
 *** 1:3.3.3-1ubuntu1 0
        500 http://fi.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status

Still same on 17.10

fancontrol:
  Installed: 1:3.4.0-4
  Candidate: 1:3.4.0-4
  Version table:
 *** 1:3.4.0-4 500
        500 http://tr.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
        500 http://tr.archive.ubuntu.com/ubuntu artful/universe i386 Packages
        100 /var/lib/dpkg/status

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers