lm-sensors not working on Intel d945gclf

Bug #458811 reported by Jorge Suarez on 2009-10-23
104
This bug affects 21 people
Affects Status Importance Assigned to Milestone
lm-sensors-3 (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by Balaji
Nominated for Natty by Balaji

Bug Description

Just upgraded from 8.10, installed lm-sensors to get fancontrol, it's not working.

First I run sensors-detect:

# sensors-detect revision 5249 (2008-05-11 22:56:25 +0200)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

We can start with probing for (PCI) I2C or SMBus adapters.
Do you want to probe now? (YES/no):
Probing for PCI bus adapters...
Use driver `i2c-i801' for device 0000:00:1f.3: Intel 82801G ICH7

We will now try to load each adapter module in turn.
Module `i2c-i801' already loaded.
If you have undetectable or unsupported I2C/SMBus adapters, you can have
them scanned by manually loading the modules before running this script.

To continue, we need module `i2c-dev' to be loaded.
Do you want to load `i2c-dev' now? (YES/no):
Module loaded successfully.

We are now going to do the I2C/SMBus adapter probings. Some chips may
be double detected; we choose the one with the highest confidence
value in that case.
If you found that the adapter hung after probing a certain address,
you can specify that address to remain unprobed.

Next adapter: intel drm CRTDDC_A (i2c-0)
Do you want to scan it? (YES/no/selectively):

Next adapter: SMBus I801 adapter at 3000 (i2c-1)
Do you want to scan it? (YES/no/selectively):
Client found at address 0x2d
Handled by driver `smsc47m192' (already loaded), chip type `smsc47m192'
Client found at address 0x50
Probing for `Analog Devices ADM1033'... No
Probing for `Analog Devices ADM1034'... No
Probing for `SPD EEPROM'... Yes
    (confidence 8, not a hardware monitoring chip)
Probing for `EDID EEPROM'... No

Some chips are also accessible through the ISA I/O ports. We have to
write to arbitrary I/O ports to probe them. This is usually safe though.
Yes, you do have ISA I/O ports even if you do not have any ISA slots!
Do you want to scan the ISA I/O ports? (YES/no):
Probing for `National Semiconductor LM78' at 0x290... No
Probing for `National Semiconductor LM78-J' at 0x290... No
Probing for `National Semiconductor LM79' at 0x290... No
Probing for `Winbond W83781D' at 0x290... No
Probing for `Winbond W83782D' at 0x290... No
Probing for `IPMI BMC KCS' at 0xca0... No
Probing for `IPMI BMC SMIC' at 0xca8... No

Some Super I/O chips may also contain sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no):
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor'... No
Trying family `SMSC'... Yes
Found `SMSC LPC47M15x/192/997 Super IO Fan Sensors' Success!
    (address 0x680, driver `smsc47m1')
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor'... No
Trying family `SMSC'... No
Trying family `VIA/Winbond/Fintek'... No
Trying family `ITE'... No

Some south bridges, CPUs or memory controllers may also contain
embedded sensors. Do you want to scan for them? (YES/no):
Silicon Integrated Systems SIS5595... No
VIA VT82C686 Integrated Sensors... No
VIA VT8231 Integrated Sensors... No
AMD K8 thermal sensors... No
AMD K10 thermal sensors... No
Intel Core family thermal sensor... No
Intel AMB FB-DIMM thermal sensor... No

Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `smsc47m192' (should be inserted):
  Detects correctly:
  * Bus `SMBus I801 adapter at 3000'
    Busdriver `i2c-i801', I2C address 0x2d
    Chip `smsc47m192' (confidence: 6)

Driver `smsc47m1' (should be inserted):
  Detects correctly:
  * ISA bus, address 0x680
    Chip `SMSC LPC47M15x/192/997 Super IO Fan Sensors' (confidence: 9)

I will now generate the commands needed to load the required modules.
Just press ENTER to continue:

To load everything that is needed, add this to /etc/modules:

#----cut here----
# I2C adapter drivers
i2c-i801
# Chip drivers
smsc47m192
smsc47m1
#----cut here----

Do you want to add these lines automatically? (yes/NO)yes

Correct sensors are detected, so I modprobe the required modules:

andres@server1:~$ sudo modprobe i2c-i801
andres@server1:~$ sudo modprobe smsc47m192
andres@server1:~$ sudo modprobe smsc47m1
FATAL: Error inserting smsc47m1 (/lib/modules/2.6.31-14-generic-pae/kernel/drivers/hwmon/smsc47m1.ko): Device or resource busy

Tail syslog:

Oct 23 03:32:21 server1 kernel: [ 1074.936062] i2c /dev entries driver
Oct 23 03:33:32 server1 kernel: [ 1146.597922] smsc47m1: Found SMSC LPC47M15x/LPC47M192/LPC47M997
Oct 23 03:33:32 server1 kernel: [ 1146.597987] ACPI: I/O resource smsc47m1 [0x680-0x6ff] conflicts with ACPI region RUNT [0x680-0x6ff]
Oct 23 03:33:32 server1 kernel: [ 1146.598033] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

Seems to be acpi related. My kernel:
$ uname -ra
Linux server1 2.6.31-14-generic-pae #48-Ubuntu SMP Fri Oct 16 15:22:42 UTC 2009 i686 GNU/Linux

ProblemType: Bug
Architecture: i386
Date: Fri Oct 23 01:28:38 2009
DistroRelease: Ubuntu 9.10
Package: lm-sensors 1:3.0.2-2ubuntu4
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
SourcePackage: lm-sensors-3
Uname: Linux 2.6.31-14-generic-pae i686

Jorge Suarez (andres-430) wrote :
COMRADE_ARTYOM (ua2fga) wrote :

Try to append acpi_enforce_resources=lax to your "kernel" line in /boot/grub/menu.lst, and reboot. That worked for me.
(this advice was found here: http://bbs.archlinux.org/viewtopic.php?pid=645833)

Darko Surjan (dsurjan) wrote :

I can confirm the same problem with Intel D945GCLF2 motherboard and 2.6.31-14-generic kernel. I added
acpi_enforce_resources=lax to defoptions line in /boot/grub/menu.lst, run update-grub, rebooted the system and sensors works fine now.

MarkG (movieman523) wrote :

Same here: D945GCLF2, just upgraded from Ubuntu 9.04 to 9.10 and the sensors stopped working.

roemer2201 (roemer2201) wrote :

acpi_enforce_resources=lax works fine for me on D945GCLF2.

But i may want to add another bug:
After an uncertain amount of time the temperature get stuck. It works, if i restart the computer, but after some minutes it stucks again...
Can someone confirm this behaviour?

Wil Clouser (clouserw) wrote :

Information about this bug (and why that boot flag fixes it) is at http://www.lm-sensors.org/wiki/FAQ/Chapter3#Mysensorshavestoppedworkinginkernel2.6.31

They suggest adding that boot flag is a dangerous and unpredictable option.

Ron W6FM (w6fm) wrote :

So this is a feature and not a bug ;-> I have an Intel D850GB and I am affected as well. I am not concerned about the bios writing to the pwm control for the fan. There are three different hardware sensors on the board and it appears that the bios does not use any of them. I think the hardware engineers got a bit ahead of the game. Adding the boot flag allowed me to load the smsc47m1 module and I have my fan control back. Cheers!

Erhard Härtel (erhard-haertel) wrote :

after upgrade from UBUNTU 9.04 to UBUNTU 10.04 no function of lm-sensors and fancontrol. It worked perfectly with 9.04.
Motherboard D945GCLF2 with Intel ATOM 330.

Guillem (guillemsola) wrote :

anyone knows where we should report this? maybe somewhere at Intel?
I understand that disabling that acpi check is a bad option and that the driver is not well designed.

Ron O (ronouel) wrote :

LM Sensors addresses some of this if you can navigate their site and then figure out what they are talking about. . If you join their mailing list, your inbox will be swamped with notes and code that will really make you ask "what are they talking about?" Good luck. http://lists.lm-sensors.org/mailman/listinfo/

Changed in lm-sensors-3 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers