Comment 4 for bug 1387011

In , Dfarler (dfarler) wrote :

Following the instructions at http://llvm.org/docs/CMake.html#embedding-llvm-in-your-project , a simple CMakeLists.txt fails immediately with LLVM 3.5.0 or 3.6.0svn installed at /usr/local, at "find_package(LLVM REQUIRED CONFIG)"

CMake Error at /usr/local/Cellar/llvm/HEAD/share/llvm/cmake/LLVMExports.cmake:6 (set_property):
  set_property could not find TARGET LLVMSupport. Perhaps it has not yet
  been created.
Call Stack (most recent call first):
  /usr/local/share/llvm/cmake/LLVMConfig.cmake:50 (include)
  CMakeLists.txt:4 (find_package)

similarly for all set_property calls in LLVMExports.cmake.

This fails for CMake 2.8- and 3.0 series.