clang and clang++ are missing on update

Bug #1420570 reported by Leo Davis on 2015-02-11
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
llvm-toolchain-snapshot (Ubuntu)
Undecided
Unassigned

Bug Description

When I upgraded clang 3.5 yesterday, /usr/bin/clang and /usr/bin/clang++ (at least) that were clang 3.5 binaries are no longer installed.

These are the clang packages I have installed:

ii clang-3.5 1:3.5-4ubuntu2~trusty1 amd64 C, C++ and Objective-C compiler (LLVM based)
ii clang-3.5-doc 1:3.5-4ubuntu2~trusty1 all C, C++ and Objective-C compiler (LLVM based) - Documentation
ii clang-format-3.5 1:3.5-4ubuntu2~trusty1 amd64 Tool to format C/C++/Obj-C code
ii libclang-common-3.4-dev 1:3.4-1ubuntu3 amd64 clang library - Common development package
ii libclang-common-3.5-dev 1:3.5-4ubuntu2~trusty1 amd64 clang library - Common development package
ii libclang1-3.4:amd64 1:3.4-1ubuntu3 amd64 C interface to the clang library
ii libclang1-3.5:amd64 1:3.5-4ubuntu2~trusty1 amd64 C interface to the clang library

These are the llvm packages I have installed:

ii libllvm3.4:amd64 1:3.4-1ubuntu3 amd64 Modular compiler and toolchain technologies, runtime library
ii libllvm3.5:amd64 1:3.5-4ubuntu2~trusty1 amd64 Modular compiler and toolchain technologies, runtime library
ii llvm-3.4 1:3.4-1ubuntu3 amd64 Modular compiler and toolchain technologies
ii llvm-3.4-dev 1:3.4-1ubuntu3 amd64 Modular compiler and toolchain technologies, libraries and headers
ii llvm-3.4-runtime 1:3.4-1ubuntu3 amd64 Modular compiler and toolchain technologies, IR interpreter
ii llvm-3.5 1:3.5-4ubuntu2~trusty1 amd64 Modular compiler and toolchain technologies
ii llvm-3.5-dev 1:3.5-4ubuntu2~trusty1 amd64 Modular compiler and toolchain technologies, libraries and headers
ii llvm-3.5-runtime 1:3.5-4ubuntu2~trusty1 amd64 Modular compiler and toolchain technologies, IR interpreter

The /usr/bin/clang-3.5 and /usr/bin/clang++-3.5 binaries are installed (and seem to work OK):

$ clang-3.5 --version
Ubuntu clang version 3.5.0-4ubuntu2~trusty1 (tags/RELEASE_350/final) (based on LLVM 3.5.0)
Target: x86_64-pc-linux-gnu
Thread model: posix

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in llvm-toolchain-snapshot (Ubuntu):
status: New → Confirmed
Leo Davis (leo-davis) wrote :

Still missing even after today's clang package update.

ii clang-3.5 1:3.5-4ubuntu2~trusty2 amd64 C, C++ and Objective-C compiler (LLVM based)

Matthias Klose (doko) wrote :

packages are not updated to new releases in stable Ubuntu releases

Changed in llvm-toolchain-snapshot (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers