package libomp5-7 1:7.0.1-4 failed to install/upgrade: trying to overwrite shared '/usr/lib/llvm-7/lib/libomp-7.so.5', which is different from other instances of package libomp5-7:i386

Bug #1813162 reported by dezi on 2019-01-24

This bug report will be marked for expiration in 44 days if no further activity occurs. (find out why)

14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
llvm-toolchain-7 (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu 19.04

ProblemType: Package
DistroRelease: Ubuntu 19.04
Package: libomp5-7 1:7.0.1-4
ProcVersionSignature: Ubuntu 4.19.0-11.12-generic 4.19.16
Uname: Linux 4.19.0-11-generic x86_64
NonfreeKernelModules: sep5 socperf3 pax nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu19
Architecture: amd64
Date: Wed Jan 23 23:23:43 2019
Dependencies:
 gcc-8-base 8.2.0-14ubuntu1
 libc6 2.28-0ubuntu1
 libgcc1 1:8.2.0-14ubuntu1
 libidn2-0 2.0.5-1
 libunistring2 0.9.10-1ubuntu1
DuplicateSignature:
 package:libomp5-7:1:7.0.1-4
 Unpacking libmkl-core:i386 (2019.1.144-3) ...
 dpkg: error processing archive /tmp/apt-dpkg-install-20EQGy/59-libmkl-core_2019.1.144-3_i386.deb (--unpack):
  trying to overwrite shared '/usr/share/doc/libmkl-core/changelog.Debian.gz', which is different from other instances of package libmkl-core:i386
ErrorMessage: trying to overwrite shared '/usr/lib/llvm-7/lib/libomp-7.so.5', which is different from other instances of package libomp5-7:i386
InstallationDate: Installed on 2019-01-23 (0 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190120)
Python3Details: /usr/bin/python3.7, Python 3.7.2, python3-minimal, 3.7.2-1
PythonDetails: /usr/bin/python2.7, Python 2.7.15+, python-minimal, 2.7.15-4
RelatedPackageVersions:
 dpkg 1.19.2ubuntu2
 apt 1.8.0~beta1
SourcePackage: llvm-toolchain-7
Title: package libomp5-7 1:7.0.1-4 failed to install/upgrade: trying to overwrite shared '/usr/lib/llvm-7/lib/libomp-7.so.5', which is different from other instances of package libomp5-7:i386
UpgradeStatus: No upgrade log present (probably fresh install)

dezi (slavslav2019) wrote :
tags: removed: need-duplicate-check
Sylvestre Ledru (sylvestre) wrote :

The lib isn't multiarch ready. Patches welcome

how could you install both amd64 and i386 if the package is not marked as multi-arch ready?
looks like not a bug to me...
(making it multiarch might be considered a feature request, but for sure this apt error is not something you can have with stuff in the archive and normal apt commands)

Changed in llvm-toolchain-7 (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers